Jump to content
Sign in to follow this  
P Retondo

Stretch 3D object bug fix??

Recommended Posts

Does anyone know the status of a fix for the following version 9 bug reported earlier in these forums: stretching a 3D object by its center handle gives an erroneous result?

This is the most serious bug I've seen reported, and I have not seen anyone from NNA acknowledge it.

By the way, this error seems to result only when stretching up or down (relative to the screen), not side to side. Further, it is inconsistent - the error is likely to be different when redoing the exact same operation. Try this test: extrude a 2" wide x 6" high rectangle. Place an 8" high rectangle beside it, and attempt to stretch the solid using the bottom or top center handle to the 8" dimension. Redo this several times. The results I get for the y dimension of the solid were as follows: 8.17", 8", 8.084", 8.348", 8", 8", 8.17", ... . Note there is some kind of quantum effect here, perhaps related to pixel size. This behavior seems to be affected also by zoom factor and whether "constraint to grid" is selected. To get the craziest results, do not constrain to grid.

VW 9.0.1

Win 2000

PII 333/192

[This message has been edited by P Retondo (edited 10-04-2001).]

Share this post


Link to post

The only bug I can find which remotely resembles this has to do with resizing an extrude by using the tab key to adjust values in the mode bar.

According to our records, a fix was put in 9.0.1b3. So it should be working correctly in the final release of 9.0.1.

Please let me know if you can reproduce the problem in 9.0.1 and I will have Steve give it another look. I could not get it to reproduce myself in either 9.0.1 or the current 9.5 build.

If you want to call or write directly, this bug is on record as #20304 and #22011.

Matthew Giampapa

Technical Support

quote:

Originally posted by P Retondo:

Does anyone know the status of a fix for the following version 9 bug reported earlier in these forums: stretching a 3D object by its center handle gives an erroneous result?

This is the most serious bug I've seen reported, and I have not seen anyone from NNA acknowledge it.

By the way, this error seems to result only when stretching up or down (relative to the screen), not side to side. Further, it is inconsistent - the error is likely to be different when redoing the exact same operation. Try this test: extrude a 2" wide x 6" high rectangle. Place an 8" high rectangle beside it, and attempt to stretch the solid using the bottom or top center handle to the 8" dimension. Redo this several times. The results I get for the y dimension of the solid were as follows: 8.17", 8", 8.084", 8.348", 8", 8", 8.17", ... . Note there is some kind of quantum effect here, perhaps related to pixel size. This behavior seems to be affected also by zoom factor and whether "constraint to grid" is selected. To get the craziest results, do not constrain to grid.

VW 9.0.1

Win 2000

PII 333/192

[This message has been edited by P Retondo (edited 10-04-2001).]

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...