Jump to content
Sign in to follow this  
mmyoung

hidden line rendering - faceting

Recommended Posts

When I render in wireframe, arcs are fairly smooth. In hidden line, they are faceted (see attached).

If I use hidden line as foreground rendering in a viewport, it looks terrible.

It seems like I figured this out once before,

but I'm stumped now.

How do you get the facets out of a hidden line render?

I have Custom Renderworks Options/Geometry set to Very High curve detail.

Share this post


Link to post

Have you tried setting the smoothing angle in the hidden line render options to 20(ish). (I've found the sweet spot is usually between 15 to 30)

Share this post


Link to post

Line Render Options, as I recall, also needed to be adjusted. Or was it alternatively? High conversion resolution slows down pretty much everything.

Share this post


Link to post

That's true! It will slow down the render.

The smoothing angle affects the curve in its surface. Removing the lines that will draw in it: 18 deg. is ok for most cases. But the resolution of the geometry for curves is affected by 3d conversion resolution (and this affects hidden line rendering, and his brothers: Dashed and polygon renders).

I think Vw should handle this by object and not globally. Control object curve resolution via object info and with a number.

Share this post


Link to post

The file I had a problem with (above) is buggered... looks like it didn't make it across the divide from 2009 to 2010.

*However*, this thread made me drill more deeply into resolution issues.

Something does appear to be wrong here ? or at least I am getting reproducible errors on this machine (see attached PDF and VWX):

I generated the objects like this:

- 26' circle

- Offset & duplicate inside 6"

- Trim above the centerline, as shown.

- Select everything and Compose.

- Extrude 24"

- Modify / Rotate / Rotate Left 90? to erect it upright.

- Set to perspective view and adjust with Translate View tool.

- Render in Custom Renderworks (Sht-4 in attached PDF); options for curve detail Very High and in Hidden Line with Line Render Options / Smoothing Angle set to 0?.

The rings behind the arch were made the same way, duplicated upward using Move by Points.

The model renders nicely in the Design Layer.

** BUT when I make a viewport (Sht-1, Sht-2, and Sht-3), Custom RW and Final Quality RW both render an obviously faceted profile!

You can treat this somewhat by making a Foreground Render with Hidden Line (see Sht-2), but it doesn't actually solve the problem.

** Why ought it render well in the Design Layer and badly in the viewport?

Share this post


Link to post

This inconsistency between rendering on a sheet layer vs. a design layer is very common and a real weakness in my opinion. Clearly two different rendering engines are being used.

Kevin

Share this post


Link to post

Viewports have it's own 3d conversion resolution setting in Advanced properties. Maybe that's your issue.

The resolution is considered, in any case, per curve and not per object. Thats way the differences that you showed us.

When more control over the geometry is needed, we use polygons instead o polylines. Also we make regular polygons (with number of sides as resolution) instead of circles.

I think we need more control over this. At curve level to precisely focus it.

Share this post


Link to post
You're right Kool Aid... It's there only for Section Viewports!

So, the 2010 prize for the most Illogical, Inconsistent and Confusing User Interface goes, for the umpteenth years in an unbroken row, to Nemetschek North America!

Well done, NNA!

Share this post


Link to post
So, the 2010 prize for the most Illogical, Inconsistent and Confusing User Interface goes, for the umpteenth years in an unbroken row, to Nemetschek North America!

Well done, NNA!

And just last week you were defending the fact that the tool/command distinction was made manifest in the interface...

Share this post


Link to post

MichaelK ? yeah, I've got 3D Conversion res set Very High. Really, as Kevin McAllister mentions, there seem to be different rendering protocols for Design Layers and Sheet View. I think they got 'em backwards ? I'd rather see the "good stuff" in the Sheet Layer viewports.

I did send this in to Tech. It just seems wrong, not a bug so much as a goof.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...