Jump to content
Sign in to follow this  
sarah_earney

Help! VW2010 viewport referencing and class overrides...

Recommended Posts

Admittedly I only put 2010 on my machine a couple of hours ago, so this might be me being quite stupid, but, I'm having trouble with viewport referencing.

When, in a new file, I go to make a new viewport that references another file, I go View/create viewport, but 'select source' is greyed out. If I go to the references tab of the organisation window and go to settings then 'design layer viewports' is checked. So, it feels like there's some tick box somewhere that I need to untick, but I can't find anything and don't know what else to do. Help anyone?

Also, I have a file (well, one of about a thousand) created in 12.5, now opening in VW2010, and I can't override the class colours in the viewport on the sheet layer that references another file. Or at least, I select the viewport, go to the Info palette, select classes, and tell them all to be black, but this isn't working. If I go out and come back in then they're all listed as being black (my override), so it's not forgetting them. I've tried remaking the viewport from the layer that's referenced in from the other file (not made by me in 2010, imported with the drawing from 12.5), I've checked it is referencing the right file and that all the lines in the right file are all set to colour by class. They were all fine when the drawing was in 12.5. Again, feels like I'm missing something small but significant.

Any help or suggestions will be very welcome.

iMac, 2GHz intel core duo, 2GB ram, running OS 10.5, only upgraded from VW12.5fundamentals to VW2010 architect today, have run the SP1 update.

Share this post


Link to post

I can answer the first part.

The Select Source will become available as soon as you pick a design layer in the pull down above the select source button.

michaelk

Edited by michaelk
  • Like 1

Share this post


Link to post

Ah... I had sheet layer selected, if I select one of the design layers then it's fine... so I can't create a viewport referencing another file directly on the sheet layer? How does that work then? I create a viewport of the refereced file on the design layer and then make a viewport of that on the sheet layer?

Share this post


Link to post

OK, so if I open a VW12.5 file in 2010, and in the settings button on the 'warning this was created by an older version' window that comes up, I select 'convert referenced layers into referenced viewports' then I get the problem with the class overrides not working, but if I untick this then it all seems fine - I can override to my heart's content. But don't I want to be able to convert all my referenced layers into referenced viewports?

Share this post


Link to post

Yep.

Can't wrap my poor little brain all the way around your second question... Can you post an example, or maybe someone smarter will be along soon...

michaelk

Share this post


Link to post

OK, file 0421_81_2001 is the one I'm having trouble with - select the viewport (elevation of reception desk), go to the info palette and try and change the class attributes within the viewport. Also attached, 0421_ele_concierge, is the file it's referencing (I draw the lines in the ele file, and then reference it into the format file for annotating etc, so I have 1 format file for each individual drawing number/paper drawing).

Both of these were drawn in VW12.5, both when bringing in to VW2010 I ticked the 'convert referenced layers into referenced viewports' tick box. If I don't do that then I can use the class attributes overrides fine, turn things black, blue, whatever.

So, the question is, why won't the class overrides on a viewport that has been imported from VW12.5 work, when I've elected to turn all my references that were in the 12.5 doc to viewport references in the 2010 doc? I can tell them to be black in the classes box, but they don't turn black on the drawing.

Hope that clarifies it... thanks.

Share this post


Link to post

I got the same results as you. I can control visibility, but not attributes.

However, if you just want to make it B&W, you can click Advanced Properties in the sheet layer viewport OIP and select B&W.

Sorry. Not much help.

michaelk

Share this post


Link to post

Hmm, but if I make it all B&W then I'll lose the fills and the areas of colour and any tranparencies. Thank you for your help though, on the 'select cource' issue you solved my problem.

Can anyone from VW help with this or have I stumbled across something that shouldn't happen?

Edited by sarah_earney

Share this post


Link to post

Hi Sarah,

It might be that some of your source information does NOT have the attributes set "By Class"(Color by Class,etc.)

There also seemed to be some broken links in the file, so I "fixed" it.

This may mess you up but I think I can get the target file to do what I want.

See what you think.

Share this post


Link to post

Hi Wes,

Um... I'm not sure what you did to make it work, but if I download the 2 files you sent back, and update the reference in the target file to be the source one that you sent, then I still can't control class colours.

Perhaps I'm being stupid, but I'm selecting the viewport, then selecting 'classes' in the info palette, then selecting the relevant classes (ie all of them) and turning the pen colour to black. And they're staying the pink and blue and green that they were. And in the source file I've done a select all and made sure that everything was on colour by class.

If you can do it and I can't, does this suggest it's my computer?

Thanks.

Share this post


Link to post

Hi Sarah,

I left out a bit of info?so sorry. The way I?m controlling this is by either using the Nav Palette or the Organization Palette under the Tools Menu. Let?s say I use the Org Palette ? I select the Viewports Tab, then select the Viewport I want to modify, in the case of the file I sent to you, it?s called ?Mine VP? ? right click on the Viewport Name and go to ?Edit? ? in the ?Properties? dialog box, choose ?Classes? ? you?ll see where I?ve modified your ?People? Class and ?160 furniture general? class by double clicking and changing the fill or line color.

See if that works?

Sorry for the confusion

Wes

Share this post


Link to post

Hi Sarah,

In addition, you'll get a dialog box similar to the illustration below when you modify a Class, just say "Yes" and things should work out.

Share this post


Link to post

Ah yes, OK, that works... thanks. It's somewhat more long winded than how I used do do it on VW12 (through the info palette as previously described)... should it work the old way then? Or is this how it is for sheet layer viewports and I can use the old way on design layer viewports?

Thanks.

Share this post


Link to post

OK, I think I'm understanding this now; if I go to the design layer on which I've created a DLVP referencing another file I can overide the class colours here, then create a sheet layer VP to get it onto my title sheet. Which was what you were doing, but just using the organisation palette. Right. OK.

I think I should invest in the training DVDs and stop bothering you guys.

Thanks for all your help in the meantime!

Share this post


Link to post

Hi Sarah,

I just experienced the same issue you had with class properties not functioning in files that i had converted to 2010 from 12.5.

I followed the solution Wes mentioned and that worked out.

My only question is that this seems relatively labor intensive to have to convert all the viewports individually.

Our entire office is switching from 12.5 to 2010 and I can't imagine every project in the office having to go through this.

Did you by any chance find a option in the "batch convert" function that keeps this from happening?

Thanks.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...