Jump to content

VW2010 crashing on editing viewport annotations

Recommended Posts

Have been doing some more work on this - still success though and can't edit the viewport crop. This is what I have tried to see if I can fix it :

- Trashing preferences

- Deleting all viewports and recreating them. The first time I make a new viewport, going in to edit annotation causes the crash.

- Tried not displaying planar / screen objects on the viewport creation dialogue.

Will try going back to my last 2009 version and reconvert it (don't have 2009 installed on this machine)

Any other suggestions??



Link to comment

Back to the usual VW trouble shooting.

Have you tried reseting the VW Preferences? Open the Prefs and click the reset button. You will have to manually adjust the preference back to your preferred state.

If so, have you tried to completely delete the preference file from your User/Library/Preferences/net.nemetschek.vectorworks.something something something file? Same as above, but you will need to also reenter your serial number.

Have you tried creating a new user and running VW there? System Preferences:Users. If it works in a new user then you know you have something wrong in your account.

Have you tried deleting and reinstalling VW?

Just some ideas from easiest to hardest.

Link to comment

Thanks Pat -

Tried all of those except re-installing VW - which I will try later this morning as I have to go to a meeting.

I'm afraid none of them worked!! A blank new file doesn't cause problems, so it must be something to do with the file I am working on?? For some reason, I suspect the Callouts I have made into Keynotes. They have been behaving oddly. Numbers not referring to the correct note and on one Viewport the first Keynote I entered showed up as 1, and the second as 8. Keynotes 2 - 7 then appeared in the legend and were referring to callouts on other viewports.

Thanks for all,


Link to comment

I have been asked to make one more suggestion regarding tracking of crashing bugs.

Both VW2009 and 2010 offer an Error Reporting feature. You can turn this on in the Session tab of the VW preferences.

From what I have been told, this feeds crash information directly to the engineers at NNA.

If a new file does not crash, then it is probably a file related problem.

To check bad fonts on Mac go to the Font Book app. Select all of your fonts and choose Validate Fonts from the File menu.

Link to comment

Andrew (et al),

If you want to get the best results for tracking down the problems and getting a resolution then please check in "Vectorworks Preferences" that the option "Error Reporting" under the "Session" tab is set to "Send crash details and usage patterns".

This is new technology and functionality to VW that is now the single most important means of finding and fixing problems.

To curb any concerns, NNA does not collect ANY personal data. The crash logs and use logs for Vectorworks 2010 are the only pieces sent to NNA automatically, nothing else. But these logs are very informative to our engineers in finding, analyzing, diagnosing, and fixing problems such as this. Our beta testers used this functionality and provided an enormous value to our engineers to get the best, highest quality initial release, of a VW version, out the door.

Also, follow up each crash/issue with a bug report so it can be paired with the logs to better define the problem and get better personal attention from NNA staff.

I would encourage EVERY user to verify the same setting to get the best troubleshooting results.

Edited by Jeffrey W Ouellette
Link to comment
cupsd runs ok, but cupsd -f timesout.

Filename is EMBL_2010 v010.vwx so that should be ok?

How do I check for incompatible fonts?

Try > sudo cupsd -h

this will list options ... as long as cupsd is active you can then: Safari >

which opens the CUPS System GUI.

If there are no issues withCUPS or FileName... great !

Use Font Book .app to analyze your entire fonts libraries..

[important] make sure that you don't have fonts laying around in unblessed directories.

Link to comment

Hello -

Just to update you, the UK distributor - Computers Unlimited, fixed this pretty quickly for me - or at least identified what the problem was.

Deleting the truss - or having it on a layer that is not shown has proved the workaround - just in case anyone else has the same issue.

Hopefully it will be fixed soon in an update?


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...