Jump to content
Sign in to follow this  
Terri

Problems with plant symbols from 12.5 to 2009

Recommended Posts

I have been able to import my plant symbols and library from 12.5 to 2009 but with unresolved issues.

Is there a way to use 12.5 plant symbols in 2009 so that they have editable properties, such as color fill and tags? I like the graphics of many of the plant symbols in 12 which aren't in 2009.

Also, when I see these plants in the plant tool, it doesn't show the graphics associated with them.

When I tried using these symbols a few months ago in a document with 2009 symbols, they showed up as dark squares. I had to delete them and use only ones from 2009.

I was told before by a VW trainer to create a new library so that I won't have these problems, which will be very time consuming. I haven't seen any other posts of users with similar problems. I can't imagine that everyone is starting over with their plant libraries when upgrading from 12 to 2009.

Share this post


Link to post

I had problems with this and I had to make a 12.5 drawing and place all the plant symbols in this. and open in 2009 and save as 12.5 plants symbolsand add the drawing in favorites in the resource browser. I have been able to use them here althoughn I have not done much in changing colore etc. You do have to make any changes in tags, etc before using them it seems like.

fwiw

as a novice You get what you paid.

jim

Share this post


Link to post

Thanks to everyone who provided suggestions. In working with Donald Ward, a VW trainer, we developed a detailed procedure that solves my issues and I'm sure others also. I wanted to share it so that everyone may benefit from it.

To convert Landmark 12 plant library to 2009:

Open 12 plant library in 2009 and resource browser. View resources as thumbnails.

When you first set this up, go to the plant tool and double click on a tree symbol and a plant from the standard 2009 symbols (Plant Objects.vwx). By double clicking on the symbols this will add the plant component classes in the Navigation palette to your current document.

Select the VW-12 plant symbol in RB, right click and select edit 2D graphics.

To edit interior linework of symbol:

Select all. Shift and click on outline to deselect the color fill geometry.

With interior linework selected, change class in object info palette to Plants>Component>Interior Linework.

For color fill control:

Duplicate the color fill (Surface object/Circle/Polyline), with the 2D selection tool hold down the option key (mac) or Ctrl key (PC) and move your courser over the color fill. You should see a + sign beside your cursor click on plant outline so that the color fill is duplicated directly on top of the original geometry.

Change the attributes in the attributes palette of the duplicate copy to have a none fill color and solid pen line.

Change the class to Plants>Component>Outline.

Send this class to back with Command + B (mac)or Ctrl + B (PC).

For plant fill color:

Select the (Surface object/Circle/Polyline).

Change the attributes in the attributes palette to the desired color fill or gradient and choose a none pen color.

Change the class to Plants>Component>Color Fill in the object info palette.

Click on Exit Plant box on top right corner.

If you are editing Tree symbols it is best to assign the fill color of trees to the Plants>Component>Canopy class. This will keep consistency with the fill color of tree symbols created in VW-2009.

To control the plant tag, it also needs to be edited.

Select the plant symbol in Resource Browser, right click and select edit definition.

In Default Prefs tab, change Tag Class to Plants>Component>Tags.

This is also a good time to make any other changes to the definition.

Click OK.

This plant symbol now has the same controls with classes as 2009 Plants.

Refer to Tech Tip on the Knowledgebase Adding New Plants to Place Plant Tool to export into plant defaults.

Also note whatever 2D geometry is sent to the back when editing the 2D graphics will be the graphic that shows when choosing Mass Over Lapping in the Rendering options when editing the Definition of the plant (i.e. if the solid color fill geometry is sent to the back you will see the fill color of the plant, if the outline is sent to the back then you would see just the outline of the plant with this option turned on).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...