Jump to content
  • 0
Sign in to follow this  
Gerrit

Import DWG file results in numereous design layers

Question

I'm trying to import a 11MB dwg file into VW2009. There's quite a few problems that I can't figure out :

1. the drawing itself (floorplan) is scaled right, but all the hatches need an additional scaling with factor x 1000 (using the RP for that). Why weren't they scaled ?

2. the object is extremely far away from the absolute 0,0. I'm talking 15 km, more than I've ever seen before. Is there an option during import to avoid this awkward position ?

3. Right after importing the drawing, I'm facing a whole list of new design layers, named : _Layer_Crop-xxx, where xxx represents a value from 0 up to 287. Many of these additional layers have a few objects, so I can't just delete them.

4. Several symbols have a selection area that is way larger than the object(s) would have you to expect. Scale to Objects results in a zoom number like 0,004%. Top right would be the actual symbol, while the rest of the area seems empty. I already checked for text objects size 0, arc centers etc.

5. The VW file is app. 13MB, but very hard to handle. I've seen an Out Of Memory window more than once.

6. Out of curiosity, I've imported the same dwg drawing in a version 12.5. All the same problems seem to occor, except number 3.

I'm looking for a way to make this into a workable VW document, I'd love to be able to continue to draw in this file.

Providing the above information is sufficient, who can offer help ?

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

Here are a few thoughts based on my own experience of importing DWGs. Hope they help.

2. the object is extremely far away from the absolute 0,0. I'm talking 15 km, more than I've ever seen before. Is there an option during import to avoid this awkward position ?

You can choose to centre on import (primary setting>model space in the import dialog). This should help with this problem.

3. Right after importing the drawing, I'm facing a whole list of new design layers, named : _Layer_Crop-xxx, where xxx represents a value from 0 up to 287. Many of these additional layers have a few objects, so I can't just delete them.

After years of bringing in Autocad layers as Vectorworks layers, I finally switched to bringing in Autocad layers as classes. I would suggest you try the same. When you delete classes to clean up the drawing, you are given an option to move or delete the objects within that class. So the scattered objects can be brought together into one class or reassigned to other classes, instead of being deleted. Also, classes can be quickly grouped by using the dash ( - ) within the name of the class, so in the class drop down menus they nest cleanly.

4. Several symbols have a selection area that is way larger than the object(s) would have you to expect. Scale to Objects results in a zoom number like 0,004%. Top right would be the actual symbol, while the rest of the area seems empty. I already checked for text objects size 0, arc centers etc.

Usually this means either objects within the symbol in a class that is turned off (may not be likely in your case, since you are importing layers), or that there are loci (Autocad points) in the symbol. Often the points are the WCS/UCS 0,0,0 of the block. Try Vectorworks>Preference>Display and turn Display 3D loci to Always.

Hope these suggestions help.

Kevin

Share this post


Link to post
  • 0

Thanks for answering, Kevin.

- Centre on Import was checked, I believe - must try again.

- I actually did import AC layers to VW classes, the design layers may be caused by AC viewports ?

- The loci inside the symbols : good suggestion, never heard it - I'll dive into that.

Share this post


Link to post
  • 0

I get .dwgs that have objects far from the main drawing. That may explain why your import isn't centered. Try doing a select all then fit to objects.

Share this post


Link to post
  • 0

Gerrit,

if you leave "Center on import" on, that shifts the drawing's origin to the center of the imported objects (15km away). In most cases this is not something you might want. Or at least not something you should leave checked carelessly, without being aware of the origin's shift.

I find best to uncheck "Center on import" and move the objects to page center after import with:

* all classes visible

* all layers visible and "show/snap/modify others" on

* select all

since I don't ever want my origin moved.

The difficulties you are experiencing in handling the file is probably due to some objects extremely away from page center. Moving the objects as said should fix it.

orso

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...