Jump to content
Sign in to follow this  
theob

Screen Redrawing Lag - VW2009 & Macbook Pros

Recommended Posts

I'm currently testing vw 2009 on my macbook pro and I have noticed that there is a certain choppiness when scrolling around the screen, as well as zooming in and zooming out. This occurs in design layers as well as sheet layers, and it is much more pronounced in larger drawing files with lots of 3D geometry. I have compared a few drawing files in both 2008 and 2009 and the lag/choppiness occurs across the board on 2009 in comparison to 2008. It is even apparent, to a lesser extent, when panning around an new drawing file.

I know there was talk of the screen redrawing lag when vw 2009 first came out and I was aware of this when I bought the program, but I had not seen much talk of it recently. For my larger drawing files, the screen redraw can take anywhere from roughly .3 sec to a full 3 secs. In this current state, the program is unusable for me. I have tried turning off all of the smart cursor cues, snaps, etc, to no avail. the only thing that seemed to help was putting the screen at an absurdly low resolution (640x480 - i have the 17" model with the native 1680 x 1050 resolution).

For reference, I asked a colleague to open one of the larger files I am using on his current Mac Pro and he says the delay is no different (or only slightly different) than the delay he has on his other, smaller drawings. He said the maximum lag he has is about .25 secs, maximum - roughly on par with 2008, or slightly slower.

Has anyone else encountered this problem? Is my laptop outdated for vw 2009? Does anyone know if the latest MBP can handle vw 2009 and potentially vw 2010, onwards (within reason, of course).

This sounds like a video card (GPU) issue to me, no? Any way to fix this?

Thanks...

Share this post


Link to post

I know my post was a little lengthy, and I am working with NNA to see if there is a way to fix my problems with 2009, but can any Macbook Pro users out there tell me how 2009 works on their systems? Do you get choppy panning and zooming? I'm not experiencing a lag of seconds when I pan, but it's enough to be annoying and I do get a longer lag when zooming.

Just a quick post if you use VW2009 with a MBP to say if it is choppy or not would be helpful. If you can, include your system specs. Sadly, I'm trying to decide if I need to update my computer.

Thanks.

Share this post


Link to post

Screen refresh is quick for hand tool and scroll/key pans , but lags about a second with scroll wheel zooms. The image pixilates then recovers. Turning off VW pref for Zoom Line Thickness speeds things up a little. The Anti Alias pref does not seem to affect refresh rate.

Magnify Glass tool, Fit to Objects/Page and Click to Zoom commands have no refresh lag.

Design layers and sheet layers behave the same.

Good luck.

-B

Share this post


Link to post

Thanks for the info. I worked with someone at tech support and we seemed to get it running at a decent speed. In rough terms, what we did amounted to trashing all preferences that 2009 had stored, without reinstalling the program itself.

I am wondering if it was an old workspace that I imported from 2008 that slowed down 2009? I also believe that it might have something to do with the fact that, without knowing wither or not Windoor 13 worked with 2009, I installed it anyway. My guess is on the latter. Stupid error, I admit.

Does anyone know for certain whether or not Windoor 13 will work with 2009? I have an email in to OzCad, but with the time difference, I'm not sure when I'll hear back.

Share this post


Link to post

yeah, i have the same issue for VW2009 on my MBP, in fact, if you search the forum you will see I started a thread on it a while back. Lots of potential solutions were offered up, but none really did it, hence sticking with VW2008 as I can't be hanging around for 3 seconds for a screen refresh with every pan or zoom.

Share this post


Link to post

I'm using a 2 year old MBP w/ 2G of memory. I had zoom issues at first w/ 2009, but that script that was posted fixed it. I don't see any of the symptoms you describe.

Good luck

michaelk

Share this post


Link to post

I have the same zoom re-draw problem with my macbook pro as well. Theob...can you tell me more specifically what you had to do to your 2009 settings to rectify the problem? I've been in touch with tech support, and they sent me a script to run but it made no difference. I've also been told the WAD solution...in that it's "Working as Designed". But I don't believe this as not everyone is having the problem, and it is VERY annoying. I can't go back to 2008 as I also have Interiorcad and the 2008 version of that is terrible.

Macbook Pro 3.1 Intel Core 2 Duo 2.2Ghz

L2 Cache 4MB

Ram 3GB

60GB free space

Edited by Ride

Share this post


Link to post

I've been having this problem since upgrading to 2009, and since the last update a couple of weeks ago, I am not having constant crashing problems. Usually it happens when I am editing text....can't figure it out.

I'm frustrated with the screen refresh issue, though....looking forward to a prompt solution to that....

Share this post


Link to post
I know my post was a little lengthy, and I am working with NNA to see if there is a way to fix my problems with 2009, but can any Macbook Pro users out there tell me how 2009 works on their systems? Do you get choppy panning and zooming? I'm not experiencing a lag of seconds when I pan, but it's enough to be annoying and I do get a longer lag when zooming.

Just a quick post if you use VW2009 with a MBP to say if it is choppy or not would be helpful. If you can, include your system specs. Sadly, I'm trying to decide if I need to update my computer.

Thanks.

I've noticed that with mouse wheel scrolling the screen freezes up (ie. only parts of the drawing are visible or have very low resolution) with no refresh after zooming until I move the cursor then it refreshes, plus a certain instability in general along the lines stated in other posts in this thread.

Edited by Vincent C

Share this post


Link to post

2.33 and 2 gig.

Pan and zoom are fine. Only objection is nudging. A single nudge works fine but doesn't go far. Multiple nudges go more but take a long time. Continuous nudging is uncontrollable (was very controllable in 12.5). A little movement, then no movement then a jump, maybe beyond where you wanted to go.

Donald

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...