Jump to content

Plant Database...


Recommended Posts

We're working with the 2009 plants database and trying to set that to a server location in order to be accessible from multiple users in the office.

When following the Help steps to set up the Database on our server, it initially sets up in the designated folder. However, each time you try and access it, it creates a new copy within the designated folder as if it's not referencing the original that was set up (default is to continue creating new database when no database is recognized in a desired location).

Any tips would be much appreciated.

Link to comment
  • Vectorworks, Inc Employee

If you give a little more information, I might be able to help out.

What OS are you running on?

Does each user have the proper permissions to access the network folder you are referencing?

Verify that the entire database is in the folder you have chosen. Let Vectorworks do the copying for you. In your folder you should have both a 'VW Plants.usr' file and 'VW Plants' executable (.exe on Windows, and an application package on Mac).

After choosing the folder, go to your user preferences dialog and verify that the database folder was added as a workgroup folder.

Link to comment

I think I figured it out yesterday. I'm on OS 10.4.11. Finally started working, or at least not making continual copies once I set my user folder to the server location. Previously hadn't done that.

Have yet to test other user locations as I'm the guinea pig for the new system and how they link up. We're hoping to create a more standardized system using a user folder that's server-based. When I was working with it as a simple work-group folder, it wasn't working.

Link to comment

What I had set up yesterday appears to not be working. I was able to access the database only if my User profile was on the server. Switched my folder back to my HD and now am not able to create or access the plant database to our Server-based workgroup folder. Being an office of multiple users, we'll need the single database as a resource. It's pretty pointless to have everyone on separate database files.

Here's the specs and hopefully you'll be able to help figure this out.

MAC OS 10.4.11/ VW 2009

Have our Work Group folder set up in our desired server location and located via VW Preferences/User Folders/ Work Group Folder. As there's currently not a database in that location, it should automatically install per VW Help. The Network folder doesn't require any permissions, unless it's something buried in VW.

If I go to Landmark/ VW Plants Database I get the "Choose Plant Database Location." From here, select our Work Group folder/ OK, which should kick off the installation of the database to our server work group folder. Unfortunately, nothing happens. Also tried creating the database in my HD User Folder and nada. Doesn't create the database in either location (both folders do not have the database). I know there can be reference issues if both locations have the database, so made sure both were empty of the Plant Database.

Thoughts? Also, if we figure this out, is there a way to set the workgroup folder as the default?

[EDIT] Through additional playing around. The Database is up and on the server and my user folder. However, when I try to open the database, it is only referencing my user folder database. When I open VW Plant Database, it opens automatically and doesn't give me a dialogue to choose the location. If I go to Choose VW Plants/ Select Work Group folder and then open the database it is still referencing my user folder. As a test, I went through these last steps and imported a picture into the Autumn Joy Sedum. When I close the database and manually open the server database, no picture in Autumn Joy Sedum. If I manually open the user folder database, it has the photo.

Edited by cdub
Link to comment
  • Vectorworks, Inc Employee

I have some further ideas.

First thing is to check exactly wherethe application thinks it should go to access the database. For this you should check your saved settings.xml file in you user folder. Search for the PlantDBLocation entry.

Second: If you copied that database to your server, which OS did you use. If you copied it from a Windows system and then tried to access it from a Mac, there will probably be a problem with missing files. Try the following steps:

1) Copy all the files from a Windows install to your server location. When choosing a folder, make sure you maintain the folder structure of /Plant Database/VW Plants. This is important. Vectorworks will do this for you if you allow it to setup the database.

2) Go to a Mac install. In the application's plant database folder, there is a packed file called 'VW Plants.app'. It may just show as 'VW Plants' in the finder. Copy that also to you server folder.

3) From Vectorworks, choose this folder as a workgroup folder, if it is not already configured as such.

4) Now try selecting this folder as your plant database folder.

Please update on how this goes.

Link to comment

The application continues to reference the Hard drive location even when selecting workgroup folder from "Choose VW Plants" or from the "VW Plants Database." This was confirmed in the savedsettings.xml file.

As mentioned previously, we're on Mac here. I've tried locating the plant database multiple ways: 1) manually copy the "Plant Database" folder from HD to server; 2) let VW install the "Plant Database folder to the server as it's supposed to do when the database doesn't exist. Both instances revert back to the HD location whenever I open it and try to use the server-based database. As a check, I've moved the Plant Database from the HD location outside of VW 2009 app folder. Now, when I open VW Database the Choose Database location comes up, I select Workgroup Folders which has the preset workgroup location on our server. And, nothing. If I go back to VW Database, nothing and the Choose Database location comes back up. Endless circle.

I've seen reference in the VW Help section that mentions if a file or setting is in both the User Folder and Workgroup Folder, the User Folder takes priority. When I remove it from the user folder, it won't open from the WorkGroup Folder.

I'm going to need a beer before the holiday weekend, it appears.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...