Jump to content

Crashes whilst saving Creates VWTMP


Recommended Posts

I have been working on a drawing and sometimes saving it successfully, however sometimes when I try to save, vectorworks stops responding, and so I have to shut it down. When I reopen it, the file repairs itself (maybe to the last backup save, I'm not sure), but it calls itself .recover, and it won't let me save it at all or save it as something else. Also a -VWTMP file has appeared in the drawing folder bearing the same name as my troubled drawing. What is going on, and how can I sort it out?

Jenny

Link to comment

this sometimes happens to me, but i have had it sometimes where you have thought you have saved your drawing and continued working, only to find out 5 hours down the line once you have closed and re-opened the drawing that it has not saved any of it at all, thus losing a lot of work!

i have not seen VW stop responding though, i get a message sometimes telling me to save to another location (i/o error or something like that).

one thing that has worked is the trusty old method of copying and pasting into a new file.

this stuff stopped happening with the latest update to 2008, and i have not had any problems since.

i cannot see what version you are using so cannot really help any more

Link to comment

is it only happening with this drawing??? or has this happened with other drawings before????

if it is only this one, then it may be something within the drawing which is causing it to crash while saving. how big is the file size? have you tried purging unused objects to see if that helps? whats is in the drawing?

Link to comment

It does just seem to be this one, I've purged it before, but am doing that again, it is 18MB, but it really has got a lot in it. The architect's background forms about 14MB of it. I haven't had this trouble before with other files, but I am very new to vectorworks (3 weeks in), so I don't know if it's persistant in other files.

Link to comment

Try using the auto save settings, Tools>Options>Vectorworks Preferences>Autosave.

I have mine adjusted to save over the original file every 50 steps without confirming.....you barely notice when it saves (and its worth the wait in the end) and if it crashes most of what you have done has already been saved.

Link to comment

18MB is not very big at all to be honest, my files are often between 100 & 200MB with no real problems.

it could be the architects drawing, its hard to say really without playing around with the file.

the only thing i can suggest is if you dont need to mess around with the architects drawing you could try just bringing in a PDF of their info and drawing over the top, instead of having it a digital info. that way you could possibly work out if its their drawing or yours causing this problem.

how long have you tried waiting when saving the file?

Link to comment

Thanks vincent, I'll set that up.

Monkey - I waited about 5 mins before looking at the program through the task manager, which told me that the program was not responding. To start with, the CPU usage had been very high, but it dropped right down when the program was unresponsive. I've just had a new processor put in too, so it should be quite fast and good...

I am ambling along now with frequent backups, so hopefully should be ok. I'll wait and see if it happens on my next project.

Thanks

Jenny

Link to comment

The problem seems to be that it takes more that 5 mins to save, and that during that time, the CPU usage drops right down to 2 or 3 percent, and the task manager registers vectorworks as not responding, the whole computer runs slowly. Are there any ways I can improve this situation?

Edited by Jenny
Link to comment
  • 10 months later...

in my experience, this happens a lot when read/write permissions on the file server are out of wack.

This then results in io errors where the file can no longer be saved. In our situation, we get the warning once. If you then save to desktop, all is fine. If you try to save again after the warning, VW invariably crashes.

To be save, we have automatic backup set to every 25 steps, to a local folder.

One related thing I have been unable to solve, I sometimes get rogue files created on the file server after such problems starting with a double period, ie "..documentname VWTMP-VWTMP.vwx"

For the life of me, I cannot delete these files, when I click on them, they disappear, only to resurface once I revisit the folder.

Even as root (this is on OS X Server) I can't get at them.

Not sure if it is coincidence, but this seems to only happen on Intel Macs with VW 2008 SP3.

I wish VW would fix some of this stuff instead of just telling me to buy the next version. I love the program, but with every new feature/version, we get these kind of bugs to work around and they never get fixed until the next version which introduces... etc.

Doesn't make me very upgrade happy.

_________________________

Mac OS X 10.5.8

various iMacs G5 & Intel

VectorWorks 2008SP3

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...