Jump to content
Sign in to follow this  
botto

Plant Report

Recommended Posts

Hi,

Whenever I make one report the counting of the trees does not appear correct!

This is, when I make reports without activating the option ?Summarize items with the same,?? the amounts appear all correct ones, but with species repetition.

Whenever active the ?Summarize items with the same,?? it leaves to exist repetition of species names but the amounts do not appear!

I thank all the possible aid!

I leave images better to explain my problem!

Thank?s,

Pedro Botto

Share this post


Link to post

How are you putting the plants into the drawing?

I just tried to put in a number of individual plants and a plant group. When I then SUMmerize based on the plant ID, I get the proper count of the total plants.

Are you manually editing the information in the Plant Record?

Please tell us a little more about exactly what and how you are doing it.

It looks like you worksheet is a report based on a Plant Record being present. Is that correct?

Also, please let us know what version of VW and what kind of computer you are using. You should probably add it to your signature (MyStuff:Edit Profile at the top of the page) so we have if for any future questions.

Share this post


Link to post

Hi,

I place the plants through the tool ?Place Plant?. I create a plant and I give the features to it and later I place them in the drawing.

Not, not edit manually information in plant record.

I use the following process:

Editing the plants with the features and later I place them in the drawing or isolated or group, later I create report automatic.

Use one mac with vectorworks landmark 2008. Only work in this computer.

Share this post


Link to post

If you are using Create Report and selecting Plant Record your Worksheet should be fine

Pat - here is a dumbo question - is it ok to use #,.-_* etc in VW Plant Ids?

I just tried that and my plants still claculated properly

Pedro - Can you place the plants - a few of each into a new file and try another Report - see what happens

If it does the same post it here or email it to me

Share this post


Link to post

I just went back and tried it in VW2008 and I can't repeat bottos results. Can you post a test file that shows the problem?

Ozzie, as far as I know, the Plant ID field is a text field. That means that just about any character other than single (') or double (") quotes should be OK. If #-* seems to work for you, it should continue to work.

Share this post


Link to post

Good night,

The table that appears in the doc was executed in excel!

I wait that they can help me.

Pedro Botto

Share this post


Link to post

Pedro, why did you use excel and how did you get your plant data into it?

Have a look at the attached file

Tools/CreateReport then select Objects with a Record from List All and then Plant Record from Listing objects with record

Set up the fields you want in Worksheet Columns

And if you wish to add the quantities of the same Plant variety together tick and select summarise by ID - you could use Botanical name or Common name

that should get you started if that is your problem

Share this post


Link to post

There is a mistake in VW2008 that is causing the error. The Quantity field in the Plant Record is defined as Text. The worksheet does not know how to add up text fields.

This has been fixed in VW2009.

I don't know a an easy fix in VW2008. Probably the easiest would be to use a script to attach your own record and copy the text from the plant record and put it in your record as a number and then edit the worksheet to display your record for the quantity. You would have to remember to run the script every time you change quantities of any plants in the drawing.

Let me know if the script option will work and if you need help.

Share this post


Link to post

Very Obliged for the Help!

I go to try script.

As soon as experimete I say some thing.

Thank?s,

Pedro Botto

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...