Jump to content

Perspective within a viewport

Recommended Posts

I was wondering if anyone had any suggestions for me. I need to do a final shaded polygon render with perspective in my viewport.

I've found that it looks fine in orthagonal, but when I change my projection to perspective a small viewport box shows up with nothing in it. I was able to view the viewport in the "cavalier" perspectives, but these are not what I'm looking for. Any suggestions would be greatly appreciated. Thanks!

Link to comment

This always seems to work best for me if starting from a design layer. Use the camera tool or the "Set 3d View" command to get the view you want, draw a rectangle (or whatever) that you will use as the cropping geometry. With the crop selected, select Create Viewport, it'll ask if you want to use the cropping object, say 'yes', then select the sheet layer you want. Once on the sheet layer, you can modify the view, the classes and layers visibilties, etc. You can also use the walkthrough and flyover tools inside the crop edit mode, which isn't necessarily intuitive.

One caveat is that you can't adjust the crop while the scene is rendered, as this will kill the render cache.

Link to comment
  • 6 years later...

Interesting, I am having the OP's (original poster) exact same issue in VW2015 SP4 (with renderworks.)

I have created a viewport from 2 or 3 design layers, all at the same scale, nothing super fancy. When I go to set the Render options for the viewport, Orthogonal & Cavalier views work fine, but when I select "Perspective" I get the same tiny (~10 or 12 pixels square) box in the middle of an otherwise-blank Sheet Layer.

When I change the perspective to "Orthogonal" and do Update the viewport instantly appears as it should.

Any further thoughts on this? Should I attach a sample file?

Link to comment
  • Vectorworks, Inc Employee

File > Document Preferences > Document Settings, under the Display tab uncheck "Cropped Perspective"

Its a holdover from the older perspective views in documents or templates from a ver versions back. In new files it should be disabled by default, and you can update your templates to remove this setting if it keeps happening in your documents.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...