Jump to content
Sign in to follow this  
Vectorlogic

Mapping issues in Final Render

Recommended Posts

Happy new year to all. I'm not sure if I'm missing a new setting that was added in 09, when I map a texture to open GL setting scale etc looks fine, then in the final quality render the scale is way off. I've been punting my way through this for a while, but need to figure this out. Any thoughts?

Share this post


Link to post

I've been having the same problem. It looks fine mapped in open GL, and then in Final Renderworks, it shifts position. Maybe its a glitch?

Generally, mapping in VW is a pain. I wish they would improve this part of the program.

Share this post


Link to post

Hi Vectorlogic

Do I see it correctly that the attachment posted is in Final Render?

If so, have you done a Custom Render to see if you could alter this?

Did you draw the keyboard or get it as a symbol from somewhere??

and which version are you using of VW??

Share this post


Link to post

Your issue sounds very familiar! I too am having issues with a mapped texture or graphic looking one way when using the opengl render mode and then seeing the alignment for that graphic go out the window when switching to a fast renderworks, fast renderworks with shadow, custom renderworks and final quality renderworks.

Because of this, the mapping function under the render tab in the object info palette is useless as is the attribute mapping tool in the visualization tool set. I have to align the texture by keying in the coordinates by trial and error under the object info palette render tab.

Tech support suggested that I should map textures to 3D polygons or Nurbs surfaces rather than extruded shapes.

Talk about throwing a wrench in the work flow. My last several texture heavy projects have been painful.

What is up with this? I AM NOT seeing the much vaunted increase in speed and efficiency here!

Rant off...

Thanks,

m

Share this post


Link to post

Well I still need to pester the o.p. to see what he's learned.

At the vectorwork users group meeting in Austin last night it was suggested that selecting the "Use World Z for Origin" might help.

I'll try that soon.

Share this post


Link to post

Sorry for the late response, I watched the board for a while but had not seen anything. Anyhow I have been having this issue with VW 09 since the start. Image looks good with Open GL but not the same scale with final render. the origin did not seem to help. My previous post had one Final render visable the other was the attachment below that in Open Gl. The final version has the key texture but is so small you can't see it. I made this from scratch. It is constant through all my renders. I'm going to copy and paste back to 2008 and see what happens. either way the issue seems to be happening all the time in all drawings.

Jim

Mac OSX 10.5

Multiple Machines all the same result

VW 2009 SP2 Build (99197)

Share this post


Link to post

Hi Vectorlogic

Would be glad to help you out, but do not have that version of VW to have a look see as to what could cuase this.

Maybe someone from NNA could shed some light on this.

Share this post


Link to post

Okay, I just tried selecting "Use World Z for Origin" under the the Edit Mapping function on Object Info's render tab and it made no difference what so ever.

With textures not lining up consistently with opengl and the differing renderworks options then there's no point in trying to use the Edit Mapping function on Object Info's render tab.

The Edit Mapping function appears to use opengl for placing & orienting the textures.

The trial and error method of keying coordinates for the graphic and re-rendering the scene gets old quick.

I tried the "attribute mapping tool" under the visualization tool set and found it to be quirky when mapping to flat surfaces and useless when dealing with curved.

Thoughts? Thanks!

Share this post


Link to post

Mark,

I am having the exact same problem and have been forced to use the same solution- entering values in the object info palette and then using trial and error to map the objects. Needless to say the mapping is very imprecise.

What we have is an already clumsy mapping capability made virtually useless.

Also for the life of me, I have never understood why VW doesn't map an object to its extent by default like 3D Max. In other words in a simple scenario, say you want to map an image on a number of different sized boxes (like TV screens for example). Why doesn't VW just stretch the image or compress the image to fit exactly on the box?

This alone would eliminate 90% of the mapping time for me. Materials would be independent of the objects they are associated with. In other words the textures are not in scale- their size changes with each object that they mapped to. If you want them smaller, you simply tile them.

Share this post


Link to post

I think its important to point out that this is a new problem in VW 2009. VW 2008 didn't have this problem. This makes me think that it's definitely a bug.

Does anyone know if VW is aware of this problem, or what is the best way to bring it to their attention?

Share this post


Link to post

I sent this to tech@vectorworks.net on January the 15th and have been in contact with Donald[?] Ward and Sofy in the tech support dept at VW since then.

For some reason Ward thought the problem might be that I was attempting to map to a surface on an extruded object rather than a 3d polygon or a nurbs surface.

That suggestion was a non-starter for me, as I have been successfully mapping textures to extruded objects for 5+ years now.

This a problem for me on [2] other machines, as soon as I get home from the office I'll be able to post their spec's as well.

I hope they get this sorted out soon!

Share this post


Link to post

Hello All:

For the objects that show different texture results between OpenGL and RW modes, are they set to planar mapping type and is the "Auto-Align Planar Mapping" checkbox turned on in the Render pane of the Obj Info palette? Also, has the 3D mapping of the object been edited through the Edit Mapping dialog?

There is a known bug where auto-align planar mappings altered through the Edit Mapping dialog render differently between OpenGL and RW modes. The fix will be to not allow the Edit Mapping dialog to edit the 3D mapping for these textures, just the 2D offset, 2D scale, and 2D rotation.

If you uncheck "Auto-Align Planar Mapping" the objects should render the same in all modes.

Also, as long as the 3D aspects of the mapping have not been altered with the Edit Mapping dialog's tools (just the 2D offset, 2D scale, and 2D rotation) then the mapping should appear the same in all modes.

Edited by Dave Donley

Share this post


Link to post

Dave It seems that if I toggle the auto align off then back on it seems to get the renders to match, I don't remember this to ever require any other actions once a texture was mapped in previous releases and the results seem inconsistent. Also when I exported backwards to a VW2008 File all the mappings were off. Is this a bug or a new issue we should get used to?

Thanks

Jim Woodward

Exhibit Logic

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...