Jump to content
Sign in to follow this  
Eric Myers

Apply Textures

Recommended Posts

I've been having issues with applying textures to objects for rendering. Today I'm working with some text I've extruded and have tried unsuccessfully to apply different textures - the text always renders white (or grey) no matter what color the texture is that I've applied. I've also changed the Map Type and flipped my text object to see if the texture was being applied to the opposite side, but to no avail.

Does any one have any suggestions to help me work through this issue?

Thanks.

Share this post


Link to post

It is likely that the extrude is set to Use Class Texture. Go to the Render tab of the Object Info Palette and pick a texture there.

If that does not work, double click on the extrude, select all of the polylines and make sure that they are set to have a solid fill.

Share this post


Link to post

I have chosen various textures under the Render Tab, some defaults and some created by me, all with no luck. I did not think about looking at the attribute settings, but it was already set to solid. Trying a quick (relative term based on my hardware) render using a different attribute color to see what kind of results I get, but would still like to use textures as opposed to flat colors when possible.

Share this post


Link to post

Copy and Paste one of the extruded letters into a new file and post it here, we'll be able to figure out what's wrong.

Share this post


Link to post

I just opened your file and I'm able to apply textures to any of the letters through both the OIP and the resource browser. Here is the file.

Share this post


Link to post

Thanks for your help with this...

I've tried downloading your file twice, and aside from it having a different file name (1869), VectorWorks claims it is unreadable (I'm using 2008, btw). Also, my issue is not applying the textures, it's getting them to render properly with the textures I've chosen. Were you able to render the textures?

Share this post


Link to post

Ray would need to know how you intend to manipulate then render the textures.

If you use "Planar" mapping then the texture will only be correct on the face chosen but you will be able to use the Attribute Mapping tool to adjust, if you change to "Perimeter" Mapping then you will have to rely on the Offset parameters and Rotation to adjust.

If you go to the Render Tab of the Object Info Palette you can change the Texture for the Group of Letters and it should render as desired.

The issue I think your facing is that the Letters can have a solid fill as well as a Texture for Rendering under the Render Tab. If you Assigned a Texture then it will override the Fill color in a 3d view. The Letter needs a fill though in order for it to Render the Texture chosen. You can change the "Letter" Texture to any material of your choice but would suggest using names to textures that are associated to the actual texture, for instance Metal Chrome or Metal Cast Aluminum.

Share this post


Link to post

The file is version 2009.

It would help if you would create a signature with your version of Vectorworks and computer specs.

Here is the 2008 version of the file.

Share this post


Link to post

Thanks to everyone for their help and suggestions. Today I opened the file and it rendered the text exactly as it should have. This was after opening the file from Ray (thanks) so I don't know if that jogged something in my app settings or not, but I didn't have to make any changes to my file to get it working today.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...