Jump to content
Sign in to follow this  
Iain

Bottom Z or Z Origin

Recommended Posts

Hi,

Longtime reader, first time poster.

I have a layer with a wall on it. The bottom of the wall is sitting at z = 0 but the bottom z shown in the OIP is set to 3367mm. If I set the bottom z to 0 the wall moves down. A new layer in the existing file has the same issue. A new file created from the same template does not have this problem.

I can not find any information on resetting the wall's bottom z or the elevation of the z plane.

Can any one help? Is there some trick about repositioning the reference z0.0 position?

Iain

VW12.5.3 on XP

Share this post


Link to post

You set the Z height of the Layer in the Organization Dialog box. Either select if from the Tools Palette, or double click on the "button"/"tab" for Layers in the Navigation Palette. Select the layer you want to change and click the Edit... button.

Share this post


Link to post

Hi Pat,

Thanks for this. Unfortunately the layer z and del z are not the issue. The wall has the bottom z offset with respect to its own layer z. Changing the layer z affects my layerlinked model in the way you would expect but does not alter the fact that the wall is offset with respect to its own layers z.

Any other thoughts?

Cheers,

Iain

Share this post


Link to post

Try looking at the 'Insertion Options' in the Wall preferences for your particular wall. Under 'Link Height to Layer Delta Z' you may have inadvertently added some number in here which will cause the wall to be inserted above or below the Z height.

Share this post


Link to post

If your walls somehow got offset from the Z, the easiest way to fix it (provided you really want all of your walls to be at the layer zero), is to use the Custom Modification command from the tools menu.

Use it to select all the walls. It will then open a dialog box that looks a lot like the Object Info Palette. Change the Z setting to 0 (zero) and click OK. All of your walls should not be sitting at their individual Layer zero levels.

Pat

Share this post


Link to post

Hi Pat,

Sorry to be thick. I can't find this menu item in any workspace. Even when I go to Architect Classic it is not there. Cant find it in the VW help file and cant find anything like it in the workspace editor. I'm using VW12.5.3

any thougths?

Share this post


Link to post

My fault. Custom Modification was added in VW2008.

You will have to do the walls on each layer separately.

Use the Custom Selection (Tools Menu) to Select Only Walls.

Make sure your Layer Options are set to Active Only.

Go to each Layer and set the Wall Z to zero in the OIP.

Make sure you don't click on anything before you get all the layers done or you will have to reselect the walls. It might be best to save the Custom Selection of Walls as a script so you can easily redo it if necessary.

Pat

Share this post


Link to post

Hi again Pat,

Yehhh... thanks again. I probably should say that although I am new to posting here I am reasonably experienced with VW having used it for a couple of years including a bunch of stuff in 3D.

So let me try to explain the issue again. Say you have only one layer and one wall in it and we are looking at it in front view. In normal circumstances the wall will have bottom z of 0 on the OIP and will in reality be sitting with its bottom sitting at z=0 in the layer environment. If you give it a bottom z of 1m in the OIP it will sit 1m below the layer plane. In this way the position of the wall and the bottom Z of the OIP for the wall are in harmony; return one to 0.0 and the other will also be at 0.0.

My issue is that I have walls sitting on the z=0.0 just as you would like but the OIP bottom z is 3376.4mm thus they are not in harmony and I get funny results from things like 'fit wall to roof' etc.

Pat, If I set the bottom z to 0 then all my walls are 3376mm below plane. If I drag them up, the OIP bottom z responds as well.

Cheers,

Iain

Share this post


Link to post

Hi Archeus,

I missed your post. Yup looked at that already. Nothing there that relates to bottom z offset. There is an offset for plan displacement and for top edge of wall compared to layer height but nothing for z offset.

Share this post


Link to post

Hi again,

I don't think it is the wall object. If I copy the wall and paste it to another clean file it is OK. When I bring it back the problem is back. I think the whole layer is confused about where 0.0 is. The toilet and bath are also too high but are consistent with the wall positions.

Share this post


Link to post

Have you added wall peaks, or fit walls to roof? I've had several instances where the walls became corrupted, such that moving a vertex up caused the actual wall corner to move the corresponding distance downward, below the z=0 baseline. The result was "figure 8" shaped walls, and the only remedy was to delete the wall and redraw it. The walls frequently became corrupted again, so the exercise became routine...

Share this post


Link to post

Hi Chad,

Nope, no wall peaks. I have introduced newly created walls and they also have the problem. It is interesting that no-one has said "This is how you move a wall up and down without changing its bottom z", or "This is how you reset the bottom z to 0.0 without moving the wall". I don't know what the 1000 club is but it seems that to be part of it Pat would know a thing or two. I suspect he did not suggest this because it is not possible. I suspect the file is corrupt with the only issue being the funny behaviour or the layer z=0.0 with respect to the bottom z of the objects on it. Maybe there is a configuration part of the mcd file that holds these values and changing them there is the anwser.

Share this post


Link to post

You are right. The reason no one has told you that is there is not a way to do that.

Why don't you email me the file (less than 40 MB) and I will take a look at it and see if I can see anything amiss.

Pat

Share this post


Link to post

Thanks Pat. I'll clean it back to the basic layer at issue and send it off.

Share this post


Link to post

Iain,

It looks like your origin has gotten set to something other than the page center. This is what is causing a new wall you draw to appear to have a negative Z value.

Go to a Top/Plan view and Go to Tools menu, Set Origin. Choose the Set Origin to Page Center Option. This will put the bottom of your new wall at the zero point on the scale. All of your old walls will still be too high, but the tricks we talked about earlier will help you to bring them down to where they should be.

Pat

Share this post


Link to post

Hi Pat,

Yup you got it! So now my overly mathematical brain is punishing me. The origin is set in the plan view and therefore is a repositioning with respect to x & y coordinates - the xy plane if you like. So now I go to a front view and am dealing with x & z axis (xz plane) but the orthogonal repositioning of the origin seems to be relevant to this also. I had it in my head that somewhere there was an absolute origin represented by a cartesian origin of (0,0,0). I thought that changing the origin in the xy plane could not affect the z, but it seems that all I was really seeing was an offset on the left hand ruler. I assumed that when I went to front view the left hand (vertical) ruler was advising me about the relative position of objects with respect to the absolute origin of the layer in the z axis, but if fiddling with the origin in the xy plane then affects position in the xz plane then the scales are just rulers and the fact that I had a dodgy bottom z was in the end meaningless since it was just a ruler offset.

So I am left thinking that I should keep the origin at the centre of the drawing and this will mean that the OIP gives me good advice about where an object is with respect to my overall model space (made of many layers each having differing elevations).

Am I right?

Share this post


Link to post

I never shift the origin, so I don't know exactly how it works, but it does seem to just be a shift in the vertical and horizontal ruler bars.

The normal recommendation that I see/hear on this board on the mail lists is to not move the origin.

Pat

Share this post


Link to post

Hi Pat,

Thanks so much for your help. So there you have it folks, don't mess with the origin! I think this thread is put to bed.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×