Jump to content

Trim tool

Recommended Posts

Just upgraded to VW2009 from 12.5, and that was a mixed experience.

I really like the new improvements, but there is one thing I can't understand considering VW/MiniCad's roots in 2D drafting. The trim tool is as buggy and as useless as in VW12.5.

Drawing a tangent line between two arcs and then trimming off the arc, results in the whole arc gets deleted.

This is not consistent either, see the attached picture, one side is trimmed OK but the other is not and the split tool was used instead. Frustrating!

Is this just me or are anyone else having the same experience?

Link to comment

Just tried to trip up 2008 with a similar operation and it worked every time. I have had problems in the past however. Probably a silly suggestion but have you accidentally left "snap to grid" on? This will result in the line not actually touching the arc, and then the whole arc will be deleted when trimmed.

Link to comment

I don't have any problem with the trim tool. If you could post the file with instructions on how to recreate we could take a look. Snapping has changed in VW2009, not big changes but it seems a little stickier to me, good now that I have gotten used to it. I always draw with snap to grid on.

I would use the Connect/Combine Tool to do what you want.

Link to comment

Charlie and Ray, thanks for your reply.

This is not a big issue for me, there are alternatives. But as the the trim tool is more efficient (1 click) to Split, Connect/Combine it is rather annoying when it is not reliable.

Snap to grid is off.

The posted file is made up of four arcs, duplicated and moved in to position. Then the connecting lines are are drawn with snap to tangent on. I can make four successful trim operations; both on top arc, lower on the right arc and left an the lower arc.

Link to comment

I was able to get the correct result with both the Trim Tool and the Connect Combine Tool, both in about the same amount of time (about 20 seconds). With the Trim Tool I selected all, chose the Trim Tool clicked on a line, repeat for the remaining 3 lines, then deleted the arcs that were trimmed. With the Connect Combine Tool I clicked on an arc first (which I always do when using it on arcs), then a line, repeating for all arcs/line intersections.

Link to comment

My mistake, I did mean the Trim Command.

With the Trim Tool, the problem on your sample drawing with the whole arc disappearing is the line is not touching the arc. When you zoom in very close on any of the intersections that fail you can see that.

After playing around some more, I think the problem here is Constrain Tangent. It will draw a line very close to the arc but not touching it, even when the smart cue says I am snapped to the arc. I have to zoom in very tight to make it work. I'm going to file a bug on this.

Link to comment

Oh yeah, the three tools in this group that consistently have trouble in our shop are:

? the Trim Tool, which frequently removes the whole line instead the segment I clicked on,

? the Fillet Tool, which consistently trims off the wrong part of the object (in a very nice, thorough response from tech support, after I submitted a reproducible bug, thank gosh, I was advised that a workaround is to Compose the object I'm filleting).

? the Connect/Combine Tool, which often fails by removing the wrong portion of a line or connecting the wrong ends of spline

& You're right ? these are fundamental drafting tools that malfunction. I'm kind of jumping up and down about this, because it costs us a lot of time. I resort to the Split Tool a lot to sort this out, and that tool never fails, but it's tedious to have use that when the other tools ought to do it. I've sent in some bug reports, and I'm pretty sure they're being worked on. I hope they get to the top of the queue. It's important.

These issues come up a lot more if you are doing complex drafting with splines and so on.

Link to comment

Most of the time (VW12/2008) I tended to use the 'join tool' when trying to trim arcs with tangent lines.

VW09 should now inform you whether the line is tangent when placing a line tangent to an arc. It should display a red dot on the final placement click if tangent. Check your constraints/smart cursor settings.

Another method is to use the Constraint Tangent tool and then the joint tool. That's the beauty about VW's...there's so many other methods to do one job.

Link to comment


If you see my earlier post and the attached test file and you'll find that the lines are tangent.

And I agree, there are alternative methods to the the Trim tool but none as efficient in this case. Maybe you can call that a beauty of VW, but still, this is a at least 2 year old bug in one one of the most basic and fundamental 2D tools.

Link to comment
  • 8 months later...


there IS a bug with the trim tool.

When trimming two crossed plines in VW2009, sometimes when you click on one of them to trim it, it deletes the whole segment...

Very annoying stuff, basic command, VW tech guys ought to do something for that, it is so basic stuff...


Link to comment

GRPDS have you submitted an example as a bug? If you can replicate it use a program like iShowU or SnapzPro to record it to show what is happening and submit the movie along with the file (pre the trim of course so undo) so the QA people can look at it and assess whether it is a bug that needs fixing.

Link to comment
  • 5 years later...

So has this issue not been resolved yet in 2014? Because it is very inconsistent but it usually deletes an entire line when it clearly is interesting with an arc end. or if I undo it and re-trim, it will actually trim the line correctly.

I can not seem to find anywhere a fix for this or anything that really address this issue directly, most posts just seem to end with people saying they have this problem and thats the end of it.

Link to comment

For me the Trim Tool works as expected in 2015. So far, anyway. I reproduced the open poly from original post and drew a line extending through tangent points at both arcs. 2015's Trim tool accurately trimmed arc ends and/or line extensions to tangent points.

In earlier versions, I found that click location makes a difference. Eg trimming a little nub sticking past the trim boundary can result in removing objects on the other side of the boundary or deleting the entire object. Undo, zoom and retrim usually solves.

I can't verify this, but perhaps the unexpected trims (whole object or wrong side of boundary) is related to the selection box and snap box settings (Vectorworks Prefs>Interactive Tab). If the box spans the intersection at time of click, the tool will remove segments from other side of the boundary, or even both sides. A smaller selection box might avoid the problem.

Also, some boundaries, eg splines, bez, and planar NURBS curves, seem to be sort of undefined between their controlling vertices, in the sense that they are unable to bound a trim action except at the boundary vertices.

Some other possible situations of trim fail - Top instead of Top/Plan view, Layer Plane instead of Screen Plane. Objects not on same plane.

OK, just some amateur sleuth conjecture. Others may be able to confirm.


Link to comment

You're not alone. It has always been an issue with me. If I have two objects that clearly intersect, most of the time that object that I am trimming disappears. I end up zooming in to make it work which is too much zooming in and out for what should be a few simple clicks. It's been like that for me since about VW2009. Very frustrating.

Link to comment

I, too, often run into entire objects being deleted with the trim tool even when objects are clearly overlapping. It's not related to Screen Plane / Layer Plane, and it happens even when objects overlap by a lot. It seems to have no correlation to anything in particular, but zooming in/out solves the problem. Very frustrating (especially when trimming a bunch of things and not realizing an entire object disappeared until some time later).

Link to comment

it really seems to be a tolerance issue, as this kinda of thing happens within AutoCAD is you do not have your tolerance set. However with Vectorworks, it seems to be a random thing, trim function is seriously the most glitchy function I have even used for any drafting program. Surprised it has not been addressed yet.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...