Jump to content
Sign in to follow this  
tgm

Offset composed objects issues????

Recommended Posts

Does anyone know if the older issues of offsetting composed objects has been corrected as of yet in VW2008 or VW2009??

The specific issue is when lines and arcs are composed and then offset using the offset tool and the resultant shape is broken up into various line segments and arcs.

We are contemplating upgrading to VW Architect but are hesitant because of some the older lingering issues still out there, this being one of them which sparked a lot of heated discussion.

Thanks,

Tom

VW12.5.3

WinXP SP3

Share this post


Link to post

the use of the parasolids engine has fix many 2D offset issues in 2009. It may be worth geting a demo Cd and trying some of the geometry that you are having issues with.

Share this post


Link to post

Response from Tech Support: "Here is the result from offsetting the HPGCTerasen polyline. Handles show extra vertices on the outer offset polys; uppermost handle is the arc vertex from the original road centerline. So, to answer your original question, it looks like offsetting operations have improved. The vertex behavior that you have observed is still present."

Arc vertex polylines where the tangent length of the curve is greater than 1/2 the distance between the vertexes can not be edited correctly. In addition there is no warning that the program will change the RADIUS.

Share this post


Link to post

Tom,

When I compose an object using arcs and straight line segments, so far offsetting them seems to be fine, they offset like any other object. I may not be pushing it too hard, but it seems all right. In 2008, I didn't have any trouble with this either.

Invoking the 2D Reshape Tool doesn't reveal a welter of tiny segments, just a few polylines, and they are easily editable... so far.

Decomposing the offset polylines seems to cause the addition of perhaps one or two new arc segments, but nothing prohibitive.

Is that what you were asking?

Share this post


Link to post

Michael

What happens when you increase the radius that is geometrically correct, but the tangent length is greater than 1/2 the distance between the vertexes. Never has worked correctly & probably will not until VW adds an additional vertex mode that doesn't depend on a mid-point (false vertex).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...