Jump to content
Sign in to follow this  
mcobbs

VW2009 Questions

Recommended Posts

Ok, here's a few questions about the new 2009

1 = We use hybrid symbols for almost everything we do, we have a clean simple 2d version, and then a complex 3d version. We use the simplified 2d Plan to move around objects and snap walls together. In 2009, it is now snapping to the 3d object, even in 2d plan mode (did not do this in 2008) There must be a way to turn this off??? Edit =OK, I just realized that this is doing this with symbols from 2008, not new ones I create in 2009, please tell me I don't have to redraw my entire symbol library to get my snaps to work correctly..

2 = I also have tried the Zoom tool when snapping to objects (called snap loupe) but this is not working in 2d mode, only 3d mode. If I'm in 2d Plan, and I press "z", I get a blank white box, but it still tries to snap to objects, if I'm in 3d Plan, it zooms and shows up correctly...

3 = I don't suppose there is a "Classic" workspace option??

I added a file, this shows how my 2008 symbols are reacting to snap points versus 2009

Thanks

Share this post


Link to post

There is a legacy bug in VW where it snaps to 3D symbols inside hybrid symbols when in plan view.

Your 2008 symbols are different from your 2009 symbols in that they contain 3D symbols.

This bug will be fixed in a future maintenance release for VW2009.

Share this post


Link to post

A legacy bug? Please tell me you are joking.

Monkey, now that software is distributed electronically, companies have fallen prey to using early adopters as testers. When the companies had to burn and ship software, updating was expensive. Now it is relatively cheap, so the QC suffers.

Share this post


Link to post

One reason your example is not showing snaps in prior versions is that the 3D objects aren't producing any snaps. I believe there may have been some improvements in nurbs snapping in this version. Or, perhaps 3D edge snaps are typically turned off in prior versions. Anyway, I can observe unwanted 3D snaps in prior versions with a test case involving a 3D symbol contained within a hybrid symbol, so yes it really is a legacy bug.

Another reason snapping bugs have lurked below the surface in prior versions is that they went unnoticed. With the sweet snap hilighting in VW2009, many snap problems came to the surface, and we fixed them. This one snuck by, obviously.

Share this post


Link to post

Forgive my ignorance, but what are 3d Edge Snaps?

I've turned on and off every snap option I can find. I seem to have the most problems when I turn on "mid point of edge"

I'd be happy to try turning off 3d Edge Snaps, but have no idea where to find them, I do not have "Smart Edge" turned on.

Share this post


Link to post

In the Constraints Palette, double-click Snap to Object for the parameter on 3D edge snapping. Some of these dialog boxes are pretty buried and easy to lose track of......

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...