Jump to content

Vanishing Symbols

Recommended Posts

I have a big problem with symbols in viewports (either sheet or design layer)

The symbols cannot be seen in the sheet layer viewport. This is not a class issue, it applies to most symbols no matter what the class (but some are visible !). Most are in design layer viewports visible in the design layer but not in the sheet layer, some in layer links, and some directly in the design layer.

I have tried to remake the SLVP and also as a DLVP, same result both times. If I convert the symbols to a group the problem goes away but there are a lot of symbols !

If I zoom in while in the sheet layer I can see some symbols, zoom out they vanish again. Either way they will not print.

At this time all I can think of is start a new file, import the design layers, and recreate the sheets. Any other ideas out there?

Link to comment

I know you said it is not a class issue,


I think you might want to check again.

If you make all classes visible, does this

problem go away? If so you might want

to go into the Edit Symbol (both 2D & 3D)

mode and make all of the objects either

in the same class as you would always

put that symbol in, or just to be safe you

can also just set all of the objects to the "none"


Link to comment

I have done some more investigation. It seems to have something to do with the sheet layer viewport looking at a designlayer viewport (or a layer link) within a larger design layer. I recreated the file with a number of layers, all the same scale. I located the first design layer viewport in place, this showed correctly (ie with symbols) in both design layer and in the sheet layer viewport. I then located the second DLVP, symbols would appear in the design layer but not in the sheet layer. I then made a layer link to the same layer, again no symbols.

The original file is a little large to post, about 13MB

Link to comment

After some more work I can now reproduce the problem in a new file. It works like this:

Create a new file with three design layers

Place some objects in two of them, include 2d and hybrid symbols as well as others.

Create 2 design layer viewports, one for each, and place in the third design layer. Set both to top plan view.

Place a symbol directly in this combined layer

Create a sheet layer viewport of the combined layer

At this point I can see only the symbols that are present in the fist DLVP that was created, none of the others are visible including the direct symbol.

In the SLVP uncheck 'project 2d objects'. Now all symbols with a 3d content become visible.

Link to comment

I just tried to duplicate your problem and I can't. I think I followed your directions.

Two DLs each referenced to a third DL through individual DLVPs. 2D Symbol on the same layer as the DLVPs.

SLVP of the Layer with the DLVPs.

I see exactly the same thing on the SLVP as on the DLVP layer.

Can you post your test file for me try?


Link to comment

One thing I did not mention. When I zoom in in the sheet layer I can see the symbols but when I zoom out they vanish. They do not print eithr way.

The attached file is set on the sheet layer. I can see 3 symbols in the smaller square on the left, one in the cente but no others.

Link to comment

I feel your pain!

I submitted a file with the same issues on July 1 to a tech in the tech support department. He wasn't able to replicate it on a mac, but was able to on a pc.

If's very frustrating having 3D symbols in a design layer viewport not render in a sheet layer viewport. They show up in wireframe and in hidden line views, but not in any of the renderworks render methods [fast renderworks, fast renderworks with shadows, and custom renderworks].

I think a tempory work around would be to go "old school" and use a layer link instead of a DLVP.

Link to comment

I talked with VW support and this is how we solved the problem:

Remove any classes in your viewport on the sheet layer that contain viewports. This embedded reference really messes with the PC version of VW.

Next, duplicate the Viewport.

Now, turn everything else off except for the content of your referenced viewport. Turn on any viewport class(es) on this new viewport which you turned off on the original.

This way you may have, for example, one viewport with the architectural drawings, and one with your lighting instruments. This layered approach to viewports on sheet layers seems to be a temporary fix until a patch is released. The support team is aware of the problem and working on it, from what they told me.

Edited by bfeaginjr
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...