Jump to content

Hollowing out an object?

Recommended Posts

I can't get it to work in your drawing. However if I take one of your object halves and paste it into a new drawing and then use Ungroup to undo the history (deleting the split plane after the first ungroup) I get back to the starting point of two extrudes.

If I then use Solid Subtract to create the hollow object and then split this with the Split tool I get two hollow halves, as shown in the image below.

There must be some trigger for the intermittent abberant behaviour - quite what it is is the big unknown.

Link to comment

It's all part of the Great Mystery.

How about we drum up a response from the moderators? This is also happening in VW2008.

I've done all my little pea brain can dream up here....ready to move on and accept the workarounds. I cannot bugsubmit since I don't run VW2008.

Link to comment

i have no problem splitting the cube after i have hollowed it out. and it renders properly. but man this program is a PITA!! is there a way to see what commands you have given in this program? all the other 3D software has it so you can go back to an individual command you made and change it.

Link to comment

Heng2001 the command shows on the OIP (as shown in the image below).

You can step back through the object history via successive Edit Group instructions. You can then modify a particular edit in that sequence. You can also remove a particular edit in the sequence with Ungroup.

Link to comment

Works for me every time (so far) in every file - In the case of solid subtraction of extruded concentric cubes, if remove fill from the inner cube, then cavity renders hollow.

I opened up Mike's 1052.mcd. In the red rendered solid subtraction, the inner cube has a blue fill. Remove the blue fill, and the cavity renders. Attached here as modified 1052mod.mcd.

But the situation is kind of strange. In the case where the the inner cube has fill (solid subtraction renders filled rather than hollow), the extract surface tool finds a picture frame on the section plane rather than a rectangle.


Link to comment

Benson, it worked for me to begin with, but the more I looked at the issue the more often it didn't work. Two images below:

- First image two halves of the one split cube. One half is hollow and one isn't.

- Second image. Same process used on all three objects with all three subtracting objects having a solid fill. The one which didn't work was the cube with sides of 1m.

When it fails if the inner object has no fill then it won't show a fill to the cut surface.

The attached files are VW 12 files, but the same happens in VW 2008. The sectioned cube file was originally a VW 2008 file.

Link to comment

Hi, Mike - You are working hard on this! Seems that this thread has established that the split or sectioned cube is a special case. It fails, at least intermittently, to render the cavity. Other types of objects (spheres, extruded rectangles except squares, etc) seem to render the cavity consistently.

Perhaps my "discovery" amounts to a workaround. but it seems to always work: If the cavity does not render, remove the fill of the inner object and the cavity will render. This works with the "solid" half of the split cube in your 1072.mcd.

Add this to the strangeness: For a no-cavity-rendered split cube, remove the inner cube fill, exit the edit mode, render to display the cavity. It's fixed. Now unfix it - select the split object (don't enter the edit mode) and change its color. This reapplies a fill to the inner cube. Render and note that the cavity still displays. The fix stix.

Should we call it VextorWorks?


Link to comment

Starting from bc's file I subtracted, split & rotated and it worked. Did it again. It failed. Did it again, it failed but recovered when I double clicked back through the operations (as per Pat). The fourth time I converted the failure to nurbs and selected & moved the rogue face.

Clearly something fishy with the sectioning apparatus - I think this has turned up before but I can't immediately find the relevant forum threads... (was something in rendering I think)


Link to comment
Starting from bc's file I subtracted, split & rotated and it worked. Did it again. It failed. Did it again, it failed but recovered when I double clicked back through the operations (as per Pat).

This is exactly what I did and why I left the file with only the two cubes ready for operation. It worked at first go and then failed and then successfullly reappeared after editing the subtraction. But this is in 12.5.3. But so it is with VW2008 apparently and this would be a good place for the bug swatters to start swatting.

So have we reviewed this to the limit?

Edited by bc
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...