Jump to content

Walls disappeared in 3d view


Recommended Posts

Hi. Ive just noticed one of my walls has dissappeared when i look at it in 3d view. its there in plan and i can select it but in section VP and 3D view, open GL its missing! seems like a bug. anyone else have problems like this? I've found previously to just delete it and do it again, however I do worry that there could be an underlying issue??

Link to comment

Is the wall filled? If it isn't, you will get outlines in 3D instead.

Is the wall assigned to a filled and textured class?

Had you used Fit Walls To Roof on it? I had a problem recently where a lower lean-to roof just overlapped a wall by a few mm, so the wall went to that lower roof height instead of the higher roof above as I intended, resulting in a hole in the side of the building.

Link to comment
  • 1 month later...
  • 1 month later...


we've noticed many of the same issues occur when objects are grouped in a model. if the class of the group or objects within the group are turned off, it may result in visibility issues. these visibility problems don't typically show up in top/plan or wireframe, but often do in openGL or other rendering methods.

one thing you can try as a test is to take a copy of your file, and ungroup everything in your model (assuming you have groups), turn on all your classes, and then take a look at a 3d rendered view.

we have a post which may relate to your issue here:


hope that helps,


Link to comment
  • 6 months later...

this same problem has happened to me about three times in the past hour or so! i am on a new computer, so have recenetly re-loaded VW and other programmes.

once the wall had disappeared, i re-drew it and updated the VP and it was there, then i had to join my new walll into an existing wall and as soon as i updated it, it disappeared for the 3rd time! please please please can someone sort this!!! soooooooooo frustrating!

Link to comment

oh, forgot to add, that after re-reading these posts, i shut VW down and reopened and it did re-appear, but im not planning on doing that everytime, especially when im working on up to 3 files at once, so have to keep closing them all down and re-opening them again! efficient working? i think not!

Link to comment

This is the second time I have had walls disappear in 3D views.

Here are some screenshots.

1). Wire frame view, note the walls are outlined:


2). OpenGL rendering, NO WALLS!:


3). Same view, but after copy/pasting this into a brand new file:


I have attached a sample file. Note that it is an educational file, so do not copy/paste anything from this file into one of your project files. It will put

a watermark on it. You will not have a problem otherwise.

Any help will be greatly appreciated. The solution of copy/pasting everything into

a new file is not really a workable option. I have too many viewports and sheet layers that would need to be re-built...Many, many hours of work. And then what

if it happens again?

Thanks Wes and anyone for taking on this challenge. I have quit and restarted both

VW and my computer and it still is a problem.


Link to comment

I just downloaded the file and it opens and renders here fine. I get the same image as your third image above, but the little yellow car is missing ;-)

Have you checked your OpenGL options in the View:Render menu? Could they have gotten set to some odd setting?

I can make a view like your missing walls above if I turn off the Walls-Interior and Walls-Exterior classes. Are you possibly using a Saved view or sheet layer that has the wrong class visibilities?

Link to comment

Thanks Pat.

No, it is not a class issue, all classes turned on.

Open GL options set on Low and Use Textures.

And it is not just OpenGL, it is all rendering modes.

It is file specific. If I copy/paste to a new file it is fine.

In order to get the sample file small enough I just

deleted a couple dozen design and sheet layers.

What gets me confused is that Lucylou is reporting VW2008, I am on 09.

. I can't figure this out. I am in a world of hurt.

Edited by gmm18
Link to comment

Several possibilities:

1. It could be Ed version specific, but I doubt that. I am running an E series serial number which it like the Ed version but without the watermarks.

2. It could be SP2 specific. I had problems with the SP2 install and had to reofrmat and revert to SP1 and have not tried the upgrade again yet.

3. It could be file specific. How about using YouSendIt or Pando so we could get the whole file rather than the edited version. That would also make it easier for NNA Tech support to download and look at the file. My email will take up to a 40Meg file, so you could email it directly to me at the address in my signature.

4. I know it seems to be file specific, but have you tried resetting your preferences? If that did not work, what about deleting the prefs and reentering your serial number? What about reinstalling VW?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...