Jump to content
Sign in to follow this  
billtheia

unable to select viewport

Recommended Posts

I am having trouble selecting one sheet layer viewport in a set of drawings.

I started with a template set of drawings that had all of the layers, classes, views, sheets and viewports already set up. I pasted in drawing information from a file that I had started before I created the template set.

Most of the viewports seem to work just fine. One plan viewport (power & communications,) however, can only be selected by area. I can not click on the plan to select or double-click to edit. I can select the drawing title that I had placed in annotation space but not the plan itself. This is a problem because I want to move the plan to a specific location on the sheet but can't because I can't grab a part of the plan to use as a handle.

Has anyone else run into this problem? Am I missing something obvious?

I could really use some help on this one.

Thanks.

Share this post


Link to post

Bill,

This sounds very much like a class issue. Make sure you have the relevant classes turned on both globally (menu bar) and in the affected viewports. Check to see what class you have the VP itself set to.

It takes a little work, but you can actually set Class visibility in such a way that you can see something but not select it!!

Let us know how it works out.

Good luck,

Share this post


Link to post

in the navigation palette

go to viewport section

double click on the viewports it will show the vp and on the sheet it resides

then change the class to None

we put all our VPs in None Class at creation

because None class is usually always on

or we can find it, if lost for whatever reason

Share this post


Link to post

I bet it will not render in anything other than wireframe either?

I have had a similar issue recently http://techboard.nemetschek.net/ubbthreads/ubbthreads.php?ubb=showflat&Number=98833&page=2#Post98833

Im going to set my class to none, but I'm pretty sure it was not a visibility issue as I was running with class visibilities as show/snap/modify others and I even made sure that I had the correct class selected as the default.

I have my suspicions, but the problem started when I cut/pasted a set of viewports from a different sheet layer to a new one.

Edited by IanH

Share this post


Link to post

I don't think that it's a class issue - I turned on all classes and the problem persisted.

Ian, I haven't tried rendering in anything but wireframe because the viewports in question are plans. I'll give it a try and let you know what I find out. Also, the link that you posted is to THIS post - did you have another post with this issue?

Share this post


Link to post

OK - the plan viewports in question are in the None class and I can render them any way I'd like. I just can't select them by simply clicking and double-clicking doesn't do anything. I CAN select them by dragging a box around them.

help.

Share this post


Link to post

Bill, right click anywhere on the screen and pick class options. Choose the Show/Snap/Modify others option.

These options can be set in any views you create, which explains why in some views you can seem to pick everything and in others you can't!

Share this post


Link to post

Are you unable to select it if you use Force Select? I didn't see it mentioned, though you may have tried it by default.

Edited by JimW

Share this post


Link to post

Jim, I am not able to use Force Select because the cursor is not recognizing the objects in the viewport.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...