Jump to content
Sign in to follow this  
panthony

Fonts - TTF, FON and OTF

Recommended Posts

I just purchased an OTF font type and it does not appear to work in VW.

Does VW not support OTF fonts at this time?

Pete A

Share this post


Link to post

Here is what is happening...

The text display while entering text looks fine until you hit escape to place the text object then it reverts to Arial.

See Pic

Top text is placed object

Lower text is preview window while entering.

TestText.jpg

Strange...never had this happen before.

Text font works in all other programs on my system.

Share this post


Link to post

Korataki

Had to purchase in order to get a clients logo right on plans...however, VW will not let it work...stumped.

Found the problem...GDI Imaging must be OFF in order for the system to display the text properly.

Looks like a bug...I'll submit.

Thanks Ray for the help

Pete A

Edited by panthony

Share this post


Link to post

Hey all,

I am testing out VW2008 for my office, and I am having the same issue with our open type fonts (they show up as Arial until I double click to edit it). Does anyone know if there is a fix for this problem. Although it appears to print fine, the appearance on the screen reverts to Arial font.

Share this post


Link to post

Just to clarify, some Open Type fonts may work but VectorWorks only supports True Type and Post Script fonts.

Share this post


Link to post

I found this thread and I saved me a lot of time.... I suddenly have the same font problem with "Graphite Light" where it automatically changed into ariel and I could not change it back until I turned off GDI imaging. Other fonts seems to be OK. Even though I found this "work around" I'm still puzzled because I've been using this font for years and with VW 2008 since it shipped, but this is the first time I ever had the problem and I'm pretty sure I've had GDI imaging 'on' before.

Is it a coincidence that it happened shortly after I downloaded a Windows compatibility fix so my Excel 2003 could reead Excel 2008 files? I tested Graphite Light font on MS Word and it worked fine. Oddly, when I am actively adding text with Graphite Light as the default selection, it shows nicely in the text box until I hit the esc key, then it turns into arial font.

I hope my input can help VW tech supoport find a cure.

VW 2008 Arch RW, Win XP sp2

Share this post


Link to post

I can understand the statement: VectorWorks only supports True Type and Post Script fonts", but we have been using the same fonts at our office for YEARS on many previous versions, and have had no issues like this. I can open the same file in VW12.5 and I don't have this issue. I also can't imagine the fix to be all that difficult.

by the way,did VW ever support open type fonts? Or, is there a way to convert Open Type to True Type fonts?

(As a tester here at my office, I'd hate to hold off a 40 license upgrade for the company, but there is no practical way we can upgrade unless we are sure this font issue is dealt with. By all means we have thousands of projects with a particular font, and to know that our font all of a sudden doesn't work seems kind of ... lame, perhaps.)

Share this post


Link to post

Is NNA planning to add support for OpenType fonts in a future VW2008 update? All of the 2,300 fonts in Adobe's Font Folio 11 are OpenType fonts, so future support of OTF in VW is a necessity.

I guess that this is the reason that when I use Export PDF, OpenType fonts will produce garbled text (see the linked image 'otf_export_pdf.jpg').

But if I use the Save as PDF in the Print dialog the OpenType fonts print fine (attached image 'otf_save_as_pdf.jpg'). This is also true if I print to an Adobe PDF printer.

While we wait for NNA to add OTF support, it would be helpful if there were a warning in the Export PDF dialog box stating that VW does not support OpenType fonts at this time.

Tim

Share this post


Link to post

My apologies for not being clear in the previous post. Open Type fonts are not supported when using the GDI Imaging options.

If you are having trouble using a specific font please contact tech support, tech@nemetschek.net, so that we further investigate the problem.

Share this post


Link to post

Thanks for the clarification.

I tested it out on my Mac with several different OpenType-PS and OpenType-TT fonts, and it does seem to be a problem with a specific OpenType-PS font.

It's not a problem with PDF Export or Quartz imaging being turned on. I'll contact tech support, but I'll also switch to a TT version of that font.

Thanks for your help.

Tim

Edited by rDesign

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...