Jump to content
Sign in to follow this  
tgmedin

Fillet and offset problem........another bug?

Recommended Posts

Well here is todays reason why not to use VW dxf outputs for any type of manufacturing. We just scrapped about $5K worth of mold parts due this particular VW issue.

To duplicate the problem just draw a 6" sq. on the screen. Go to the Fillet tool and apply a 3" radius to a corner and trim the excess. Now go to the Offset tool and offset the resulting polyline .5" inward. All looks OK until you decompose the objects and you will notice that the radius that was offset is not only the wrong size, its sweep length is not 90 degrees and now a short line segement appears to connect the missing part of the arc.

This is able to be duplicated at will in 11.5.2 that we are using.

If you decompose the object first and then select the radius and adjoining line segments, the problem does not occur, at least with the limited testing we have performed.

We had a small issue on the CNC last week with some other parts and we could not pinpoint the cause. Now we have.

I hope you users with the Machine Design package are carefull, as this issue could lead to all sorts of manufacturing problems.

Well, it's back to the other drawing programs for our everyday file outputs to the machines. They are not as user friendly as VW has been, but these types of issues do not occur and we cannot afford to scrap anymore products.

Share this post


Link to post

This problem has existed since I started using miniCad in 1992 & VW2008 has not remedied the problem, even though Robert Anderson advised that it had been fixed. I have bug reported, complained, & even wish listed a fix for this problem in the recent Landmark survey.

The problem is the result of the software using a midpoint between vertices, if the end of one arc is beyond the mid point the program reduces the OFFENDING radius. The work a round is to add additional vertexes between the midpoint & the corner vertex, but these additional vertexes have to be deleted & redone if a vertex is moved.

Please can we have another vertex mode for inscribing a curve between 2 intersecting lines where the point of intersection remains the control point. Numerous programs for road design have had this capability for years (HighRoad, Landesign & AutoCad.

Share this post


Link to post

Yes, there've been many problems with offsetting polylines that include curves. I always avoid it and find some other way to accomplish the task.

In the case you cited, I would offset the 6" square first (drawing a new 6" square between the non-filleted opposite corners if necessary), and then fillet the corner of the resulting 5" square to a 2.5" radius, using the third mode of the fillet tool. There's no need to de-compose, but if you do the arc is correct.

The problems with offsetting curved polylines have been much discussed here. There should be a pop-up warning when you try to do it.

Share this post


Link to post

It's amazing to me that such a simple tool is rendered unusable in a program of this caliber.

I cannot afford to have someone work with this issue having to rely on his/her memory each time they use the tool. That is just plain ludicrous! To some of the users it's just lines on paper, to me it becomes $$$$ in the trash bucket.

I sure hope someone resolves this and other issues soon.

Tom in PA

WinXP Pro, VW11.5.2..

Share this post


Link to post

Anyone from NNA want to chime in on this issue??? Or is it a sensitive topic..?

Share this post


Link to post
Guest

Tom,

The best thing to do would be to direct this inquiry through Tech Support.

I suspect the fix was in VW 2008.

Share this post


Link to post

Katie,

According the the first reply to my post above VW2008 still did not correct the issue. Can you verify is that is so?

Doesn't Tech Support monitor the problems that this board brings to the forefront??

Share this post


Link to post
Guest

If you submit an inquiry through Tech Support directly, they can assist with the issue.

This board is not a replacement of Tech Support. It's a place to discuss issues, ideas, and concepts.

If you have a Tech Support issue, especially a time sensitive one, it should be directed through Tech Support.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...