Jump to content

Shift-Select has ceased to function

Recommended Posts

Lately, my ability to select multiple object through shift-click has ceased. Also, option clicking does not function as a "crossing" window selecting items it touches. Wondering if anyone out there has some insight on this? I am using Version 12.5, but checked in on my older version 11.5 (i don't throw anything away) and it has the same problem. Seems like an Mac OS issue (BTW running Mac 10.4 latest version is up-to-date. The symptoms are somewhat corespondant to my installation of Parallels 3.0.

Any thoughts will be appreciated

Link to comment

Reinstalling is mostly a good solution. Try that, but first...

I'm on OS 10.4.11 and have tried this function on both 12.5 and 11. It works fine.

I don't think it is a OS issue - rather a hardware issue. Have you tried another keyboard?

Edited by bonus
Link to comment

Yes, thanks, I've re-installed program A. It didn't help. I'm thinking that there is some advanced section that program C may have effected-program C (Parallels) now having been un-installed. It was after an upgrade to this that I lost some of my keyboard's functionality

It all baffles me-so all input is appreciated

Link to comment

Thanks also-I have used an external bluetooth keyboard and have had no success sadly. I don't really blame the system for messing things up, I just think that somewhere in the system there is a place to fix it. Now, that said, I have completed re-installing the OS from the discs shipped with the computer to try and re-set things that way, but so-far-not-so-good.

Link to comment


The shift-select issue is a known OS issue, which has been reduced over time throughout the OS X lifetime. Unfortunately, the problem does seem to crop up time to time without consistency. Usually only one or two applications are affected.

Restarting the computer typically alleviates the problem for a short period of time. Running disk utility to verify and repair disk permissions will address the issue for a longer period of time.

If you are not already doing so, I strongly encourage you to run Disk Utility (or another 3rd party product similar in nature) to verify and repair disk permissions on a regular basis. Personally, I run it every few weeks. It should also be run any time new software or hardware is installed/added, & software and OS updates are installed.

Link to comment

Thanks Katie and everyone, at this point I've still not resolved the issue having repaired permissions, dumped caches, dumped Keyboard plists. I am going to re-re-install over the weekend and see what happens. The next step will be to wipe the computer-storing everything I hold near-and dear off site and re-installing for real. Any bets on whether this will work. Again, thanks all, if more ideas (or more specific cache dumping or data clearing ideas) come up, I'll be back. Wish me luck

Link to comment

It is me again. So-I fixed it then it broke again so I am looking at a way to really fix it. I did find that deleting the prefs made all the difference, but it is a royal pain to get all the software back up to speed. I am wondering if anyone has advice on figuring out which of the prefs is specifically affecting VW other than the time consuming process of going through them one-by-one. Oi!


Link to comment

I have tried the clean install and sadly the problem persisted. I am not running Leopard (yeah) and so far it has contined to be an issue (boo). It looked like Quicken might of flumuxed the issue, but I'm afraid to try twice with as many pots on the burner as I have right now. I'd just like to keep it going, if ya know what I mean. So for now, keep your fingers crossed. I've figured out a quick, but certainly dirty way to repair the issue-dump the prefs for everything and restart, but this is annoying as I have to then re-set-up so many little things. Alas, If you hear of anything, I'll be back. Oh, and the other news is VW 2008 is on it's way, maybe that is the solution.

G. Ben

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...