Jump to content
  • 0
Sign in to follow this  
Chris Fleming

dxf import scale issues

Question

I've searched and can't find a thread addressing this, so here goes. When I import dxf files for my drawings (primarily moldings, etc.), they don't come in at the proper size (the size the molding actually is). The file says it is 1/8' scale. However when measured, the moldings are fractions of their actual size. For example, a 5" high molding is 5/8" tall in the file.I've tried importing into 1:1 and 1/8' scale layers. I've tried changing the layer's scale after import. Nothing seems to work. I usually end up grouping, then resizing to approximately the correct size to achieve near visual accuracy. But surely I'm missing something, and there is a way to have the files come in the correct size.

Help!

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

Chris,

My guess is that the units the DXF file was created in are different than the units you are using. In the Import Options dialog box check the Unit Settings:

If the objects are about 2 1/2 times too small, they are probably in centimeters. Set the dialog to 2.54 DXF Units = 1"

If the objects are about 25 times too small, they are probably in milimeters. Set the dialog to 25.4 DXF Units = 1"

If the objects are about 12 times to small they are probably in feet. Set the dialog to

1 DXF Units = 1' (that is a foot mark, not an inch mark).

Pat

Share this post


Link to post
  • 0

1:8 is the scale we normally call 1 1/2" = 1' - 0", a common scale for molding details. It may be that they were drawn 1/8 actual size so they would print at 1 1/2" scale without having to use viewports. That method used to be standard practice in Autocad, which doesn't have layer scale. I know of people who still use it to put drawings at two different scales on the same sheet, and I've seen exactly what you described in manufacturer's drawings.

Except for the units issue that Pat mentioned (and none of those would give you a 1:8 reduction), geometry always comes in at the size it was in the DXF file. Layer scale doesn't affect that; it only affects the relationship between virtual geometry and virtual print-out in the VW file. If it's as I suspect, the only solution is what you're doing now, re-sizing with the Scale Objects command. You shouldn't have to group them in order to do that.

Share this post


Link to post
  • 0

Thanks Pat and Jan! I did a couple of trial and error adjustments and was able to nail it. I would have not known where to look without your help! Thanks again.

Edited by Chris Fleming

Share this post


Link to post
  • 0

What I did was to use the custom units setting. I set it for 1 DXF unit = 8". So far, every molding import I've done has been correct to within about 1/64". That's more than accurate enough for my use.

Thanks again!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...