Jump to content

VW 11 2D Polys to 3D Contours problems


higgins

Recommended Posts

Hi!

I'm trying to create a site model with VW 11 using 2D Polys to 3D Contours command from dwg imported contour lines, but the instant I launch the command, VW zooms out to the print area so I cannot even see the lines, not to talk of the values written next to them.

Then, as it wasn't bad enough, it places a single contour (chosen randomly?) and offers to delete the original polygons. Polygons get deleted no matter what I pick and only a single contour is made.

Any help? :crazy:

Link to comment

Here are some things to try:

Create a new blank drawing file, draw few simple polys, and create a DTM from them to see if the command works.

If the command works in the new drawing, go back to the problem file and:

A. Make a few test DTMs with small subsets of the polys - maybe one or more of them are corrupt.

or

B. Recreate the polys - trace them and delete the old ones. I have found corrupt polys from dwg imports (don't know if it is corrupt from orig or if import does something to them). You could do this in stages - two or three contours at a time. With a test DTM for each set.

If DTM command doesn't work in the new drawing, you are not applying the tool correctly, or you might need a VW reinstall.

Also try restart the computer, perform system maintenance.

-B

Link to comment

First, make sure you are using VW 11.5.1.

Second, make sure the layer with the contour lines has ONLY the contour lines, and no other data.

Alternatively, you can convert the 2D polys to 3D Polys using the Model menu, and assign a z height via the OIP.

The 2D polys to 3D contours does the same thing, but picks the contours in order they were drawn, and you have to use the Up and Down buttons to set the z height. It sounds like the z height is next to the contour and you need to see this to set the height. It would be far easier to do this with the OIP.

The 2D polys to 3D contours does not let you adjust the viewing window in your version - it's going to fit the viewing window to all polygons on the layer.

Link to comment
What is the imported scale of the DWG?

1:500

What is the Page scale of the Layer ?

1:2000

Where is the DWG Page origin .. usually its at the lower left?

World coordinates.

Is there any 3d information in that DWG ?

That's my main problem. There doesn't seem to be (at least when imported) any 3d objects when I import "all 3d".

Okay, there is a single object off the others, at the height of 144,1 m, but I belive it's there by error.

Try viewing the imported DWG Datum using 3d Views ... what happens ?

Hmm... I'm not sure what you mean by that. Could you elaborate?

Create a new blank drawing file, draw few simple polys, and create a DTM from them to see if the command works.

Perfectly.

A. Make a few test DTMs with small subsets of the polys - maybe one or more of them are corrupt.

Was one of the first things that I tried... Separated 6 from 156 and it worked.

B. Recreate the polys - trace them and delete the old ones. I have found corrupt polys from dwg imports (don't know if it is corrupt from orig or if import does something to them). You could do this in stages - two or three contours at a time. With a test DTM for each set.

I think I resolved my issue. I imported the file as "all 3d" whili I should have done it 2d. I bet it was the "convert to polygons" command I applied to 3d ploys that messed the file up. I imported the file in "all 2d" separated the horisontals on a separate layer, composed them, converted into polygon from polylines and it seems to work now! I only have to make a pdf first to zoom in so I could see the actual heights in another window when applying them.

But what's the difference in convering in wireframe or hidden line mode?

The 2D polys to 3D contours does not let you adjust the viewing window in your version - it's going to fit the viewing window to all polygons on the layer.

Can it be done in VW 13?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...