Jump to content
Sign in to follow this  

DTM site modifier errors

Recommended Posts

i have been working on a DTM with some frustration b/c each time i try to update my site model to reflect the site modifiers i have drawn, it gives me this error message:

"pad intersecting a fence"

but i have inspected my pads & fence very closely and can not find any intersection!

i have several pads at different elevations drawn within one fence--is this a problem?

one of the pads is for the basement so it's elevation is far below the lowest contour--maybe there is a better way to show excavation of the basement on a site model?

Share this post

Link to post

Do you have any plugins that might have a site modifier hidden within? Things like road objects, landscape walls, massing models or hardscapes can have pads hidden within.

Share this post

Link to post

there are no pads intersecting and

no plugins on the site model layer.

i use VW 12.

nocholas-i'd like to avoid redoing the site model completely--you said you regenerated your site model with the same data, can you elaborate?

i first generated my site model by importing the surveyor's plan as an image file i had scanned, traced the contours with polylines, converted the polylines to 3D contours then created the site model. i remember a pop up window asking if i wanted to keep the original data in the source layer (or something like that), but i think i chose no. do i need to start over from the point where i traced the contour lines with polys? do i need to redraw the site modifiers too?


any other suggestions would be greatly appreciated!

Share this post

Link to post

If you've lost the source data then you may have to retrace it.

I never delete things like that due to personal insecurity and paranoia.

If you have the source data from which the DTM was made, all you do is run the Create DTM command again with the data and the modifiers you have already made.

It just builds a new model. You might have to reset things like the contour interval,

but otherwise it's just a matter of setting it off to run.

I have fixed the fault you described on a number of occasions like that.


Share this post

Link to post

Try using only one fence around all of your site modifiers. Make sure it doesn't touch any of them or extend beyond the DTM boundary. Also try making the 2D and 3D options Proposed Only and see if that makes a difference.

You can recover your polygons by:

- Removing all of the Site Modifiers.

- In Top / Plan View convert the DTM to a Group (Convert all sub objects)

- Delete the border and use the contour polygons to create a new DTM.

I suggest you do this on a copy of the file. Being redundant whenever you are doing anything that could be risky can save a lot of angst if it all goes pear shaped.

Edited by mike m oz

Share this post

Link to post

To recover your source data simply select the site model. Use the menu command (it must be from the menu in vw 12) to 'edit group'. Select all, copy. Exit the group (site model) and paste.

Don't delete all your site modifiers yet.

Also check to see that only used modifiers on current layer is turned on. This can help isolate the offending result. You don't have a nurbs road do you?


Share this post

Link to post

i've tried regenerating the site model from my existing data, but as soon as i put the site modifiers in i get the same error message of a pad intersecting a fence. i tried removing all but one pad and the fence but again--error...i tried starting with a new pad and a big fence around it, but nothing changed when i hit update.

maybe i am not using the site modifiers properly?

i am trying to excavate a basement by drawing a pad and putting it at the proper elevation for the basement floor(which is 8' below the lowest contour elevation on my site model--is this a problem?

is there a better way to show a basement excavation so that when i show the architectural model the light wells don't look like they are filled in?

i was also trying to use pads to define the different elevations of the garage floor, the main floor of the house, and the courtyard.

in the site model layer i am working on, i have only the regenerated site model, four pads at different elevations, and one fence surrounding all the pads (with no visible overlapping). i don't have a nurbs road or any plugins.

Share this post

Link to post

(which is 8' below the lowest contour elevation on my site model--is this a problem?

That's a good question. I've never tried it, but it seems logical that this *might* be causing the error...What does NNA say???

Share this post

Link to post

Pete, I thought you had sussed it but not so. I tried a scenario with the pad modifier lower than the lowest contour and the result is okay as long as you include a fence around the pad modifier. If you don't have a fence though the error message of "Pad which does not lie inside a fence" comes up and the result is wrong.

Share this post

Link to post

i simplified my life by tracing the footprint of the basement, extruding the poly, and then subtracting the extrude from the site model. good enough!

thanks for all the suggestions!

desiree lee

Share this post

Link to post

A couple of general suggestions:

Make sure none of your pads touch each other. Also make sure your fence doesn't touch any pad or the edge (hull) of the model. If you have any roads make sure "use fence" isn't checked.

From the downloaded picture it looks as if some of your pads are touching each other and your fence is very close to the hull at the top.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...