Jump to content
Sign in to follow this  
Melshimber

Leopard & 12.5.2

Recommended Posts

Hiya

I have a copy of Leopard and 12.5.2 and am disturbed by Nemetschek's method of trying to get everyone to update to 2008. The lack of a timeframe for the update of 12.5.2 is shocking especially considering the 2008 was updated prior to the full release being available. I hope you are all working very hard to get us a proper solution to these 'substantial functional problems'.

I am afraid to say I was also very disappointed with your press release as listed below.

VectorWorks 12.5.2 Compatibility

NNA has tested VectorWorks 12.5.2 with the latest seed versions of Leopard available to us, and we have found that it has substantial functional problems. We plan to evaluate these problems after we receive the final release of Leopard and will then determine how we plan to address them. We will provide more information as it becomes available.

Extremely annoyed.

Share this post


Link to post
I have a copy of Leopard and 12.5.2 and am disturbed by Nemetschek's method of trying to get everyone to update to 2008.

Er, nobody's forcing you to upgrade to Leopard. I find it rather perplexing that you're shocked and disturbed.

Annoyed, I understand. But with NNA?

Share this post


Link to post

NNA must have know about the update issues. If they had sent out a mail to their resellers they could have warned their customers not to get overly excited about Leopard unless they update to 2008. Without a statement by NNA why they did not share their experiences in the past months many will feel annoyed and for a good reason.

Anyhow, it might be comforting to know that for me, the update to Leopard and VW2008 is a big improvement, I love it and would not go back to 10.4 and 12.5

Share this post


Link to post

Two years ago? Even a year ago? I don't think so. Mr. Apple is no more forthcoming than Mr. Nemetschek. Tens of my objects & scripts need to be reworked, hundreds of hours need to be spent.

If all that would just go away by buying a cheap upgrade, I would not spend hours on this board complaining.

Share this post


Link to post
Er, nobody's forcing you to upgrade to Leopard. I find it rather perplexing that you're shocked and disturbed.

Annoyed, I understand. But with NNA?

Leopard is on the whole a better operating system than Tiger - it has generally improved the stability and speed of my computer (which I was surprised by!) and why would we not want to upgrade when there is an obvious improvement to the speed of completing simple tasks when going about my work?

If we as consumers don't voice or opinion to the manufacturer then how would they ever know we want an upgrade to at least make it passably operable? At the end of the day it is their choice to decide if I am a minority voice or not but I wanted to be very clear about my thoughts on the matter.

As for the software being two years old - we were until recently a small firm and update software much more slowly than larger more established companies so we have not had the software for 2 years. Software is still a big purchase and it would be good to know it has a bit more life yet! (assume we place to upgrade in a piecemeal format). A lot has been said on this issue, but that does not mean it is unimportant to say it again! :)

Share this post


Link to post

Mike,

You are - as you say - a firm, not even a small one. You are not a consumer.

Nevertheless, when you bought VW is irrelevant. What you have has as much life in it as you give it. Just don't upgrade the OS! No-one is forcing you. Growing? Instead of brand-new computers, buy second-hand machines - especially as you seem to be cost-conscious. Or does that only apply to the software you use to earn your livelihood?

Share this post


Link to post
and why would we not want to upgrade when there is an obvious improvement to the speed of completing simple tasks when going about my work?

Heh, the exact same argument could be made about VectorWorks 2008.

My point was that NNA has no control over what operating system you choose to use. They've told you which system v12 is compatible with. It's your choice to use one that's not.

I'm not suggesting NNA shouldn't issue a bugfix for v12 to work under Leopard. I just think it's unjustified to criticise them for not issuing before the retail version of Leopard had been released.

Share this post


Link to post
NNA must have know about the update issues.

Don't blindly make the assumption that NNA knew about the problem. For those who aren't aware, Apple is FAMOUS for making last minute changes to their OS leading up to the public release, often leaving developers in the lurch. The problems that have arisen with VW12 and Leopard may have simply been unavoidable.

NNA has a proven history of doing the right thing with respect to solving these issues.

V-G.

Share this post


Link to post

regarding the "no one is forcing you to upgrade"

we need to buy a new mac for a new staff member starting soon, try ing to find a copy of vw 12.5 was tricky enough, now i have to find a mac for sale with 10.4... apple dont sell 10.4 anymore.

or should I just wait for the indeterminate period of time until vw gets sorted.

we cannot afford to upgrade the whole office to 2008 yet... and with the problems listed here i would wait a few months anyway. this current situation is very poor.

Share this post


Link to post

Can you buy a copy of OS X Tiger off the internet (ebay or the like)? You should be able to set up a multiple OS install, so you can switch to Leopard when you have a compatible version of VectorWorks. Amazon.co.uk has some folks selling it, or you could look to ebay or the like.

Share this post


Link to post
now i have to find a mac for sale with 10.4... apple dont sell 10.4 anymore.

[snip]

this current situation is very poor.

Are you saying that it is impossible to buy a second-hand Mac with OS 10.4 in the U.K.?

Is there a market for such machines there? I could easily source a few hundred in a week or so.

Share this post


Link to post

I would have thought until new stock arrives from the factory with Leopard pre-installed the machine you are likely to still buy a machine with Tiger installed and a leopard on a disk to install when you see fit.

Even after such time the until a machine sees a refresh of hardware it should be able to be downgraded to tiger with the old installer disk.

So you don't even need to buy second hand just talk to your mac dealer about where you stand whats coming up and how they can help you. Business is about relationships after all.

Edited by iboymatt

Share this post


Link to post

1. With new yearly upgrade likely, there may not be any further x.5 releases of VW. Just something to think about in making your plans.

2. If you have install disks for Tiger, you could always buy a copy of Leopard so you have the license, but install Tiger. If Apple sues you over this I will contribute to you legal bills.

Pat

Share this post


Link to post

To add a bug to the list:

After upgrading the OS (not by my choice, thanks) classes are un-editable for me in any way. Sometimes I can open the window to edit classes, sometimes it crashes my program. I can't add a class without crashing the program. I can't select classes.

I am experiencing this as well as the hatches-on-ruler, hatches covering the newly-exposed area of a drawing during panning, invisible lines and objects during drawing and moving, and some corrupted files.

I'm not intending to join the to-upgrade-or-not debate, but this seemed the most likely thread (on approx. 10 min review of forum) to post my experience/bug in.

Edited by Joz

Share this post


Link to post

I am in the same situation as JOZ above, I am experiencing exactly the same problem, small office, we purchased Vectorworks 12 only few months ago and we don't intend to upgrade Vectorworks before another few months.

It put us in very annoying situation as we all enjoy the benefits of OS Leopard.

I am not interested (and don't have time) in joining useless debate with some very antipathetic person who writes on this forum (hello petri..)

But I wish there would be Nemetschek people telling us in this thread that some efforts are done to fix the bugs and release and update.

Thank you.

Share this post


Link to post
But I wish there would be Nemetschek people telling us in this thread that some efforts are done to fix the bugs and release and update.

They have.

Share this post


Link to post

I am in a serious quandary here. I read these boards, and then called in to the Nemetschek Tech Support line to ask about the timeframe for the 12.5.2 fixes. The tech support guy told me that they were trying to decide "IF" they were going to release a fix for the problems. I was under the impression that something was definitely going to be released, so I asked again, to clarify, and was told the same response.

I expressed my disappointment, given how recent a release version 12 is, and that I wasn't ready to upgrade to 2008 yet, since it is so expensive. I reminded him that right on the side of the box are the words "CAD for the Smart Sized Firm", and that this smart sized firm can't afford every single upgrade. The next words out of his mouth floored me: "If you can't afford to upgrade Vectorworks, how can you afford to upgrade your OS?". When I explained that I upgraded my OS because it was only 10 dollars, due to purchasing my new mac in the last month, he said "Well, gee, isn't a new Mac about $2000.00? If you can afford that, why can't you afford Vectorworks 2008?".

My next question was met with even more idiocy. I asked about the poor souls who had purchased Vectorworks 12.5.2 new (not as an upgrade) only months ago, to now find out they are screwed. He responded, "If they don't like it, and they are within the warranty period, they can return it for a full refund." Well, gee, there's one way of TAKING CARE OF YOUR CUSTOMERS.

#1: I don't owe this idiot any explanation for how I choose to spend my money at my firm. Despite that, here is how most of us do things: 1) We plan a new computer purchase because we are facing a hardware limit. 2) We upgrade our OS, so that we can then plan to upgrade our software packages in the future. 3) We THEN upgrade our software as we can, taking advantage of the new OS. To do this in any other order doesn't really make sense.

#2: This is, to coin a term, downright "AutoCadian" in nature. Forcing LOYAL users like me to purchase each and every single upgrade is ridiculous. Nemetschek's statement that they didn't have a final release of Leopard to use 12.5.2 on is ridiculous. How in the world does 2008 work with it??? To not support a software release that is only months old is just inexplicable. Somehow, my old copy of version 10 still works on Tiger, despite being years apart in their respective releases.

#3: My firm, which is ME, has thousands of dollars invested in Vectorworks. We upgrade EVERY OTHER RELEASE, because that is the only way we can afford to. Forcing us into the AutoCad model of constant upgrades will force us to another CAD system, one which appreciates its customers.

If Nemetschek comes out tomorrow with a total fix for 12.5.2, then I take it all back. But, I just don't understand how someone can make their brand new product totally compatible, while saying out of the other side of their mouth that they had no way of testing their previous product with the same operating system. It just doesn't make any sense.

Someone from Nemetschek SERIOUSLY NEEDS TO DO SOME DAMAGE CONTROL HERE. Who knows how many of us are out here in the same situation: using what we consider to be a current product, only to have the rug pulled out from under us, with almost no explanation from the company to which we have forked over thousands of dollars to. SOMEONE FROM NEMETSCHEK PLEASE TELL US IN DETAIL WHAT IS GOING ON, AND WHEN WE CAN EXPECT A FIX. PLEASE!!!

Share this post


Link to post
Guest

Kerry,

I understand the situation you are in. As soon as we discovered the issues with VW 12 and Leopard, we alerted users via the Knowledge Base, our home page, this forum, and various user listservs.

It is not uncommon for an OS system to change between the beta versions issued to manufactures such as NNA and the final build. Often, the changes are significant between OS releases to manufactures.

The engineering team is working on a way to address the issues between VW 12 and Leopard. As of right now, we do not have an anticpated fix. We appreciate your patience while we work on resolving these issues and maintain quality in VW 2008.

Share this post


Link to post

I feel your pain and agree with the gist of your sentiments, Kerry.

NNA has been very good to us and our 3 licenses in the past, including discounted software upgrades at local trade shows, and because we have been LOYAL customers over the years. I trust that they will do the right thing.

That said, I would agree that not every upgrade is necessary, and the decision is ours to make, and not to be forced upon us. In fact, our situation is that an upgrade to our OS is on $199 (family pack) vs. nearly $1,500 for the 3 licenses we have of VWA 12.5.2. That too, is a big difference. And it is true, the new OS 10.5 (Leopard) does make it feel like we have new Macs, and would increase our productivity and enjoyment of use in a work environment. I definitely relish the time I use my computers at home, which have Leopard. Alas, I can't bring that upgrade into the office environment as VWA will not work properly.

End result: no upgrades to Leopard OR VWA 2008. Hmm. There's a silver lining here: A savings of over $1,700!

Let's keep hope alive.

Edited by Speedy Gonzales

Share this post


Link to post

"If you can't afford to upgrade Vectorworks, how can you afford to upgrade your OS?". When I explained that I upgraded my OS because it was only 10 dollars, due to purchasing my new mac in the last month, he said "Well, gee, isn't a new Mac about $2000.00? If you can afford that, why can't you afford Vectorworks 2008?".

Our worst fears have been realized. Petri is working the customer support line at NNA.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...