Jump to content

Vectorworks 12.5.2 Crashes 10 times a day with NVIDIA software!

Recommended Posts

I have been using Vectorworks since the old Minicad days and it has never given me so much grief.

My system just hangs no particular event or set of procedures seem to set it off, it might just be moving a group of objects or adding text. Does not make any difference if other programs are running.

I have reinstalled updated used the standard workspaces asked friends the distributer but I'm spending so much time watching the machine reboot its driving me mad.

If anyone out there knows what's going on I would appreciate it . maybe not financially but you will feel good about yourself!

Im using XP Professional 64 bit version SP2,

(I use the Cinema 4d 64bit software with the Vectorworks plug a lot)

Vectorversion 12.5.2 Fundementals

Intel 6600 Duel Core 2.4Ghz

2 Gig Ram (would have 4 but Vectorworks crashes on boot with 4 Gig)

90 Gig of free space on HD.

Others in the office don't have this problem using the same workspaces and templates.

Many thanks

Peter Card

Van Den Berg Design Team


Edited by Pharr
Link to comment

No error messages, just hangs.

I have the updated Nvidea unified driver (the 64bit version for XP64) GeForce 7600 gt 256mb Ram! a few months ago, ill dig around and see if there is yet another update.

Many thanks for your interest.

Manifest from forced shutdown.


UI LCID=1033



TitleName=VectorWorks Application

DigPidRegPath=HKLM\Software\Microsoft\Windows NT\CurrentVersion\DigitalProductId

ErrorText=The program is not responding.

HeaderText=You chose to end the nonresponsive program, VectorWorks Application.

EventLogSource=Application Hang








Peter Card

Link to comment
I have reinstalled updated used the standard workspaces asked friends the distributer but I'm spending so much time watching the machine reboot its driving me mad.

A terrifying scenario we can all understand and appreciate... worst nightmare comes to mind.

But not the end of the world as we know it, yet. There's got to be some resolution.

Monitoring the Processes via sampling may help ... getting a CrashLog with stats, too.

Try this trick ...

disconnect from printers, & network and all externals except mouse & keyboard.

Open a new clean file and begin working on something simple ... using the basic Tools only ... work at 1/2 speed of normal. Save often ...see what happens ...

be patient ... study everything... the answer is there somewhere.

You will beat things demon ; )

Link to comment


My machine worked fine with ver.12.5.2. With 2008, I am getting screen flickering, unexplainable slow downs, to the point of hanging. I am trying to isolate the issue, but have not seen anything that I can repeat other than it happens after an hour or so. I have updated my video drivers. I do find that when placing plants with the poly-edged space mode, that I have to move alot slower and can not pan the screen or I loose the string of plants.

Link to comment

Another problem with the NVIDIA GEForce 7600 video card!

Peter, just for kicks, you might swap out your video card and see if that doesn't solve the problem. A couple of other users have reported problems on machines with that card.

I've been running 12.5 on an x64 machine for about a year with no problem (different video card, though). x64 seems to emulate 32 bit processing just fine. I'd be curious to know what problem you had with 4 gigs of RAM, since I'm thinking about upgrading my 2 gigs.

Link to comment

Just tried installing 4 gig again! with Vectorworks in windows xp compatibility mode, didn't work.

After a long delay I get a message about telling Microsoft about the problem!

Very upsetting as I got XP64 because it addresses 8gig of ram and Cinema 4d produced a 64bit version of their program and it all appeared like a good package until Vectorworks refused to work with more than 2 gig.

I'm going to try Vectorworks on my Vista machine with 4 gigs. Ill let you know how it goes.

Thanks for the tip re the video card!


Peter Card

Link to comment

Peter, what is "windows XP compatibility mode?"

Okay, researched that myself. I have been running without checking that option for almost a year, without experiencing problems. From what I understand, if you are in compatibility mode you may be unable to run 64 bit programs, and since some of those are part of the system, you might run into some problems. In fact, I wouldn't be surprised if this is the reason you can't run with 4 GB RAM. It's worth a try anyway, and I have an ulterior motive in getting you to try in that I'm uncertain whether to upgrade my RAM!

I don't know why you are opting to use compatibility mode, but on my system the 32 bit emulator works just fine without resorting to compatibility mode. BTW, with 64 bit you could install 128 GB RAM! (assuming everything works and your buss could handle it!)

Edited by P Retondo
Link to comment
  • Administrator

Hi Peter,

This thread started discussing severe hangs and/or crashes which seem tied to something unique about your machine and then the thread turned to discussion of problems when running with 4GB of RAM.

What has become of the original problems? Are you still having them? Did you change something about your video card? Please give an update.

We do know about a problem which prevents you from running VectorWorks on a Windows 64 bit (and possibly also 32 bit) operating system machine containing 4GB or more of physical RAM. We have investigated this and will provide a way to get around this limitation shortly. Until then, you should go back to a 2GB configuration.

BTW - can you mail me at pharrnemetschek.net so I can get more information from you on this.

Link to comment


I have pulled this thing apart a few times and have removed the sound card, swapped over the SIMMs, reinstalled xp 64, formatted the HD and reinstalled xp64, reinstalled all the programes, updated all the patches, downloaded 100's of mb of windows updates, run VW with the standard workspaces and rebuilt my default startup sheet.

It still crashes! i'm getting a 6 sense about it now and save every 5 min, but many of my files are over 200mb and take over 30 sec to save!

but I must say its only crashed 3 times today since I updated the Nvidia driver all 55mb of it!

many thanks for your encouragement. I appreciate it .


Peter Card

Link to comment


The discussion thread suggested that I may have a hardware problem and asked if I had changed over my RAM, I had already swapped over my simms when I tried to install additional RAM.

I have had 2 gigs on my desk and 2 gigs in my PC for some time now and am eagerly awaiting the bug fix.

I have installed an updated Nvidia driver and am please to report that I have had only 3 crashes this morning! Though I am working on smaller job today.

Many thanks for your concern. Ill email you directly.


Peter Card

Link to comment
  • Administrator

I have installed an updated Nvidia driver and am please to report that I have had only 3 crashes this morning! Though I am working on smaller job today.

I'm glad you are pleased with this small victory, but I can say that 3 crashes in a morning is still quite atypical (and unacceptable) in our experience, and I think there may be more to find. The primary reason we hesitate recommending XP 64 is that the drivers are generally a little more fragile & this may be involved here somehow. Keep me updated.

Link to comment

Hey, sorry to double thread - i just started a thread named, 'vectorworks keeps crashing' and now i see this thread, and it seems to be the same issues.

below the line is a cut and paste of my thread - its perhaps a little more detailed than others so i'll post here for you to read:

I hope it gets resolved.


I seem to be having some full on issues with my vectorworks.

HP dv6000 Laptop with

Intel core 2 cpu with T5500 1.67Ghz

2Gb ddr2 ram

Nvidia go7400 256mb (128 dedicated 128 integrated)

Windows Vista Home Premium

Vectorworks 12.5.2

Last week it would crash on me within the first 3 or 4 minutes of openings when I went to do anything with some 3d imagery ? very simple stuff, not large files either, just starting the files up for a uni project, and it kept crashing on me. So I couldn?t do 3d at all which was frustrating enough. And yet it worked fine on anything that was 2d. I have done 3d in the past with no problems, big files too.

When I say crash I mean this: it stops responding out of the blue, so that you can still move your pointer around, and open into other programs and all that, but when you sit your pointer over an icon it wont let you select anything, eventually it states ?vectorworks is not responding? and puts up the loading icon (vistas circle) ? I left it on one night to see if anything happened and it kept doing it all night ? in other words it will never respond, its crashed.

Well now it wont even open at all, as of Wednesday night it just stopped opening ? it tries to start up and then I get this message:

Vectorworks Application has stopped working

Windows can check online for a solution to the program

- check online for a solution and then close the program

- close the program

View problem details:

Problem signature:

Problem Event Name: APPCRASH

Application Name: VECTOR~1.EXE

Application Version:

Application Timestamp: 4654d31b

Fault Module Name: QuickTime.qts

Fault Module Version:

Fault Module Timestamp: 4684a825

Exception Code: c0000005

Exception Offset: 001004f5

OS Version: 6.0.6000.

Locale ID: 5129

Additional Information 1: 720c

Additional Information 2: 87abfdde4e44868a2d32f6948e899598

Additional Information 3: 072c

Additional Information 4: a4dad178cb668e0ad64c9732c853becf

Read our privacy statement:


It says its a quicktime fault and I recall having some initial issues with it crashing a few months ago when i first got it and it turned out to be a quicktime thing, so I installed the latest quicktime and that fixed that. I have since tried that again to no avail?? I have uninstalled quicktime and reinstalled different versions etc - nup!

I thought maybe it was an issue with the graphics card driver? But I have updated that too ? from both the nvidia driver website, and the hp website and the vista updating driver thing ? I have even uninstalled the driver and reinstalled ? nothing. I have done system restores from earlier points and that hasn?t done anything.

Something appears to be not compatible ? I?m assuming it?s a mix between vista, nvidia, and vectorworks.

I have up to date antivirus software and adware remover ? so I?m positively sure its not a virus of any sort.

Any solutions?

Anyone with the same issues?




Link to comment

Matt, I had similar problems a while back with 12.5.2, and had thought I had a corrupt file. I ended up removing VW and reinstalling, and the problem immediately disappeared and everything has been stable since.

The signature of my problem was that when VW stalled Task Manager indicated that one processor was occupied with a VW task.

Link to comment

Wayback when the 16bit OS was being migrated to a 32bit OS ...Apple was also switching from the 16bit Motorola68000 processor to the 32bit PPC processor.

Most Users at the time were unaware that the new PPC Alpha computers were shipped with both the 68030 and the PPC chipset.

The MacOSv8 also included emulation code to run on both as required. This remarkable effort resulted in the most successful transition up to that time and Minicad survived to fight another day because of it. However, the added horsepower demanded increased RAM to avoid persistent out-of-memory crashes.

RAM SIMM was very expensive at the time. Those were...indeed.. the white-knuckle days.

Those experiencing similar issues today ... need to know that we ALL feel your pain and share your frustration to the very depths of our CAD soul.

Link to comment

Islandmon, thanks, much appreciated sympathy. I'll send you a handful of hair as a token of appreciation!

To uninstall VW, check this board for recommendations by Katie. You basically delete the VW folder and the associated Nemetschek application data in user settings, and you can also manually delete registry items (usual disclaimers about not tinkering with the registry unless you are familiar).

Link to comment

GDI imaging seems to be involved in my crashes. If GDI imaging is checked on and if there is text in the drawing, many of the TrueType fonts will cause an immediate crash of VW2008 when I try to print. (HP 8050)

If I export to PDF with GDI imaging on, the text is absent.

Some fonts (even odd ones like "EraserDust") work fine, and cause no problems with GDI imaging on.

BTW, my video card is NVIDIA GeForce FX Go5200

Edited by Lefty
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...