Jump to content

HELP! Vectorworks 12.5.2 crashed, and now my file crashes it every time!

Recommended Posts

Oh god, I knew this would happen someday.

I have a file I've been working on feverishly for hours and hours. I save every 15 minutes, but a lot of good that's doing me right now. I was editing a symbol with a fairly large amount of geometry inside (actually trying to make it simpler - changing out a-19 bulb symbols for simple representative extruded rectangles...) and Vectorworks bailed out. Now after restarts/removing plugins/etc trying to open THIS file specifically crashes Vectorworks. The file used a complicated symbol from another file, and the feeder file with that symbol opens fine. The main file starts to open, draws the frame of the window, then Vectorworks bails out.

I MUST RECOVER MY WORK IN THIS FILE. I back up every night to my laptop and to a backup server, but have had to stop that process/rename the corrupted file so it doesn't overwrite the good but almost 24 hours out of date file.

Is there ANY way, ANY tool whatsoever, to dig into a file and recover it? Even if I have to send it to the mothership and pay a fee or something.

Thank you in advance,

William Mc.

Link to comment


There are several things you can try.

1. Create a new blank file and use Workgroup References to bring in the data from the corrupt file. This may get you back everything on the design layer, but will probably not get you sheet layers or annotations. Since you have a 24 hour old copy, duplicate that and see if you can paste the referenced data into that file.

2. Open the VectorWorks Preferences and click the button that says, Reset. This will delete your preference file, and create a new one. It will automatically put your registration and serial number in the new file. You will have to go back and reset you preference to the way you like them after the reset. Since you say that it is only this only file that is causing problems, this is probably a long shot.

3. Restart you computer.

4. Reinstall VW.

5. Call/send the file to Tech Support at NNA. If there is data there, they can usually help get it out. I put his one last only because it will take the longest to get results.

I am going to take your problem as an opportunity to advocate for using the Save to a separate file in backup folder option in VWPreferences:Session. This option creates a VW Backups folder in the same location as your file is saved. With the option turned on, every 5, 10, 15 minutes, when the autosave runs, the file is saved to this folder, not to the orginal file. In your case, this would have probably resulted in a good file only a few minutes old rather than a day.

I hope you get this solved soon.


Link to comment


Thank you VERY much for replying to my plea. I agree with you about saving to separate files and am sort of angry at myself for not taking a minute to set that up since the feature is there for us to use. However it's sort of shocking that an "a-list" application like this still has the capability of eating it's own files. I expect open source and shareware to munch itself spectacularly, not an application that costs a great deal of money with a massive user base. Enough editorial for now.

I've tried step 1 you detailed above. Upon choosing the file in the workgroup reference dialog box, no layers are found. When testing and poking around choosing other drawings, the layers are found so I'm assuming there's truly a deeper problem with this file. I'm sure the layers were there!

I'm reserving the right to not bother with steps 2 and 3 just yet as the file produces the same crash on another machine with a VectorWorks 12.5.2 install ( I own the dongle'd version...I suppose I could try opening it on a PC...), and this morning I got a response from Tech Support at NNA asking me to send them the file, which I've done.

Wish me luck, and any other suggestions are welcome.


Link to comment

My experience may not apply to you, but I recently had a problem with VW freezing every 5 to 10 minutes. The crash was so bad I had to restart my computer each time. I thought I had a corrupt file, but unlike you I was able to reference the file into another. In the end, I reinstalled VW and the problem went away.

You may in fact have a corrupt file, but reinstallation only takes a few minutes.

Link to comment

Well, I have to give huge kudos to NNA for getting back to me quickly, and escalating the problem up the chain. They took my file, tried opening it, couldn't, forwarded it on to a senior engineer who works with file structures and the like, he couldn't open it either, so the drawing was lost. They really responded fast, but the answer sure wasn't what I wanted to hear. I spent about 6 hours today re-drawing the drawing.

I'm remembering my first serious outing with an application from the past called Design Workshop. One of the coolest 3d drawing concepts ever wrapped up in one of the most unstable, screwed up applications you can imagine. Same thing happened to me with that except it was about 12 hours straight to re-draw the drawing.

Okay, fine. Lesson learned. I'll use "back up to a new file" religiously now. I shouldn't have to because applications shouldn't have problems like this, but that's an entirely different discussion. The engineers say "there's not really much there to recover", but there's definitely something there because I can add the corrupted file to the resource browser, and it's symbols and views become available.

That's really the only upside to this little debacle. Oh well. I guess thousands and thousands of dollars spent on one of the costliest end-user applications out there doesn't get you any more bullet-proof performance than a $49.00 piece of untested dreck from the shareware or open source cesspool. Just my two cents. And my one drawing for the man-hours of two.


Link to comment


It is always very frustrating when this happens, but my experience is that most often when you get a file corrption like this, it is probably a hardware issue rather than software.

VW12 has been out for almost 2 years. Yes, you sometimes hear of a corrupted file, but not often enough for me to think it is a software problem. That is the reason I strongly advocate lots of backups, on multiple media, in multiple locations. One of the announced features for VW2008 is an improved autosave. I hope that will be turned on by defulat and will help in situations like this.

More likely a power fluctuation during a save, a memory chip problem or a hard disk problem. It could even be a magnetic monopole running through your hard disk ;-)

Blaming the hardware/software for lost date/time is similar to blaming your cruise control for a speeding ticket.



Link to comment

I have had one instance with the total loss of a file. I was creating many, many symbols and building a library. Names costs etc. saving every 3-5 minutes. At one point, the program began giving me strange error messages like 'duplicate symbol name; please choose another name' type of error, so I quit vw then re-opened and found that the file was totally gone. Corrupted and not recognized by vw, I went to file info and it had 0k for file size.. I was'nt happy. I believe that something in the mass symbol creation and quick, repetitive saving overloaded vectorworks's brain. But that's just what I believe. Hope this helps in some strange way.

Link to comment

Sometimes we get so involved in what we are doing that we forget that every movement & click generates a command thread for the processor to chew on.

Protocol requires discipline & pacing with occasional Saves in between all the actions. Exuberance combined with experience is a heady cocktail.

Take a look at GNU> Subversion for recursive file recovery across networks.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...