Jump to content

Load Import/Export Settings Not working

Recommended Posts

I have used this function successfully for the last couple of years moving data back and forth between LW & SL until this morning.

I seem to be able to Export from SL using a Saved Export Mapping.

The problem seems to be with the Import, when I try to Load the saved Import Mapping I get the Error Message

"File does not appear to be a valid settings file".

I have tried to Resave new Mapping Files but with the same result.

Possibly something in 12.5.2 ?

Link to comment

So I Started from scratch, made a simple drawing with 6 lamps with various bits of data in all the categories that I wished to Export.

I then Export from SL and Save the Mapping File.

I Import into LW and Save the New Automated Action

Make a few changes and Export and Save the New Automated Action

I now go back to SL, Browse to the file I want to Import, AutoLink and then do a little rearranging, Save the Mapping file , I then Import.

Everything works fine.

If I try to Import the same file and Load the same Import Mapping File that I just created I get the error message.

For some reason SL does not recognize the Mapping file that I have just Saved as a "Valid settings file".

I have just reinstalled 12.5.2 with the same result.

Link to comment

But, are they actually labeled WITH the extension? i.e. "import_mapping.txt" and not "import_mapping"? I just removed the ".txt" from my import mapping file (the one that I always use) and got that same error that you are getting. On my computer it only works if you can actually see the extension listed, regardless of whether it shows up as a text file when you do a 'get info' on the file.

Link to comment

I am indeed. Exact same setup as in your signature. I can't imagine that it would make a difference, but you might try using all the settings that I posted at http://tinyurl.com/3by8mp

That's complete documentation of how I export/map/import and merge between LW and Spotlight. But, I'm not convinced that that's the problem you're having, since it seems that you're able to keep moving information back and forth, it's just that you have to manually set up all of the parameters each time that you're going from LW into Spotlight. Ugh!

Link to comment

I did go through your documentation and compared it with my own Routines, everything matches up, and, as we know I can maneuver the Data I just cannot Store the Mapping File so that I can Load it again.

I wish I had seen your Documentation about 2 x years ago when I was trying to figure that all out, very nicely done !.

As a side note (and I realise this is getting a little boring); I can Load a Saved Export Mapping file to Export out of SL, however, as soon as I try to Load an Import Mapping file and I get the Error Message I then am unable to Load an Export Mapping file without getting the Same Error Message, it seems that once that Error message appears everything goes Pear Shaped.

Anyway, Kevin or Katie if you have any ideas I would appreciate it.

Link to comment

I just recieved an email from John regarding this issue and this is what he had to say.

"As I recall, I filed it as a bug report with NNA some months ago. Version 12.5 won't open saved mapping files for me, either.

I don't know whether the problem is in the saving or in the opening.

Perhaps if someone else has a mapping file they're successful with, they could share it with you"

Link to comment


I just went and exported data from VW12.5.2 using the - export - export insturment data - clicked the LW button and exported.

I went to LW 4.1.6, used my automated import that I have been using since I got 12, changed some data and used the auto export, again that I have been using since 12.

I went to VW import instrument data - browsed to the file clicked Ok then loaded the import mapping file I have been using all along and it all imported correctly and the updates were correct.

I don't know why John was having a problem.

I did get one Orphan.

Link to comment

Hey Simon,

o.k. this might be a stretch, and is based on my extension theory, but try this: Go to the Finder Preferences, Advanced. Select the "Show all file extensions" button. Then recheck to make sure that the .txt is showing up. Solved?....

I don't think that this is a LW problem - it seems like VW to me.

Link to comment
  • Vectorworks, Inc Employee

We need to do some more investigating to see what version the problem started but it looks like a Mac only problem.

Unfortunatly at this point it looks like it's not a problem with the mapping file, but a problem with the import command on the Mac.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...