Jump to content
Sign in to follow this  
Chuck

Polygons & changing vertices

Recommended Posts

I have experienced the following problems with v8.5.1 - drawing a polygon with normal (corner) vertices as the selected mode, after a few mouseClicks (corner vertices) the vertex mode switches without warning to creating bezier vertices with each mouseClick. The mode bar still indicates corner vertices are being created!

I have tried various constraints settings with the same result. I have tried varying the speed at which I draw the polygons with the same result. I do not have a loose finger sitting on the U-key modifier.

Any thoughts???

Share this post


Link to post

I have experienced this problem in several previous versions. I am currently using Architect and it still happens. I haven't found a cause or solution. Any ideas out there?

Share this post


Link to post

I forgot to say I'm on a G3 Mac. I would love to solve this problem as it is driving me crazy.

I don't remember this problem with version 8.0.1.....

Share this post


Link to post

Is there not one other person out there in cyberspace who is afflicted with this problem???

Share this post


Link to post

Chuck,

This is a thoroughly inexplicable and annoying problem that has existed with VW from when it was MC. I usually just start over, or go back in and modify the vertex.

Sorry I couldn't help, but at least misery breeds company ...

Andrew.

Share this post


Link to post

Thanks Andrew,

Another annoying little bug which takes the gloss off the marketable image for VectorWorks!

Let us live in hope that we get an official response from the techBoffins at Diehlgraphsoft with an explanation, a workaround or a promise to fix it soon.

Chuck.

Share this post


Link to post

I had never noticed this problem until I read your description of it and sure enough it happened to me too. I too couldn't seem to get it to stop by changing costraints. But then I found that if I moved the mouse, ever so slightly, after pressing the button but before lifting up on the buton it would create a bezier Vertex. I then tried drawing a polyline quickly once again, but this time I made sure that I fully released the button before moving to the next vertex. This time it didn't cause the switch in vertex type. This is on a pc so it might not be the same as the Mac version. Perhaps changing the sensitivity of the mouse pointer would help if this is indeed the problem. I'm guessing on this.

Share this post


Link to post

Thanks Marc.

I'll give it a try and get back to you.

Chuck.

Share this post


Link to post

Just a short update on the polyline vertex bezier-snap change from a corner vertex in the middle of drawing the polyline.

VW 8.5.2 HASN'T SOLVED THIS ANNOYING PROBLEM!!!!!!!!!!

Grrrrrr!!

Any chance of the techPeople advising of a work-around on this one??!!

Chuck.

Share this post


Link to post

Are you people using the polyline tool?

I use the polygon tool (note the different name) for drawing sharp corners and this has never happened to me.

Share this post


Link to post

Yes you are right - the Bezier-default vertex point mid-line-draw happens only while using the "Polyline by Corner Point Tool." There are no similar problems using the "Single-Line Polygon Tool".

While I am pleased that I can still draw corner-vertex polylines & polygons using the alternative tool without suddenly turning into a Bezier polyline, I would still like the apparent problem with the "Polyline by Corner Point Tool" fixed or at least explained by the techBoffins.

The lack of 'official' response from DG perhaps reflects a certain inability of the programmers to get to the bottom of this problem???

Any techBoffins care to explain??

Chuck.

Share this post


Link to post
Originally posted by Chuck:

Just a short update on the polyline vertex bezier-snap change from a corner vertex in the middle of drawing the polyline.

VW 8.5.2 HASN'T SOLVED THIS ANNOYING PROBLEM!!!!!!!!!!

Grrrrrr!!

Slow down Chuck ;-)

I notice that if you HOLD DOWN the mousekey

while drawing the line you get a bezier line,

if you ONLY CLICK the point and move your mouse you'll get a corner point.

Is not bad, isn't it?

Kind Regards,

Hannes

Share this post


Link to post

Thanks Hannes,

I agree with your assessment of default Bezier vertices appearing when drawing with "polyline by corner point tool".

But why is VectorWorks programmed to change to Bezier vertices on the run (or in my case because I try to draw polylines faster than snail's pace)???

Why can't the programme behave and stay with corner vertices, no matter what the speed of drawing??

I look forward to some DG input here.

Chuck.

Share this post


Link to post

quote:

Originally posted by Chuck:

I agree with your assessment of default Bezier vertices appearing when drawing with "polyline by corner point tool".

But why is VectorWorks programmed to change to Bezier vertices on the run (or in my case because I try to draw polylines faster than snail's pace)???

Why can't the programme behave and stay with corner vertices, no matter what the speed of drawing??


I think it doesn't depend on the speed how you are drawing. If you do just a single

click to the point you'll get a corner point,

if you click and hold down the mousekey

while drawing you'll get a bezier and only

a click get's you back to the corner point mode..., no matter how fast or slow you act.

So you can change very quick between

this two modes, it speeds up the work -

I'm wrong?

Kind Regards,

Hannes

Share this post


Link to post

Hannes,

Thanks for your further explanation. I tried the exact same thing that I have been doing on my machine on one of our other Macs (400MHz iMac) with no problems. Your suggestion of click-dragging does produce a bezier vertex then back to corner.

I will have to review how my machine (a beige 233MHz G3) is set up to see if I can get to the bottom of it all. I know I have boggins of memory allocated to VW so that can't be the problem. I have also tried the mouse preferences set to slow/medium/fast double-click speed with no success. Perhaps it has something to do with the set tracking speed. I will check and advise.

Thanks for everyone's input on this one.

Chuck.

Share this post


Link to post

I just reset my mouse tracking speed to slow and then to medium (2 notches above slow) with no change to behaviour - still a bezier-appearance in an otherwise corner vertex world.

One thing I omitted to mention in previous posts is that once I get the first bezier vertex in my corner-vertex polygon (during the drawing process) all the subsequent vertices in continuing to draw the polygon are bezier, no matter how slowly I draw and how carefully I ensure the mouse is ABSOLUTELY stationary during clicking.

And no I do not have the trembles!

Chuck.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×