Jump to content

corrupt files

Recommended Posts

I'm sure this has been asked before, what is the best way (if any) of recovering a corrupt file?

i'm on a mac and get the message 'failure on attempt to open file'

it was working fine yesterday and I think the file was open with one mac whilst the file was copied for backup


Link to comment

If the file is more than 0k, send the file to tech support for recovery.


If you haven't already, update to VW 12.5.2 to reduce file corruptions.

Link to comment

We have had some luck with this method (more so with VW 10 and 11, not so much 12). (12.5.2 did solve the corruption by minimizing for us).

Create a new blank file, and workgroup reference in the corrupt drawing, bringing in all layers. If that worked, then you can just delete the Workgroup Reference and request that the drawings stay in the file, and not be removed.

Then you will just have to somehow set up you saved views, viewports, and such...

The best way is to keep a backup copy handy, through nightly backups, rotating drives out, or using the backup feature in VW.

Thats my 2 cents.

Good luck.


Link to comment

I'm on PCs. Using 12.5.2 on a Vista machine, not just on one file, I get a similar message "failure on attempt to find end of file", which happens when it tries to save automatically. Doesn't happen everytime either. Does not happen on my XP machines.

Link to comment

I did not know that your tech support could try and recover the files. I will remember that when we have the next 4K file error.

We have this problem at work quite a bit, though less so recently. The files are on the xserve and it seems to be a problem generated when the programme crashes during a save. We usually set up our drawings so that the live drawing information is in one file which is worked on a day to day basis. The 'sheet files' are contained in another file. We use the work group referencing to bring the live info into the 'sheet file'.

If you get a 0k live file then you can go the sheet file which has all the info referenced. The information tries to refresh from the live file on open but fails - however, all the info can be copied into a new file really easilly! The info might be slightly out of date depending on the last time you opened the sheet file and refreshed the workgroup reference. It won't work if the file has already corrupted . . . . .

I hope you find this helpful.



Edited by Melshimber
Link to comment

This is typically happening when a file is minimized and then either the same file or another file tries to save.

I know it's easier said than done, but if you can find a way to draw something in the focus file (and perhaps delete it) before it saves, the problem should not occur.

VectorWorks 12.5.2 also addresses file corruption issues more so than earlier versions of VectorWorks.

PS - If the file is 0k, there isn't anything to the file to recover, so in this case the file would have to be redrawn or pulled from a backup.

Link to comment


My practice has just upgraded from Verctorworks 10 to Vectorworks fundamentals 12.1.1. All of us at some point seem to be getting this message:

Unexpected end of file encountered during file read operation. (Failure on attempt to open file). The file then proceeds to corrupt. We do back up but people are getting increasingly frustrated at losing a day's work....it seems to happen erratically and I can't work out why. We still have Vectorworks 10 on the computers, 'just in case'. Do you think that's causing a conflict in the systems? Please help.....


Link to comment
  • 2 weeks later...

Katie, anyone..would appreciate help with a file. It is an old Vectorworks 10.2 file. When I try and open it, it first says: This file was created with an older version of Vectorworks. It will be converted and opened with the new name: xxxx

I click ok

It then says:

This is an unrecognized file. It may be a Vectorworks file created by a newer version of the application, it may be a very old minicad file, it may have been created by another application, or it may have been corrupted by a hardware or system error.

It then closes.

The odd thing is, I haev no problems with any other Vectorworks 10 files I have had to convert.

Any clues?

Many thanks...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...