Jump to content

Viewport crops

Recommended Posts

Can anyone help me with a strange problem I am having...

1. I draw a polygon or rectangle around area of drawing I want the viewport

to show, in design layer

2. View > create viewport

3. To the message: 'The selected object may be used as object crop. Do you

wish to use this object as the crop?'...I say yes

4. Ok to viewport options, which takes me to created sheet layer with

viewport in it

5. I double click on the viewport > edit crop

6. I pick the polygon/rectangle and give it a line thickness of 0, so it

doesn't show

When I try to print from a PowerMac G5, nothing shows, except text in sheet layer or on annotations in viewport. If I print the same drawing from a new Mac Pro it prints without issue!

What could possibly be wrong?!



Link to comment

HP DesignJet 4000ps and yes we are using the same printer in both cases. We have also tried sending the file to print on a HP LaserJet 5100 and exactly the same problem!!!

The other odd thing is that when we 'save as pdf' the pdf that is generated is fine!!

Machines are - PowerMac G5 x 40, Mac Pro x 10 all running Mac OS 10.4.9 with latest patches applied.


PS. I could send you a copy of the file if that helps??

Link to comment

Try resetting the printer (in the print utility) and set it back up and print again.

The fact that "print to pdf" works in the print dialog notes it's not a VW problem but rather something in the OS or between the OS and the printer. It's clearly computer specific.

Link to comment

Thanks Katie but I'm sure that isn't it.. I can reproduce this problem on all of the G5's we have in the office but the Mac Pro's are fine.

If I go into the viewport and delete the crop and then print the drawing prints without issue. So to me that looks like a VectorWorks problem!!?

Can I send you the file to look at?



Link to comment

I understand where you see this as a VW problem.

However, the save as pdf built into the print driver is often used as a testing device.

If you are able to print to a PDF from the print dialog using the same printer and the problem isn't apparent - then the printer or something between the printer and the computer is creating the problem.

The PDF creating in there uses the print driver.

So, if it's successful this route, then VW is not at fault (double verified by the fact that the other computer also works). The fact that the pdf works also indicates that the problem is not with the printer driver, but some communication between the printer driver/OS/Printer combination.

Sending the file isn't going to help diagnose this problem one way or the other. It's been verified by you that the same file works fine on another computer with nothing changed other than the computer itself.

Link to comment

Is the G5 an Intel mac by any chance?

..and have you tried running disk utility or deleting all the printers and adding them back?

I've seen this situation time and time again and it's usually caused by a corrupt printing device affecting all the printers.

This problem is more prevalent on Intel Macs at first use.

Edited by Katie
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...