Jump to content


Recommended Posts

Afternoon all, hope you are all having a lovely Easter.

I seem to be making a habit of creating unrenderable drawings at the moment; everything looks reacts fine in wireframe but as when I try to render using openGL the program goes through the usual symbols...geometry.. at the top right of the screen but then crashes before render occurs. Looking at the crash logs (I now have a fair selection) they are always EXC_BAD_ACCESS ... KERN_PROTECTION_FAILURE , always thread 0 crashing, always gleAddCommand +53 with a similiar addresses (0x1834b868, 0x18347868, a number of times), the same address occurring under the eip listing for the processor report.

Looking at Apple's website there is a technote ref the crashreporter Technical note TN2123 which seems to point to a memory handling error.

The error output in the application support file (/users/username/library/application support/vectorworks/12/) shows "warning : _74_122 - Handle variable is NIL."

Looking about a bit it looks as though this may be linked to a 64 bit problem, but that's no more than a quess. There is also a suggestion that repairing permissions may help so I'll try that.

Anyone got any other good ideas?

Thanks in advance,


Link to comment

I have seen similar crashes, but not for a long time. In my case it was nearly always related to a) the file having benn imported from a funky DWG file, b) one corrupt object (this is tricky, you gotta search for it!). Try creating a brand new file, and duplicate the design layers, classes, etc. Then CUT & PASTE IN PLACE, one layer at a time, from the old file to the new. After each nw PASTE IN PLACE try rendering. This will either cure the problem or *might* assist you in localizing the corrupt object to a specific layer.

Also, on Monday, I'll bet you could send the file to Katie and see if she (or someone at NNA) can determine what's up.

Petri, please don't go. I for one will miss your constant cheerfulness ;-)

Link to comment

You could also try to verify and repair disk permissions to see if that heals the problem.

Alternatively, reboot the computer, too. It may be a matter of clearing out the OS cache.

Link to comment

Memory handling error? I'd head over to VersionTracker, download Rember and run continuous Ram test for a few hours. Flakey ram does happen, and with 3 gigs you have a higher risk than some, especially if you've gotten it from third party vendors.

Good Luck!


Link to comment

Thanks for the response Peter, the files were all VW drawn - no import; the corrupt object possibility - I tried, for a start, dividing the drawing into a number of chunks, the idea being that if one misfired I could tunnel down through in ever smaller lumps to the roque object. On first division all parts rendered OK. When I put them back together they didn't.

Charles - tried Rember, first time I've met it, looks like a useful tool. Left it running for 6 hours, all OK.

Katie - full shutdown and restart is a daily occurence, I also do logouts a couple of times a day, it really keeps VW up to speed. The disk permissions I hadn't done in a while so when I ran disk utility it found & fixed a load of stuff. Also ran Cocktail to manually clear all caches and run all the cron scripts. And for a start things rendered. Unfortunately five minutes later, they didn't, same error file as before.

Incidentally VW created about a dozen .txt files on the root directory (i.e. filepath is /) with filenames that read like a filepath - /users/username/application support/vectorworks/12/plug-ins/VW_mech/data/... the final part being a selection of VW Mech plugin names. All of these were zero K files. I deleted them during the cleanup exercise and they haven't reappeared.

Peter, I'll try your rebuilding exercise in full as a next step.

Thank you all for your help so far, any further suggestions welcome.


Edited by Charlie_P
Link to comment

Hi Again Charlie. Glad you seem to working it through. One thing to note: It used to be (and probably still is, but I'm not entirely certain) that if you modified and/or deleted either the "None" or "Dimension" class very bad things would happen. You may have noticed that every new VW's file will contain these two classes. So I have always beens very superstitious about these, as in, it is TABOO to mess with them.

Further, though... I have seen corrupt classes, but again not for a long while. One of the things that might cause corruption is a bad font. So this *might* be something to look into...

Keep on keeping on... And good luck!


Link to comment

Hello again Peter. Yes I am aware of the religious nature of None and Dimension, that's partly why I stuck everything in None - it was as near as I could get to a "clean" class, i.e. least chance of corruption and lowest possible number of classes in a file.

The plot thickens somewhat. I'm getting some partial success in that openGL will render under some settings but not others; low & medium OK, textures OK, anti-aliasing - nurbs - high - very high are all no go in any combination. Renderworks is bits of both. Sometimes FQR works, sometimes it's just a complete stall (activity monitor shows no cpu use, VW unresponsive, leave it for an hour - no change); other RW modes have been similar but I haven't comprehensively tried this problem on them (I tend to use GL for a quick look and FQR for output; reasonably swift on a quad core)

My feeling is that there is a glitch in the way VW interacts with GL. Just a feeling as I haven't tied it down fully yet, but it's a memory addressing problem and it may be a 64 bit related; it's probably something to do with my installation, my next step is a clean install of VW. We shall see...

Thanks again


Link to comment

Just a thought/theory: do you by chance have a whole bunch of "nurbs" objects or 3d "sweeps" in the file? Do you have any at all? If so, what happens if you create a new class and place all of those (types of) objects into it, then try to render?

Also, if you haven't tried it yet, you sould do the CUT & PASTE IN PLACE into a new, clean file, just for kicks. Or, there are some folks who swear that creating a new file, and then using a Workgroup Reference to bring in the layers (and all contained objects) from the funky file works for this sort of thing.

I'm also sort of curious, how large is the file? Has it been worked on over a (long) period of time? If so it is quite probable that the data is fragmented on the hard disk. Another good reason to do the cut & paste, or maybe even just do a SAVE AS, which (as I understand it) ought to resave the data all in one sequential run...

Also, I'm wondering if this could have something to do with your hardware? Any third party RAM? Etc, etc...

By the way, I hope we haven't offended Petri with all this talk about "religious classes", which is after all quite appropriate for Sunday School session ;-))

Edited by CipesDesign
Link to comment

Afternoon Peter, Yes a whole lot of nurbs/sweeps. The file as it stands now - after cutting and pasting in place from the old file - is all 3d and around 400 mb. Haven't tried WGR yet, that may well be next. Could it be the hardware? Always possible, certianly. I tried Rember overnight and nothing showed up (see earlier post) but I'll try a ram transplant from another identical but younger computer within the firm and see if that makes any difference (my ram came via Crucial, the transplantable stuff was Apple fitted). Another variable to close down.

I too hope we haven't offended Petri...

Incidentially I can't produce GL rendered viewports under any setting at the moment, same crash occurs. Hmm...

Thanks for all your help, I shall press on; progress is possible even in this reduced state. I've only got a few more views to go and then I'll resort to the more serious surgery (ram swap, clean install, visit the pub)



Link to comment

Good afternoon islandmon,

only non-standard plugins are Animationworks related (10 of them). I'll try removing them and see how I get on

Thanks for the suggestion Michael, I've been hunting for rogue objects but as the problem is affecting a number of files it wold have to be particularly bad luck. As to the number of objects I'm afraid they're all needed (yes I am using symbols), it's a complex drawing.

Thanks for all suggestions thus far,


Link to comment

Hello again Peter. No, haven't sent anything to NNA yet, but...

Progress. I've done all the things outlined in the previous posts, and good suggestions they all were. Believe it or not what I hadn't tried was reducing the load on the graphics card. So, a bit of background to the monitor - 30" Dell (I know, I know, but I couldn't stretch to a ACD and I need pixels.) running at 2560 x 1600 and millions of colours. I changed the colours to thousands, and everything functions again. GL renders as it should under all settings.

Question is why? Obvious answer is a memory handling issue but there my knowlege ends. There is also the black magic response that it's because I've got a (whisper) dell (/whisper) plugged into a mac and it took umbrage.

Thanks for all the suggestions,


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...