Jump to content

VectorWorks crashes when opening file


Recommended Posts

A brand new Macbook Pro was purchased less than two weeks ago which houses, Mac OS X 10.4.8, 2.33 GHz Intel Core 2 Duo, 2GB 667 MHz DDR2 SDRAM with Vectorworks 12.5.1. However, everytime a file is opened, it suddenly crashes.

The following has been attempted:

- To remove all Preferences and restart. This requested serial number etc, but still same problem occurs when attempting to open a file.

- Remove all traces of Vectorworks from the system and reinstall from scratch. Again, the same problem occured again.

- Attempted to start Vectorworks in Rosetta mode. Again, no difference.

I am at a loss to figure out why this is happening. Any help or suggestions would be greatly appreciated.

Many Thanks,

--- the following is from Mac OSX's crash reporter:

Host Name: james-walshs-computer

Date/Time: 2007-03-02 11:01:01.814 +0000

OS Version: 10.4.8 (Build 8N1051)

Report Version: 4

Command: VectorWorks

Path: /Applications/VectorWorks 12.5.0/VectorWorks.app/Contents/MacOS/VectorWorks

Parent: WindowServer [60]

Version: 12.5.1 (???)

PID: 1095

Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)

Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x9084b378

(I can send anyone the entire file if necessary)

Link to comment

Hi all, I am getting this problem all of a sudden as well. I've been using 12.5.1 since the second update back in January without problem on an identical set-up as anev reports above. I do have external firewire and USB attachments, including a 23" Cinema Display. Oddly, this problem only cropped up as of today!

Some files do open, but others don't. And here's a case where size doesn't matter.

I've tried what you suggested as well as opening under Rosetta with the same results: application opens, but some files won't. I've tried opening from within VWA and from the Finder.

Odd. Incidentally, my report is quite lengthy, but perhaps anev didn't include the text that followed the initial screen.

Any help is greatly appreciated.

Edited by Speedy Gonzales
Link to comment

I'm not sure if this helps, but it appears don't only a couple of files are causing the crash upon opening. All other current files I've attempted to open are fine.

I've checked the server, VWA back-ups and the application and all seems well. That is the good news.

It appears that the two or so files that crash VWA may be corrupted somehow. So how do I go about rebuilding those files or getting them fixed?

Thanks. frown.gif

Link to comment

In my limited experience these type of crashes are related to FilePath issues...

as Katie suggests a permission conflict will default to 'null' > crash...

but if the permissions are good then there's a minor but important FilePath corruption...

did you rename or relocate any files which the Resource Browser or WGR is looking for ?

Unfortunately, at this point in time VW appears to be very sensitive to these issues ...

Link to comment

Thanks for your insight. I guess that is the oddity of this situation: nothing has changed. And while some files open up without a problem, others won't (only 2 at last count). I have attempted to open these problem files from the server, my desktop and from within VWA with the same result.

That's what led me to file corruption and requesting some direction on rescuing the file.

Interestingly, I had a colleague email me one of those files, as it had last been worked on at their location. It came over without an identity (no VectorWorks graphic on the file icon). I tried to double click and open, and I was asked what application to open it with. And it had the ".mcd" suffix! I tried to open from within VWA and it crashed again. I suppose it is VectorWorks itself. Perhaps a corrupted preference file (.plist), although I can't seem to find where on my computer that might reside to trash and create anew. Any thoughts on these?

Link to comment

I was diging around to find a .plist file to throw away a possibly corrupt preference file and couldn't find one. But lo and behold what I did find. It was an "Error Output" located in the VectorWorks folder of the Application Support folder in my user Library folder. Opening the file it says: "Warning: _2344 _2345 - Object passed to routine is not the proper type." It is dated 02.27.07, probably the last time I had VWA in use. Coincidence? Related?

Help! confused.gif

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...