Jump to content
Sign in to follow this  
MattG

importing problem

Recommended Posts

May be an easy question, but cannot figure it out. I am importing all my lighting info back into vectorworks from lightwright. Unfortunatly when I do this none of it imports correctly. In that everything imports, but it is all an orphan in a box blocked together in a square. This wouldn't be a huge problem if the light were at least where they should be on the plot. Any help? I am using LW3 which could be one of the problems.

Thanks,

Matt

Share this post


Link to post

Make sure the UID is matched to the External ID in LW. This is the one piece of information that links the two applications. Any time the import acn not match LW external ID to a lighting device UID and orphan instrument is created.

Share this post


Link to post

Kevin

I don't know if Matt is running 12.5 - but I know that for myself and a couple of others we've noticed that the default mapping in "Import Inst Data/Autolink" does not seem to work by default anymore. It has been flawless single click operation up to 12.5. Now I've had to create a Import template and load it each time.

Share this post


Link to post

Just upgraded to LW 4.1.7 and it appears the AutoLink problem has re-emerged. Is this true????

Edited by Ethan

Share this post


Link to post

I've given up on the autolink. I've started a thread that describes all the settings that I use to move data back and forth between Spotlight and Lightwright.

Share this post


Link to post

Listen, every time either product rolls out an upgrade, the Autolink default mapping becomes invalid; it's just a fact of making two products work together. Because it is a bit of file written by NNA, NNA has to fix it. However, even in the best of times, Autolink has never been robust - even within one project my units will eventually break their links.

Interestingly enough, I find I can go back and forth between VW and Excel just fine... Then I export once to LW to fill in the finer details of instrumentation and focus notes and send to the printer.

I think John and Kevin have some serious collaboration to do if these two products are to work together seamlessly in the future.

Cris Dopher

Share this post


Link to post

Cris,

We think we have isolated some of the autolink problems mapping the fields between LW and VW. Till we work more directly with LW the autolink is going to just do it's best to match the fields.

Things like Gobo 1 and Template only match the minds of a lighting designer.

Autolink works great when the field names don't change, that's why you don't see any field matching problems when you use Excel.

Share this post


Link to post

Why is it that I get a "File Does [sic] not appear to be a valid settings file" error when I try to load a saved import mapping.txt file??

Share this post


Link to post

Guess what Kevin? Spotlight is software designed to be USED by a lighting designer. Both the autolink and the mapping files have nothing but a disaster from the beginning - especially for the Mac users. Ethan's problem is as common as the failure of autolink to work. And the workflow is absurdly time consuming.

Why Spotlight cannot work as simply as Lightwright does on it's end is beyond me, and it seems beyond Nemetschek's programmers.

Share this post


Link to post

The import mapping file on the Mac does not work in 12.5.2. (You will see the message that the file is not valid.) As far as I know the rest of the command functions as it did in 12.0 and 12.5.x.

The problem has been resolved for 2008 and the autolink function has been improved.

If you test LW "Suggest Matches" you will see that it also fails to match up some of the field names correctly and you have to manually match the fields. Both LW and VW make every effort possible to make the transfer of data between the two applications a simple as possible, but they are still two different applications.

Share this post


Link to post

My point on the workflow is this: Here are the steps to import data INTO Vectorworks:

File->Import->Import Instrument Data

Browse

Find Data File

Open

Load

Find Mapping File

- it doesn't work again.

AutoLink

Nope - fix all AutoLink mistakes

Import

Refresh Instruments

Here's the workflow for importing or merging data into Lightwright:

File->Merge

See the difference? Lightwright is not a sophisticated program in the grand scheme of things; and yet it effortlessly and flawlessly works imports, exports and merges in the blink of an eye. And like it or not, it is industry standard. Spotlight should do it's part as easily as Lightwright does. Why can't Vectorworks save default custom import and export routines like Lightwright does?

Share this post


Link to post

Having lost the ability to use the Load Setting I now have to rely on the Autolink Function.

If you go into LW Setup/Names and change the Long Name to match the VW equivalent ie. User Field 1 instead of Text 1 everything matches up, almost.the only thing that does not match seems to be

[Accessories] Alt-Circ

I do however agree that this is a very long winded process

Share this post


Link to post

hi folks; coming into this a little late. i ran into some number of import and export troubles as well, although i admit i was doing some pretty whacked stuff (dealing with repertory shows in single lightwright file, etc). i discovered that if i used sam jones' autoplot tools for spotlight that my problems completely went away. if you've not taken the opportunity to examine sam's stuff (www.autoplotvw.com) i highly suggest you do so. spotlight is a great program in some ways, but other external developers, including sam and josh bengiat, have added enhancements that really make the program sing. hth, shelley

Share this post


Link to post

I am using LW 4.1.5 and VW 12.5.1 and having a strange problem importing LW data back into VW. I don't seem to be having any troubles with mapping; what is happening is all the data is being imported properly but all of my instruments of one particular type turn into boxes once I refresh the instruments. There are no orphans being created, and the symbol name is still correct on each of these instruments, they are just displaying as boxes. The only way I can reverse the problem is to make that symbol active, select all of the instruments, and use "Replace with active symbol". Then they all go back to normal until the next time I import from LW. Any ideas why this would happen for only one instrument type out of the 10 different ones I'm using?

Share this post


Link to post

I agree with Rick that the workflow for importing into data into Vectorworks is needlessly complicated. At a minimum, one should be able to set the default MAPPING file as a preference and ONLY change it when necessary. In addition, the name of the data file itself should be persistent- at least within a session.

-haich

Share this post


Link to post

Smatticus, first, download the most recent Lightwright - there was a problem in the past (I forget which version though) when LW would retain the CAD symbol information incorrectly. Then, make sure that you are mapping VW 'symbol name' to LW 'instrument type symbol' in both directions. It sounds to me like you added a new symbol in VW, but never mapped that data into LW.

You can verify this by going into LW Maintenance>Instrument Type>CAD and make sure that every symbol on your VW plot has the Cad Symbol field filled. You can also manually enter the info in LW, but it has to be exact - that's why I'd recommend doing it in an import or merge.

Haich, a fine partial solution, I agree. Or at least when you hit Browse it would always default to the same D***m folder. C'Mon Nemetschek! An entire software suite devoted to stage lighting and this is basic!

Share this post


Link to post

Hey Steve,

I haven't tried the most recent version of AP and maybe I should again. But in the past I wasn't happy with how clogged the symbol libraries became - every orientation, etc. I also do repertory plots and the nice feature that FINALLY (at least partially) arrived with version 12 is that there are enough user defined fields in Spotlight to have color information for five different shows, and using classes you can turn them on and off depending on which one you are working with. Now if Nemetschek would add enough to do patterns and focus, life would be happy.

Rick Martin

Share this post


Link to post

Smatticus. Before you Export out of LW select the External ID & Symbol Field (Worksheet/Columns) this will show you which Symbol each Fixture is using, if there is no Symbol Info there then when you import back into VW those Fixtures will be displayed as Boxes.

The Symbol Info seems to disappear going from VW to LW

I have had this happen several times having Imported/Exported a File many times between LW & VW, for that reason I always have the External ID & Symbol Field displayed on my Worksheet so that I can keep an eye on things.

Share this post


Link to post

I apologize for the commercial, and I've been biting my tongue (keyboard?), but since Steve brought it up. "AutoPlot Tools for SpotLight" greatly simplifies the import export process. Steps in the process, one command: "Export SpotLight Data (LW4)" and export done. "Automated actions" for LW4 are provided to import and export in and out of LW4. One command "Import SpotLight Data (LW4)" and import done. It also improves it. How about added lights showing up at their position instead of the orphan box? How about marking fixtures that have been eliminated?

Many people use the "AP" or "AutoPlot" to refer to both "AutoPlot Tools for SpotLight" and "AutoPlotVW"; they are not the same. Rick, I think your dissatisfaction with number of symbols needed was with "AutoPlotVW"; take a look at "AutoPlot Tools for SpotLight".

There are also many other useful commands in "AutoPlot Tools for SpotLight", but I'll let others chime in here if they want or start another thread on 3rd party add ons which would include Joshua Benghiat's "Beam Draw" and Andrew Dunning's "Video Screen".

PS: Rick, if you really want extra fields, look at AutoPlotVW, but it would a require a major shift in paradigm, which you might not be up for.

Share this post


Link to post

Hi Sam,

Yes, perhaps the thread is veering, but this is still all the same subject.

I wasn't confusing the AP Tools and AP Tools for SL. I'm at fault though for not being clear on them though. My beef above was of course with Tools, not Tools for SL.

I went back though and confirmed though why I was having trouble with Tools for SL. The import and export routines are fixed, and so users have no control over what moves between the two programs, and how they are mapped. For example, you have label legends mapped to LW's 'text 5' field. I use that field as an additional color field. I'm not sure how you have the VW user fields mapped, but I'm unable to map them into LW 'number' fields because those fields will not handle letters.

But the idea that you have is EXACTLY what I wish someone at Nemetschek would develop (or perhaps you???) with the following change: allow users to set up in VW an import and export routine - or indeed multiple routines - and make them available through drop down menus. Instead of the absolutely absurd number of steps that are currently required (and which you have nearly solved) to get a custom, user defined routine to share info back and forth between LW and VW.

John Mckernon solved this years ago with the Automated Actions. This in a program that is less than 6 megs in size, and it works perfectly. Again I ask the programmers at Nemetschek why it is so difficult to implement (or why are they unwilling to) in Spotlight?

By the way, many of your plugins are fantastic and I'm motivated to buy them again - just not for the data sharing.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...