Jump to content

Sketchup import...

Daryl Wood

Recommended Posts

I tried the 'Rosetta' workaround and nothing.

Same thing when not forcing under Rosetta.

When I go to file, import Sketchup, nothing happens, no dialog box, no error, nothing.

I have tried it, then removed the object from my workspace, re-imported it, nothing...

VW 12.5.1, Mac OS 10.4.7, Intel Mac Pro.


Link to comment

Are you the administrator of the local computer?

Are you sure the SketchUp file is a version 5 or earlier and not a version 6? If it's version 6, it will not import - the file needs to be a version 5 file.

Link to comment

Katie, I did back save the file to 5 from 6, so that was not the problem.

My solution, which I feel is not adequate for an office environment, but probably fine for home.

Our setup. Single Mac os 10.4.7 server hosting Network Nome Directories for our workstations running Mac 10.4.7. Each employee logs in as their individual user, which is not a local admin for the computer, This is an attempt to limit them from installing software that could cause harm...bla bla bla.

So for an employee to import a sketchup model received from a client, they need to log out, log in as the administrator, getting the login and password from me. Then 'get info' on the VW 12.5.1 App, check 'USE ROSETTA'. Then open the application. Since we do not place a serial # under the admin user for the local machine, we need to put in the serial #. Then go to file import, Sketchup, or you must reimport the item into your workspace.

Finally the import sketchup works and it comes in OK. Save it to our network directory, job folder.

Remember to quit and uncheck the Rosetta option, then log back in as the employee.

For the PPC macs (G4 PPC Mac os 10.4.7, VW12.5.1), you still need to be logged in as the Local Administratior, for the utility to work. hmmmm. So that seems odd.

Now I get to change logins and passwords again, as some employees hear 'please do not do install any software' as 'Sure we have no problem with you downloading music, games and installing any crap that you use at home, go for it!!'


Now this is not a rant at VW, but at the whole process. Myabe there is something VW can do about the PPC machines needing to be logged in as admin, not the user. That just seems odd to me.

Anyway, these are my solutions, far from ideal.

On a side note, when can we expect Acad 2007, and Sketchup 6 file support? With VW 13? or will there be a VW 12.5.2?


Link to comment

Remove the menu item from the workspace using the workspace editor and then add it back.

If it still isn't resolved, and you are using a customized workspace, try it from a standard workspace.

If the problem is still occurring after both these attempts, uninstall and reinstall VectorWorks.

Link to comment
A sketchUP 6 file needs to be saved as a version 5 file to work with VectorWorks.

yeah. that is less than cut-and-dry. confused.gif

Here's what I did:

On my MacBook Pro:

1. I have to run Vectorworks as a "rosetta" application (use the Get Info box to do this)

2. I have to previously save my model as a Sketchup 5 model. confused.gif

That is, because the application won't import a Sketchup 6 model- rosetta or not.

Once I do that I can import the model.

There has to be a more intuitive way.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...