Jump to content

Quicktime Crash??

Recommended Posts

VW 12.5 on Windows XP

Since the upgrade to 12.5 VW has been crashing regularly during mouse-wheel zooming and other intensive read/write operations. The Windows Event Viewer shows an application error, event ID 1000: "faulting module quicktime.qts version 7.0.2"

I had previously "trashed the preferences", so I installed an update to QT 7.1.3. Shortly thereafter, it crashed again. Any suggestions will be appreciated and duly considered.

Link to comment
  • 3 weeks later...


VW12.5 on Windows XP; 1GB memory; ATI GL-X1 graphics card

VW continues to crash daily. There seem to be at least two scenarios.

As reported before, VW sometimes locks up while zooming or panning. No error message. Event Viewer utility says error 1000, Faulting module Quicktime.qts. Fault address 0x0009fd5d. Error 1002, address 0x000000000. During the lockup VW was using 50% of CPU time.

On other occasions, while drawing something as simple as a rectangle, I get an Application Error: "VW has requested Runtime to terminate it in an unusual way."

As you suggested before, I have updated the video driver to the latest version dated 9/9/05. I have also updated to the latest version of Quicktime 7.1.3.

Another recent error message said: "Instruction at 0x66868d14 references memory at 07ffddfff. the memory could not be read. I ran a memory diagnostic and everything passed.

Any suggestions will be appreciated.

Link to comment

While attempting to OpenGL walk-thru a kitchen scene, VW would crash arbitrarily at different resolutions & perspectives.

After an extensive investigation, the source of the problem was discovered to be an unclosed polygon within an imported

Table&Chairs Symbol created by a legacy plug-in.

The lesson... the QT engine is sensitive to closure of the dataset.

Link to comment


I didn't uninstall QT, but I did install the update. I was hoping that would fix the Qucktime.qts file. Does anybody know the function of that file in VW? Most of the other file types in VW are .QTR extension. Is there a way to get the Quicktime.qts file replaced without a complete QT update?


These are relatively small and simple 2D drawings (4.5MB and 10MB). Is there a relatively simple and painless way to find non-closed objects, or corrupted PIOs?

Thanks for the suggestions

Edited by JHEarcht
Link to comment

JHEarcht, a bad PIO will take down QT regardless of the file size. After discovering the offending PIO, proving it was easy... a single instance of it

in a new file would cause QT to crash.

This harrowing event forced me to take a comparative look at my installed Plug-ins and to clean-out my WorkSpaces of many PIO

accumulated over version changes.

Unfortunately , there was no easy way to do this maintenance at the time.

Link to comment

Video adapter: ATI GL-X1 1MB memory

Hard drive: 32GB free space

Workspace: created from standard Architect

A few months ago a corrupted Workspace.qtr file repeatedly caused palettes to disappear. I now keep a backup WS file. But the problem hasn't happened since I removed a 3rd party PIO. Now the whole system locks up on random occasions while zooming or panning. Somehow that doesn't suggest to me a PIO cause, but I could be wrong. :-)

I'll continue searching for the culprit, but the variety of error types makes it seem to be a deep or complex issue.

Sometimes the crash or lockup is preceeded by a slow-down of response time similar to a memory leakage, but I haven't been able to find any evidence of memory leakage or resource hogging.

Edited by JHEarcht
Link to comment

I've had the wheel zoom problem in XP since 11.5. I thought 12.0 had cleared it up, but I see that just yesterday it started up in 12.0. I noticed it happening when I zoomed to large distances quickly, say about 10-20 miles screen-edge to screen-edge (typically for a 1:1000 drawing). It got progressively worse in one certain file and that file eventually would no longer open. I tried a system restore to correct it, but instead that operation wiped out any new layers I had added in any Vectorworks files that had been opened and worked on after the date used in the failed system restore. Anyway, I found it peculiar that the wheel zoom crash happens fairly consistently at a certain "height" above the drawing. I also get the text insertion-type and pan-type crashes, but these happen in all my drawings. I don't use any third party plug-ins.

Link to comment

1. Send all the information to bugsubmit@nemetschek.net

2. Try using one of the standard workspace and see if the problem persists (testing purposes only)

3. Does it happen in all files, even simple, new files with just a few objects in the drawing?

4. You may want to check for updates to the video driver. It's likely there's a newer version available on the ATI website if the date is for 2005.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...