Jump to content
  • 0

Network Dongle Protection error:



I have two PC's with Vectorworks 12.0.1b installed, one works fine and the other randomly gets the following error message: "Network Dongle Protection error No recognizable network dongle is connected to the network dongle sever HASP License Manager) VectorWorks will now quit"

The difference in the PC's is that the one that works is a standard Windows XP SP2 build with not much else installed but Vectorwork.

The second PC is a University ZenWorks build, Windows XP SP2, with a whole range of other software, Novel client, Zenworks, Autodesk, Adobe range of products,

Using the HASP ini files I have restricted down the two PC's and license server to use only TCP or UDP and on port 4751, there are no firewalls in the way, and there is only a basic home office switch in the middle.

I have spent quite sometime investigating the problem using the Sysinternals tools, Regmon, Filemon, processmon, TDImon, with not much results.

TDImon monitors TCP/UDP traffic in/out of a workstation, and I can see the workstation communicating on port 4751 to my license server and my license server communicating back no failures.

But if I monitor my PC that works and then stop the License server I can see it sending traffic to the License server but no traffic back and then failures.

From this I would assume the communication between my not working PC and the License server is fine.

Even at the time the error message appears there are no TCP/UDP traffic failures only successes.

Regmonm, Filemon and Processmon don?t really show much at the time of the error, but I assume this is because of the HASP security layer, if simple tools like that could interrogate the HASP communication then it would be easy to crack.

I have compared all services between the working and not working PC and stopped any that were extra and started up any that were disabled - I still receive the dongle error.

I have compared all running process between the working and not working PC and ended task any that were different - still the same dongle error.

The dongle error can appear as soon as I start up the application, or after 1 minute, 5 minutes, or even one time 30 minutes, it seems to be very random most of the time it fails in less than 5 minutes.

I suspect that the HASP communication is fine and working, but that when Vectorworks gets the key back from the license server it is not saving it or activating the application with it.

Any help would be much appreciated, and any information into how the HASP key handshake process works would be very helpful.

Link to comment

7 answers to this question

Recommended Posts

  • 0

i have upgraded to a new macbook pro, OSX 10.4.7, and am unable to get past network dongle error message with Vectorworks 11.0.1. I used Mac's transfe assistant to move all applications to the new machine. When that didn't work I trashed the old files and reinstalled, twice, to no avail.

Please advise

Link to comment
  • 0

I'm having trouble with my dongle as well...it started to tell me to udate my dongle and I got no where on how to do that! I just recently bought this VW 12 only 3 weeks ago. I don't know whats wrong and it's very fustrating because I was depending on this program. It works just fine on of my other programs but that computer is slow...I mean slow...I other computer where it was first install, it worked ok but then started crashing and giving me errors on why it won't open and close. The new one is dongle error..I even tried to uninstalling the program and reinstalling it but nothing still!!! Can someone help...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...