Jump to content

Gobos crashing my rendering?


Recommended Posts

I'm running Spotlight/Renderworks 9 (I know...update, but...) on Mac OS 9.1 (see previous "I know...") and I've gotten into the problem of when I'm rendering my scene design (and accompanying theatre architecture) either the rendering doesn't complete and I crash or if I get the rendering done, I crash during exporting the image. It seems to happen when I am using gobo projectors... I tried exporting all the elements into a new drawing and that seemed to help, but when I added a couple more gobos, CRASH! I most often get "error of type 2" messages. Is this a memory thing? Can anyone help (besides telling me to upgrade either the hardware or software)? I'm not used to my Mac crashing, and so it's getting on my nerves.

Link to comment

What type of Mac? How much memory? How many mghz? Dual processor? Rebuilt your desktop recently? Run disk utilities?

Type 2 error normally means a problem in preferences- try "trashing" those first.

Drag the VW preferences to the trash (do *not* throw out the trash)- restart. Then try rendering the file. If life is good- then you can throw out the preferences for real. If not try zapping the PRAM (the apple.com site gives you a tutorial on how to do this http://docs.info.apple.com/article.html?artnum=51579)

The next place to look is- the memory allocated to VW/Renderworks. Close VW- go to the application icon- click *once* then *command i* this will open the window to set the prefered memory size for VW/RW

After that- start looking at the wallet...

Good luck,


Link to comment

(Don't laugh, but...) I'm running VW on a 300 Mhz G4 laptop 384 MB memory. I do have the memory for VW set at 100K - I don't know what is standard. I do think you're right...this baby do need a new pair of shoes.

Thanks for the ideas...haven't rebuilt recently - will start there. I had trashed the preferences once, but that didn't seem to do it.

Link to comment
  • Vectorworks, Inc Employee

RW9 uses system memory for rendering, not the memory dedicated to VW. It seems counterintutive, but try decreasing the memory dedicated to VW and make more available to the system, but if you are realy set at 100K (not M) you might want to try increasing the allocation. Have you changed versions of Quicktime recently? VW uses some components from QT to export images, so a new verson of QT may have changed some things.

Go to Vegas, win big at the tables. Stop by the VectorWorks booth and spend some of you winnings on V11. It happened to someone two years ago at LDI.

Link to comment

Kevin - I think your reply has hit the nail. I was allocating 150M, not K, sorry about that. But when I had my first problem, I increased my VW memory allocation, which then means I was causing more problems than I was fixing. I rebuilt the desktop and got my VW memory allocation in line with the suggested size and I'm rendering again without problem. THANKS to you and "Ziska". I'll let you know if I draw to an inside straight...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...