Jump to content
Sign in to follow this  
Joel Riehl

Drawing went from 24megs to 0 Kb, and won't open

Recommended Posts

One of my drawings - which I was working on as recently as yesterday evening - won't open now. It gives me a message: "This drawing was created with an older version of ....." etc. Whether I ask it to translate to V12 (which it was created and last edited in), or to cancel, it then gives me another dialogue box saying the file format is unrecognized, and may be Minicad.

On further inspection, though "Finder" (Mac) tells me that the file was last edited yesterday evening, it also tells me that the file is 0 kilobytes in size. Ok. So, what happened?

(additional information: I also spent much of yesterday working on a VW12 drawing sent on disk from another office - which drawing opens fine this morning. It had some workgroup reference issues - looking for a server that isn't here, and so-forth - but I was, and am today, able to open it and work with no problem. None of my own files except for the one seem to be affected either.)

I can try to restore this drawing from my backup files, but there will be some work missing.

Share this post


Link to post

Do you work with Autosave turned on? I use it set to every 20 operations with the Save to Separate File also checked. This way, if the app crashes, you shouldn't have lost more than the last 19 operations.

Good luck,

Share this post


Link to post

I autosave every 15 minutes, without confirmation. However, I had the "save to separate backup file" turned off. Last time I used it, my file structure was becoming crazy complex - and one of the issues I posted on here before, was when a drawing seemed to revert to 6 months earlier, and I couldn't find the current version. It turned out to be some file-path thing. Damned if I do, damned if I don't. This file was nearly complete (bad, if it's lost), and not much had been added to it in the past week or so (good, since I have it saved to an external hard-drive too.) But, even with the external hard-drive, I need to be sure to purge everything with the same name, so I don't revert to the 0 Kb version as soon as I try to open it.

Share this post


Link to post

I've experienced this when working from a server - seems that occasionally if there is an network interuption (even if just a split second) during the save operation all data is lost and shows as a 4kb file only. I've contacted NNA support but all they say is to work from desktop!! Nightmare for large teams!

Are you working from a server? I've also found that VW12 opens & saves a hell of a lot slower from server than a VW11 file of same size.

Share this post


Link to post

Sim, I've also experienced this a few times since we started working off a server. It seems to happen randomly.

We use the autosave to separate file and also have a rotating backup for the server - it has saved us a couple of times.

Joel, there was a similar thread last year i think - you may be able to find more info by searching this board if you haven't already.

Share this post


Link to post

I am not working on a network. Grant, I can't find the old thread - any suggestion for time range and search terms?

There's not that much missing from my last external backup - so I'm just going to re-draw the few things that are. But I would like to know what caused this, so I can take preventive measures. I have turned the "back up to separate folder" back on.

Share this post


Link to post

Joel

Here is a thread, although it relates to servers so won't really help you.

I'm not sure what could cause the problem when working directly off the hard disk.

I have encountered similar issues when transfering files between computers that have differing versions of vectorworks installed, although again that would appear to not apply to your situation.

Sorry i can't suggest anything else.

http://techboard.nemetschek.net/ubbthrea...=true#Post29227

Share this post


Link to post
occasionally if there is an network interuption (even if just a split second) during the save operation all data is lost

If this is truly a possibility, NNA should build in code that verifies the save is complete before allowing the program to close and release the RAM allocated to the file.

Edited by P Retondo

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...