Jump to content
  • 0
Sign in to follow this  
Ken

Zoom-in jagged lines 3D model

Question

When I zoom in on my 3D model rendered in OpenGL, there's a good 1-second pause to see the gahdawful jagged lines go away. No difference between "Low" detail with Textures/ Anti-Aliasing/ Nurbs unchecked and "Highest" detail with everything checked.

This is new in VW12. My 2GHz G5 machine is otherwise a screamer, a hotrod, a supercomputer. I sense bloatware.

Any help in the next update?

Share this post


Link to post

15 answers to this question

Recommended Posts

  • 0

Interactive mode zooming was spritely in 11. Now it lags, regardless of "hardware accelerated 2d navigation" or "use vectorcaching for faster drawing" or "quarts imaging" unchecked or checked, in any combination.

Bloatware!

Or am I missing something? like perhaps a 4GHz Quad-core G6 processor? But wait, that doesn't exist yet! Omigod... Bloatware.

Share this post


Link to post
  • 0
Guest

What other applications are you running while VW is running?

Have you run disk utility?

Share this post


Link to post
  • 0

And 1.5GB RAMM -- same as when I had VW11. A handful of other apps running such as Safari, AddressBook, Calendar, iTunes, Stickies, Preview, TextEdit... sometimes Mail, Word, Excel.

I'm talking about the difference between 11 and 12 in interactive feel due to some change that affected the way images are displayed on screen. I'm using interactive zooming, space-bar panning, keyboard shortcuts etc with as quick cursor/keyboard movements as before in 11 -- the choppy on-screen response in 12 is annoying.

Another example is zooming in/out with command-1 and -2 after a bunch of editing procedures. The object "ghosts" to the new size showing handle corners before the rest of the drawing appears. Is there some new kind of "cache" that gets built up?

Share this post


Link to post
  • 0

I've noticed this as well on my office machine: 1.8 dual processor G5 w/ 1 gig of ram. OpenGL causes the monitor to flicker as it updates. I attribute all OpenGl problems to a deficient video card. But the interative zooming problem is there.

Share this post


Link to post
  • 0
Guest

Can you close all those applications and try it?

We are currently investigating an issue that may be associated with this behavior.

Share this post


Link to post
  • 0

I have tested again after restarting the computer, then launching VW. No improvement.

Side thought: last year I tested a stock-trading software that was originally written only for Windows, but somehow they ported a Mac version using some kind of code-translation developer tool to save time on programming. It was annoying because it had interactive chunky, sloppy, sluggish problems just like this here for VW12. I hope that's not what our esteemed NNA programmers did.

Share this post


Link to post
  • 0
I attribute all OpenGl problems to a deficient video card.

That can't be right. I'm running a Quad 2.5 Ghz G5 with 8GB RAM and a 256MB GeForce 6600 graphics card, and interactive OpenGL just doesn't really work in Renderworks (same issues as described here). Compared to say, Artlantis, Renderworks as a long way to go unfortunately.

Share this post


Link to post
  • 0

I have experienced the same problem since upgrading to Vectorworks 12.5, but basic Top/Plan view. In 12.0 I used Mouse Wheel Zooms for zooming in and out...while zooming it was chunky but basically rendered in full detail once I stopped zooming. But in 12.5 when you stop zooming it just stays chunky. I found it helps by turning off "use vectorcaching" in display preferences. But generally I have found all sorts of screen refresh issues since upgrading to 12.5. Anyone had the same problems?

Share this post


Link to post
  • 0
But generally I have found all sorts of screen refresh issues since upgrading to 12.5. Anyone had the same problems?

Yes.

Apart from the Ker-Plunk delay while the screen re-draws after zooming, (which doesnt bother me that much) panning on the windows machine where I work will cause "shadows" to be left behind on the screen.

Video card ATI Radeon X600 (series) 400MHz 256Mb.

What I mean is that part of the drawing in it's original position will be left behind and the drawing -in it's new position will be drawn over the remainder. Zooming in and back out with the scroll wheel will redraw it correctly. It will keep doing that till VW is restarted.

Haven't seem it on my Mac yet

Very annoying.

Share this post


Link to post
  • 0

I have just upgraded from 12 to 12.5 and I am experiencing sluggish refreshing. I haven't got a souped up pc or a tremendous graphics card but I have been using VW for 2 years now with no issues and now these jagged lines are really getting on my nerves and I only updated a few minutes ago!

Share this post


Link to post
  • 0
Guest

Check to see if there are updates for your video driver.

Redraw issues are usually addressed by updating video drivers.

Share this post


Link to post
  • 0

Yes, the sluggish refreshing persists, but I can now happily report that the entire slew of other problems in 12.01 (I'm reading my old comments and laughing at myself) have gone away with 12.5. The jagged zigzig edges in OpenGL are still there. I've gotten used to the split-second delays and hiccups in screen redraws. Previously in 11.5.1, SAME MACHINE, no such lags, so can't blame it on the same video card, same video driver.

12.01 is like getting dumped on the head with a ton of farm animal poop. 12.5 is like removing all the poop except the ones from the cows. I am so relieved. shocked.gif

Share this post


Link to post
  • 0

Perhaps, all that methane released by v12.01 will have an effect on Global Warming... after all ... as a greenhouse gas, NH4 is 23x more insulating than CO2 !

Share this post


Link to post
  • 0

Arch.Ken - Which video card are you using? I've found the nVidia auto-install driver update to be tricky. There's a couple of hidden files that you need to manually install in order for it to work correctly. Once done, this fixed my OpenGL jaggedness issues. Additionally, make sure you have Anti-Aliasing turned on in your Open GL options.

HOWEVER.....

The driver update didn't fix evertything. The manual zoom feature in 12.5 is horrific, not only do objects vanish when zooming in and out with CTRL+1 and CTRL+2, the selection handles on objects that are viewable are nowhere to be seen.

Mouse scroll zoom worked fine after updating the video drivers, however old-school mouse users and those with arthritic mouse scroll fingers are no doubt pulling out their hair. smile.gif

Share this post


Link to post
  • 0

Hello,

In moving from 11.5 to 2008, one of the first things I noticed was the pixilated zooming in 2008. From reading the threads, seems like this was introduced in 12 to speed up drawing.

I find zooming on 2008 very annoying as parts of the drawing disappear as you zoom. I do a lot line drawing across a document by selecting a point and then zooming in to the next point.

I am sure that this does speed up the zooming process, and must be appreciated by those displaying tons of vectors.

Since this is implemented in the VW software, I am requesting a switch in preferences to turn this on and off. That would enable a user to decide when he/she would need the zoom speed up.

Bob D.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...