Jump to content

Workspace file invalid???

Recommended Posts

VectorWorks 12.0 on Win XP was working fine this morning. I came back after a jobsite visit and started up. I noticed the Tools palette was empty and the Resource Browser was on default. Assuming the Preferences file in the Registry was corrupted, I replaced it with a saved backup. this didn't fix the problem, so I tried to edit the WorkSpace. As I opened the WS Editor, this dialog popped up: "the workspace could not be read. Either it is invalid, or there is not enough memory."

Looks like I will have to re-create my workspace. but what could corrupt the QuickTime file? Do I need to save a backup of my WorkSpace.qtr file in addition to the Registry Preferences?

Link to comment

Can you zip the "bad" workspace and send the file to me? I can examine the workspace to see what might have caused the problem.

Is there anything that you can think of that changed about your computer from the time it was working to the time it was not working?

Link to comment


I have already set-up a new workspace, and replaced the preferences registry with a backup. As far as I know, nothing had changed. I left VW running and went to lunch. when I came back and started drawing, I noticed that some of the palettes were empty. I'll send you a copy of the old corrupted workspace file.

Just in case this happens again, I have backed-up both the registry and the WS file for future reference.

Link to comment

VW12.0 on Windows XP

My Workspace has been corrupted again. I think I left it running, and when I came back after a couple of hours it was turned off (but I can't remember for sure). When I started up again it went to the default WS. I fixed it by substituting the backup .qtr file I made a couple of days ago. Am I the only one with workspace woes? Any idea what could cause repeated corruptions? Could a sudden shut-down do it?

Link to comment

I had a problem with my workspace, forwarded to NNA as a bug report. No word yet on what the problem was. I've now rebuilt it, and the only difference is that I renamed a script-based tool that had a special character in front of its name - just removed the special character. No problems so far, but it's too soon to tell. I'm wondering why NNA can't debug these corrupt workspaces to isolate the problem. In my case, VW failed to boot and gave an error message, until I removed my .qtr file.

Edited by P Retondo
Link to comment

P Retondo -

We examined your workspace file, but it was corrupted in such a way as it could not be read. But about this script-based tool that had the special character in front of it - where did you obtain this script, and what was the special character you deleted? Any information you provide can help us investigate this.


Jeff Geraci

Software Developer

Nemetschek North America

Link to comment

Jeff, 1) did you verify that including my corrupted workspace file in the workspace folder causes VW to freeze while booting and 2) does it make any sense to step through the code to see if you can isolate the problem? Or was the file basically a train wreck?

The script was obtained from VectorDepot. It's a plugin called "Toggle lineweight zooming", and you can download it to take a look at it. I've been using it since version 8.0. The special character was a dot-type bullet in front of the name that appears in the drop-down menu (it appears as a verical line in the VectorScript Plug-in editor window, if I recall correctly). Here's the script itself:

Procedure zoom;


SetPref(9,not GetPref(9));



I'd suggest that if VW encounters a corrupted .qtr file when loading, it should give a warning and continue the loading process by skipping the corrupted file.

Thanks for your good work!

Edited by P Retondo
Link to comment

P Retondo -

Yes, I verified that the workspace file caused VectorWorks to freeze at startup. Unfortunately, the workspace file was corrupted at such a fundamental level, that it could not be opened.

Thanks for the info as to its origin. I will continue to investigate.

Link to comment


No, the computer is working fine. But I was just wondering if something might be causing VW to shut-down when I am away. I'll have to be more observant in the future, so I can remember if I shut-down VW before I left. both times this happened, I returned after a couple of hours away, and found the empty or default palettes after start-up. Something seems to be targeting the WS file. I haven't added any scripts or old tools, so I can't guess what the problem is. Oh well, back to the old workspace . . . Hey, where'd my palettes go?

Link to comment
  • 2 months later...

VectorWorks 12.0 on Windows XP

My workspace was corrupted again after a brief shut-down and re-start. Since this has happened several times, I now keep a backup copy. That fixed the problem for now, but I would still like to find out what is causing the corruption. If anybody is interested, I am holding on to some of the bad .ws files.

Edited by JHEarcht
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...