Jump to content
  • 0

"OpenDWG Library Error 3" when trying to exporting




We're using VW 9 (last patch, not 9.5) on Mac OS Classic running under Mac OS X 10.4 (Tiger). Ever since we upgraded OS X from 10.2 to 10.4 we get the following error:

"OpenDWG Library Error 3"

I've looked it up, and found a few references to it in the forums. We've tried the following with no success:

1. Restarting the machine, restaring the classic environment.

2. Trying to export a very very simple file (just a square and nothing else)

3. Trying to copy/paste everything from the file we're trying to export to a fresh one

4. Praying to the DWG gods for help.

Nothing worked, not even that last one. Help us -- what the hell is going on? this file is _not_ open anywhere else (that's the meaning of the message); we know that because it's an _EXPORT_, not an import; it's not a filename issue, we've tried everything, right down to "a.dwg" and "1.dwg"; it's not the complexity of the drawing since we tried a very simple one as well.

We can't upgrade to VW 9.5, because that would mean upgrade to running natively on Mac OS X, and we can't do that because there's no Hebrew language support on OS X (not even on the latest and greatest VW).

So, what can we do?

Thank you.

Link to comment

10 answers to this question

Recommended Posts

  • 0

Can you switch back to 10.2?

A fix would more likely be adding Hebrew support in a future VW release than making a change in a program that's two major revisions below the current release. (I'm not saying it's impossible, but there would be much resistance, and easier solutions would likely have to be exhausted first.)

Link to comment
  • 0

The cause is probably a change Apple made to the file handling functions.

Wild guesses:

If you're not using an administrator account, try that. Check to see if you have write permission to the VectorWorks folder, and make sure the ADINIT.DAT file is present and not read-only or locked.

And as mentioned before, try OS9 and OS10.2.

Link to comment
  • 0

Thanks, but I'm positive it's a memory issue, even a blank document won't get exported.

Anyhow, I've tried exporting directly on OS 9, which works, so it's probably related to files permissions, so now I'm on the look for some utility to help me narrow down the specific problem (since Nemetschek, obviously, have no way of really helping to solve this issue.)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...