Jump to content
  • 0
Sign in to follow this  
Don Wood - Architect

SketchUp Plug-In - Where has it gone?

Question

OK! I upgrade VW Designer to 12.0.1. I download "InstallSketchupImport1200". I install the SketchUp Plugins. 50 files in all the installer tells me. Success it is installed! But nowhere can I find either the plug-in or the command "Import SketchUp"! Hey but I do I do have the file "SketchUp.pdf" file, which I guess is something. I have tried Architect, Landmark & Spotlight workspaces. Result nil!

I have even tried re-installing "InstallSketchupImport1200" but it tells me it is already installed.

HELP!

Don

Don Wood - Architect

16 Oruamo Place

Beach Haven

NORTH SHORE CITY

ph: 09 483-7890 fax: 09 483-7804

e-mail: donw@amcom.co.nz

Mac: Dual 1.25 GHz PowerPC G4

1.25 GB DDR SDRAM

Mac OS 10.3.9

VectorWorks Designer & RenderWorks 12.0.1

Share this post


Link to post

24 answers to this question

Recommended Posts

  • 0

Don,

I don't use Sketchup, but my installation of VW Arch 12.0.1 has a SketchUpReader.dll in the MAIN VW folder. It appears to have been added during the normal install process.

When I open the Workspace Editor in VW, the Sketchup Import is listed in the Menu list as a separate item towards the bottom of the list. It is not under the Import/Export section. If you find it here, you should be able drag it into the right pane & have it show up in VW.

George

Share this post


Link to post
  • 0

Don,

I was able to install & uninstall the Sketchup Plugin using the normal drag & drop. The import dialogue box opened when I selected the plugin in VW - I couldn't test the actual import.

George

Share this post


Link to post
  • 0

I have trashed my original VW 12.0.0 installation and I will reinstall 12.0.0 and then tonight (I only have a dial-up connection) download & install VW 12.0.1 and finally reinstall the SketchUp plug-in. Hope this will do the trick. Will give you an update on the list. Fingers crossed.

Don

Don Wood - Architect

16 Oruamo Place

Beach Haven

NORTH SHORE CITY

ph: 09 483-7890 fax: 09 483-7804

e-mail: donw@amcom.co.nz

Mac: Dual 1.25 GHz PowerPC G4

1.25 GB DDR SDRAM

Mac OS 10.3.9

VectorWorks Designer & RenderWorks 12.0.1

Share this post


Link to post
  • 0

Follow up on previous message.

Last night I downloaded & installed VW12.0.1 yet again.

And again I tried to install "InstallSketchupImport1200". And yes again i get the message; "No installation was necessary. The files to be installed are already on your disk, or are not needed for your hardware setup." Bully! They are not there!

Well that is not quite true as I found files in Library/Frameworks/SU2VW.framework/Versions. Not that they helped me find the SketchUp PIOs in VW.

And also I found Library/VectorWorks/12/NNAOutput.txt (dated: 24/03/06 11.46 pm - NZ Time) the following: "Error extracting: Plug-Ins/SU2VW". Possibly informative but not much help.

Has anybody else got any bright ideas?

Share this post


Link to post
  • 0

Hello Don,

I'm sorry it didn't work. I had hoped it would be hiding in the Workspace Editor's listing under a category that didn't seem relevant and you could pull it out to the Import menu.

I guess with it not hiding in the listing, you might be at the point where you'll need to chat with Tech Support.

Good Luck,

Share this post


Link to post
  • 0

I did lodge an e-mail message with NAA Tech Support requesting help Saturday NZ time but haven't had any response yet. I guess it is the weekend in USA too even though we are a day ahead here.

But I did have a brainwave last night. Why not install on my eBook VW12.0, the update to 12.0.1 and then install the SketchUp plug-in. Great idea. But unfortunately I got the same result, same message & no "Import SketchUp" PIO. And also in Application Support/VectorWorks/12/ the NAAOutput.txt saying "Error extracting: Plug-Ins/SU2VW". However this time dated "Today 4.33 am". And I didn't even try installing the SketchUp plug-in until at least 9.00 am today!

Does this and the message: "No installation was necessary. The files to be installed are already on your disk, or are not needed for your hardware setup." mean that the VW12.0.1 Updater tried but failed to install the "Import SketchUp" PIO? But why does my attempt to reinstall also fail?

Another VW user has contacted me via the Discussion List to say he is having the same problem.

Will keep you posted.

Share this post


Link to post
  • 0

After reading your message, I was reminded about a message I believe was on the NNA download page talking about the initial release of the Update had a problem with files and users should download the repaired update.

If you haven't been to that page recently, poke around on it to see if you can surface any clues as to whether I'm working too late on Saturday evening, or if the message exists.

I find responses from NNA often take any where from a few days to a week. I'll bet they don't have enough people to handle the spike of a new release and this latest one seems to be generating a lot of questions.

Good Luck,

Share this post


Link to post
  • 0

Rogrer

Yes this was Version 2 of the the Install SketchUp plug-in. I had earlier used a Version 1 and got an error message to say it had been uodated. No other warning I believe on the download page that I can recall though.

Don

Share this post


Link to post
  • 0

Don you might be right. I just went to the download page and it sports a new look, so they might have dropped the reasons for version 2 of the 12.01 update. In its place it shows a date of Feb-21 over the Download button for the MAC, and no date for the Windows version. My windows version shows a file date of 16-Feb so I might need to update as well.

This is the page where this is listed:

http://www.nemetschek.net/downloads/fundamentals/version12/12.0.1.php

In any event it will be interesting to see what you find as the problem.

Good Luck,

Share this post


Link to post
  • 0

Don,

Have you looked in the MAIN VW Folder for:

SketchUpReader.dll

My VW 12 Arch. installed it AUTOMATICALLY & it appears in the Workspace Editor (see my prev. post).

If it was installed by default in the main folder, it may be causing the error message you're getting when yu try to install the stand alone version.

This Plug-in, like those for C4D, Artlantis, etc, must be added manually to a Workspace before they will appear as a Menu Item.

George

Share this post


Link to post
  • 0

Hi Don,

Unfortunately I'm using a PC, so this may not work on a Mac.

As a test, I downloaded the Sketchup Plug-n Installer and installed to a non-default location just to see what gets installed.

I Browsed to my old VW 11.5 folder during the install process and chose it as the Install Folder.

After installation, when I opened the VW 11.5 Folder the SketchUpReader.dll was there. You might be able to do something like this to get around the error message, then drag it into your VW 12 Folder manually and see if it shows up in the Workspace Editor.

Might be worth a try.

George

Share this post


Link to post
  • 0

George

Yes I am on a Mac. However it is not SketchUpReader that I am trying to install. Just the SketchUp imort PIO. I will try what you suggerst just to see if it miraculously works. But I think the "smart" installer does look for a folder with VW12.0.1 in it and you can't choosae any other folder.

Don

Share this post


Link to post
  • 0

Don,

SketchUpReader may be an unfortunate name! I think the SketchUpReader.dll IS the Plug-In that allows importing of SketchUp data into VW.

In my default VW 12 Arch Folder, the ONLY item related to SketchUp is the SketchUpReader.dll. There is nothing in the Plug-Ins Folder related to SketchUp,but I was able to activate it via the Workspace Editor.

After using the downloaded Plug-In installer in VW 11.5, the only item installed was the SketchUpReader.dll.

I think the name is creating the confusion.

In the Windows installer you are given a chance to choose the location. Haven't used a Mac in a while, so I'm not sure what you'll see.

Try the procedure above and drag the SketchUpReader.dll into your VW Folder. Open VW, enter Workspace Editor. Scroll down the list on the Menu Tab & see if SketchUp is listed. If so, drag it to the right side, exit the Editor and see if it appears.

If that fails, try dragging the SketchUpReader.dll into the VW Plug-Ins Folder & re-edit the Workspace.

George

Share this post


Link to post
  • 0

Don,

New test:

1. I re-installed the plug-in. Added it to Workspace.

2. Downloaded a tutorial SKP file from the SketchUp site.

3. Imported it into VW - it opened in VW as Layers & Symbols. Seems to work fine.

Not: There is also a SketchUp Viewer at the SketchUp Site. I think the SketchUpReader.dll "Reads" the file so it can be opened in VW.

George

Share this post


Link to post
  • 0

Below is my e-mail to Katie @ NAA, the reply I got from Katie and my response to her.

Only hope the 12.0.1 installer disk does the trick. But even if it does I would have liked to know why I had the problem. And why doesn't NAA post a warning on the download page?

My original message to NAA Tech Support:

Description: I believe the problem I am having is fully explained in the

following messages posted to the Tech Board/Installation Inquiries. Could

you please assist.

1. Original Message Posted on Tech Board:

OK! I upgrade VW Designer to 12.0.1. I download

\"InstallSketchupImport1200\". I install the SketchUp Plugins. 50 files

in all the installer tells me. Success it is installed! But nowhere can I

find either the plug-in or the command \"Import SketchUp\"! Hey but I do

I do have the file \"SketchUp.pdf\" file, which I guess is something. I

have tried Architect, Landmark & Spotlight workspaces. Result nil!

I have even tried re-installing \"InstallSketchupImport1200\" but it

tells me it is already installed.

HELP!

2. Follow Up Message Posted on Tech Board:

I have trashed my original VW 12.0.0 installation and I will reinstall

12.0.0 and then tonight (I only have a dial-up connection) download &

install VW 12.0.1 and finally reinstall the SketchUp plug-in. Hope this

will do the trick. Will give you an update on the list. Fingers crossed.

3. Latest Message Posted on Tech Board:

Follow up on previous message.

Last night I downloaded & installed VW12.0.1 yet again.

And again I tried to install \"InstallSketchupImport1200\". And yes again

i get the message; \"No installation was necessary. The files to be

installed are already on your disk, or are not needed for your hardware

setup.\" Bully! They are not there!

Well that is not quite true as I found files in

Library/Frameworks/SU2VW.framework/Versions. Not that they helped me find

the SketchUp PIOs in VW.

And also I found Library/VectorWorks/12/NNAOutput.txt (dated: 24/03/06

11.46 pm - NZ Time) the following: \"Error extracting: Plug-Ins/SU2VW\".

Possibly informative but not much help.

Has anybody else got any bright ideas?

Katie Roberts reply:

Don,

If you are having problems running the updater because you are on dial-up,

please contact your local distributor to request 12.0.1 installation disks

to be sent to you.

This will alleviate the problems you are experiencing.

Please note, all future technical support inquiries should be directed to

your local distributor. Contact information can be found at the following

location:

http://www.nemetschek.net/international/index.php

Respectfully,

Katie Roberts

Senior Tech Support Specialist

Nemetschek North America

(410) 290-5114

katie@nemetschek.net

www.nemetschek.net

My reply to Katie:

Katie

Thanks for your reply. I have asked Megabits to supply me with a 12.0.1 installation disk.

However.....I have managed to d/l and install 12.0.1 without problem. This despite only having a dial-up connection.

BUT I can't successfully install the SketchUp plug-in. Why?

If I find out I can't successfully install the SketchUp plug-in, even with a 12.0.1 install disk where do I go from there?

Don

Share this post


Link to post
  • 0

Don - have you tried editing the workspace to add 'Import SketchUp..." to your workspace under File / Import.

THe VAANZ Architect workspace does not automatically include the Import SketchUP command because it came afterwards. You need to add it yourself.

Share this post


Link to post
  • 0

Don - I have emailed you the plug-in at the address above.

Put it in the VW 12 plug-ins folder and the add it to your workspace under File / Import...

Share this post


Link to post
  • 0

I received my 12.0.1 updater CD from Megabits today. In fact it wasn't an updater. It was the full version of 12.0.1. Installed everything just fine even with the SketchUp Import PIO ready installed in Workspaces.

For those of you having problems with the updating to 12.0.1 via downloads, I recommend strongly that you you get the 12.0.1 installer CD.

Thanks to all, and including Katie of course, for your advice and assistance.

Don

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...