Jump to content

Empty Texture Files


Recommended Posts


I'm using VW 10.5 w/ updated renderworks/spotlight (educational version). All of my texture files (gobos and the like) come up as empty files.

example: GAM clouds.mcd - size: 9.75Mb

Upon opening the file or attempting to use it as a gobo projector nothing shows up. If I go to help>about vectorworks, it shows up as 0 objects in layers. This has been a consistent problem since originally installing vw10.1.

Am I missing something?


Link to comment

If you open the gobo library file, you won't see anything in the drawing.

The gobo's are not placed in the file. They are merely stored as a resource in the file.

Placing an instance of the object in the library file will lead to unnecessary file size additions.

You should be able to select it from the library list in the Resource Browser and expand the textures section to see all of the gobos.

Link to comment
  • 2 weeks later...
  • Vectorworks, Inc Employee

To see the texture you will have to:

1. Use it in the Gobo Projector and render

2. Draw a 2x2 square and apply ith gobo as a texture and render.

3. Edit the texture and view the image preview.

4. Look at the manufacture's website or catalog. All of the images for the gobos are provided to Nemetschek directly from the manufacture.

Link to comment

I'm having a similar problem. I am using 10.1.2 eduacational version. I have my design open and I am trying to add a gobo projector with a break-up.

When i insert a gobo projector, the only 'gobos' it lets me choose are the textures (paint elevations) that I've created for my scenic elements.

On the resource browser I went to Files and Folders- add new files and folders. I added the .MCD files that contained the gobos as resources.

"I can go to favorites and find these gobos, but they don't have thumbnails (even in thumbnail view), and I have no clues as to how to get them into a projector.

I read the help file about 100 times, and found it to be realitivly undetailed.

Any help would be appreciated.

Link to comment
  • Vectorworks, Inc Employee

First you must import the texture into the active document. (You won't see the preview thumnail because a bug in the conversion process)

Once you have imported the texture either enter the name of the texture in the Gobo 1 or Gobo 2 Field of the Gobo Projector, or click on the existing gobo projector with the gobo projector tool active to bring up a dialog and choose the texture from the list.

Set your view and then render with final quality Renderworks using the settings in the manual.

Link to comment

When I do this all I get is a white spotlight without a gobo in it.

Also, I don't see a place where I can type the name of a patten...

It has a pull down box when I first create the projector, but in the object info pallate, it has nothing about gobos.

Will there be a patch released to fix the preview bug? it would be nice to not have to use an external catolog for gobo selections.



Link to comment

Ok I figured out where you can type the gobo name to render... but it still isn't rendering them.

I have 3D objects that are textured, with various other textures i have created using the "create new resource/ renderworks texture" option.

If i try to change the texture of these objects to the texture of one of the gobos, it just turns a solid color (the color i have selected in the attributes pallate)

It appears as if the gobo "textures" aren't really textures, or I'm importing them wrong or something.

Any ideas?

Link to comment
  • Vectorworks, Inc Employee

A Gobo texture is a special texture. The only way to to create a gobo texture is from an image. If you have an image, bitmap, jpeg, gif etc, use the create gobo texture command. If you have existing geometry that you want to make into a gobo texture you will need to export it as an image then create the gobo.

There may be other ways to create a transparent texture, but this is the easiest. Your final scaled image should be 2"x2"

Link to comment
  • 2 weeks later...

There is definatly something wrong with the gobo libraary.

All of the files are blank, in the resource browser, blank in the 'add texture' preview, and blank when projected.

I add a texture by right clicking on it in the resource browser, and I select 'new resource in EDI.mcd'

I click ok on the preview window (which is also blank).

It adds the resource.

Using the gobo projector tool, I add a projector with a hight of 15', and an angle of 19 deg. I choose a gobo from the 'gobo one' drop down menu, and click ok.

I render it, using Renderworks, and I can see the pool of light cast by the gobo projector.

There is no gobo projected, however.

I need a copy of the gobo library, that acctually contains the gobos...

Am I doing something wrong?

I am starting to get woried because my project is due in about 14 days, and the gobos are critical to my design.


Nick M. Rahl

Link to comment

Perhaps the problem lies in the gobo projector...

I can't get the gobo projector to project anything other than an empty pool of light (no different than a standard light object). I tried importing pictures and projecting them, as well as creating a 2" by 2" texture in adobe illustrator and trying it. No luck.

I am also having difficulties getting non-MCD textures (imported picture files) to render on extruded objects. The only time they show up is when I set the mapping to sphere, which warps it beyond recognition.

Any help would be appreciated,


Link to comment

The preview image of the thumbnails for the gobo's is a bug, however the gobos do work.

To make the preview of the gobo appear properly in the thumbnail image in the RB, import the gobo into your drawing. Select the drawing you are working in from the drop down box at the top of the RB. Right click or option click on the gobo and select Edit. In the Edit Textures dialog box, change the Obj Size value from 4" to 2" under the Preview options section of the dialog (lower right corner). Also, change the Obj Type from Plane to either sphere or cube. Click OK. The preview should now show properly. To change this for all the gobo's, you'll need to open the gobo libary file and edit each gobo that is not showing any thumbnail image in the RB.

As for them not showing when using the gobo projector tool in association wtih a light, there should not be a problem. To further investigate, please answer the following questions.

What specific gobo and gobo library file are you working with that is not working?

Please include the version of VW and Operating system as well.

Link to comment

I'm still not sure how the importing textures works...

The gobo libraries are in .MCD format and are labled as brand and category, for example "Apollo Breakups 1000s".

When I open this file, in the files' resources window, I can see the different individual gobos (with a box with an "X" instead of a preview).

When I want to import a gobo, do I import the file with the gobo that I want, into my already existing file?

I don't understand how to import textures.

All of the files that contain gobos appear in the RB under "favorites".

When I right click on one of the textures in these files I can choose:

"new resource in test..."


"new new renderworks texture in test..."

(Test Is the name of the document)

Do I want to choose one of these options to import it?



My OS is Win XP Pro, and I am running

VW Spotlight, 10.5.0

[ 10-06-2003, 04:27 PM: Message edited by: lightnb ]

Link to comment

To use a texture or gobo in a document it first needs to be imported into your working document. THis is true for any resource - symbols, pre-made worksheets, hatches, etc.

Select the file containing a gobo you wish you to use from the Favorites list in the Resource Browser.

In the large white box, select the gobo you wish to use.

Right click (if you have a two button mouse, otherwise Control+Click) and select IMPORT.

This will import this resource into your current open document.

To EDIT this item, the docuemnt you are working in needs to be selected from the Open Files.

Click on the drop down box at the top of the Resource Browser, scroll all the way to the top where you see Open Files. THis will be in gray.

Select the file you are working on.

You should see the gobo you just imported listed somewhere below in the large white area.

To edit this following the steps outlined in the previous post, you'll need to scroll down to the gobo and right click or control click on the gobo and select EDIT.

Then follow the steps for editing the texture as described in earlier post.

You are getting the new resource in * becuase you are not clicking on the gobo, you are clicking in an open area.

Try to click on the name so it's highlighted.

Link to comment

Yes, the cube is how it's going to look. As I said earlier, you can use sphere or cube. If you want a head on view of the cube - switch to a front, right or left view, then edit the texture (right click in the RB and select edit) and click on Exit symbol.

The view will now be switched to a front view of the cube.

As for the gobo's not rendering -

Do you have the light pointing in a direction so that the gobo can reflect off an existing object?

For example - the floor will project the gobo if it's big enough, and the light with the gobo attached to it is pointing towards the floor and is far enough away.

Link to comment

I have an extruded rectangle as the floor. the light is hung 15 feet up and has a beam angle or 26 degrees.

The light is showing up as a hard edged pool, on the floor. I just can't see the gobo in it.

I am running the educational version, if it makes a difference. I think the other guy who was having this problem was running it as well.

Nick M. Rahl

Link to comment

When I use Fast Renderworks, I get hard edged pools of light.

When I use Final Quality Renderworks, the pools of light go away.

When I use Custom, I don't see the pools either.

My custom options is set to all options checked.

I tried with both mapped, and ray-traced shadows.

Link to comment

I think the problem is more program specific than a problem with the file.

I have my main document that i couldn't get it to work in originally, and then I created a test file that has only a gobo projector, and an extruded rectangle as the floor. It doesn?t work in the test file either, so either there is a bug in VW Student Edition, or I am doing something wrong.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...