Jump to content
  • 0
Sign in to follow this  
Johncfs

Windows XP Pro SP2 Dongle Problems

Question

I just recently did a clean install of Win XP Pro SP2 on a new computer I built, installed Vectorworks 10.5.1 and let Windows Update find the most recent driver for my dongle.

Now when I start VW it gives me a 'Vectorworks requires that up-to-date dongle drivers be installed. Please install the drivers and relaunch Vectorworks'

I attempted a re-install of VW, downloaded and attempted the isntall the dongle drivers from www.ealaddin.com, but keep getting a installation crash (the same crash that plauged the HASP drivers when XP was first released)

Even stranger is an [Confused] install of VW on my labtop was fine, (Win XP Home SP1)

Is the HASP Dongle Drivers and/or VW incompatible with SP2? Could it be a USB problem?

Share this post


Link to post

Recommended Posts

  • 0
Guest

I spoke with a gentleman at Aladdin tech support yesterday. He advised I gather the following information for both of you. Please send the information to follow to my email address. Please be sure you include a note in the email including a brief description of the problem.

Event View Report(s) for the application and system

Detailed system information file

I will then send the information to my contact in order to allow their engineers to further look into this issue.

Share this post


Link to post
  • 0

Hi everyone,

I haven't actually read the whole thread,

and I don't know whether you guys are talking

about the same problems I'm facing,

but I experienced some kind of the same problem

as described in the first post.

I also installed a new clean version of Windows

XP Pro SP2. I am trying to install a USB Dongle,

indicated by Windows as "Hardlock 1.02",

using also the HASP Drivers by Aladdin.

So maybe it doesn't exactly match your problems.

If that's the case, sorry about bothering you.

I couldn't find anyone talking about the version

of th HASP HL Driver....

Well, maybe I overlooked some posts ...

Anyway, I was using version 4.95

since I was thinking this was the newest

version awailable at ealaddin.com.

But I found a newer version today: 5.11

This solved my problem completely!

So, just as a suggestion, try downloading

version 5.11, dated "09/2004" from the ealaddin

site. Maybe it will work with your problem, too.

Site:

http://www.ealaddin.com/support/hasp/enduser.asp

Direct link:

ftp://ftp.ealaddin.com/pub/hasp/hl/windows/installed/redistribute/drivers/HASP_User_Setup.zip

Good luck,

Tom

[ 09-16-2004, 11:46 AM: Message edited by: lachs99 ]

Share this post


Link to post
  • 0

Tom, thanks for the info. When I saw the date of the post I hoped that Alladdin had updated the driver but, altho' file dates and sizes are different these are the same SP2-compliant drivers isued earlier (and which I have tried).

The latest file is dated 27th August whereas the earlier one is 16th August - perhaps just the GUI interface difference.

Unfortunately for me the later driver file does not solve my Standby STOP error

Thanks anyway

Eric

Share this post


Link to post
  • 0
Guest

Aladdin is investigating the problem still.

As soon as I hear information from them, I will pass it forward.

Share this post


Link to post
  • 0

Kate, Aladdin, Vectorworks,

Is there any sign of a solution to my dongle problem ? I have been waiting now for over a week without any communication from concerned parties.

An email direct to Aladdin has produced no response whatsoever, likewise with Nemetschek, as wewll as this board - does anyone care enough to deal with this and keep me informed?

The whole episode raises serious concerns over the depth and value of support offered when purchasing Vectorworks.

Eric

Share this post


Link to post
  • 0

Katie,

Thank you for that reassurance. It is now a week on and I am hoping that Aladdin are near to or have a solution.

Otherwise, regretfully, I would request your advice as to how I may return this faulty product for a refund.

Eric

Share this post


Link to post
  • 0
Guest

FYI -

There have been many other software products experiencing this same problem. Aladdin is looking into all the cases and investigating them in order to resolve the problem as fast as possible.

They ask for your patience while they determine the source of the problem.

Share this post


Link to post
  • 0

HAPPY 50Th ANNIVERSARY

It is now 50 days since I reported this problem to Nemetschek.

Sadly no solution has been offered, and contact has been minimal. Emails to Nemetschek Technical Support have been totally ignored. I am forced to copnclude that Nemetschek do not care about a problem which probably only affects a small number of users.

This leaves only one course of action - Nemetschek, please advise me of procedures to return this defective product to you for a full refund.

I hope that this can be accomplished easily otherwise, regrettably, matters would have to be taken further, fully publicised, and probably end up in court.

in some sadness

Eric

Share this post


Link to post
  • 0

Katie

Would you please advise the incident reference you have from Aladdin, concerning your report of my Standby STOP error to them

thank you

Eric

Share this post


Link to post
  • 0

As a footnote to this thread I have had dongle problems in sleep mode and according to Tech Support at Aladdin this is nothing to do with them.

I have been told how the dongle, the operating system and Vectorworks interacts is down to how Nemetschek write the software to do this. Aladdin involvement stops at providing hardware and a driver to write to.

Hope this is sorted soon.

Share this post


Link to post
  • 0
Guest

FROM ALADDIN:

You can try to download and install a different

driver from here: http://www.ealaddin.com/support/hasp/vendor.asp#latestDD

This is version 1.8, that was released with HASP HL and is fully compatible

with HASP4.

Alan -

As you can see from Aladdin, they do summise the problem is with the dongle driver. There are also a number of other programs that have reported this problem to Aladdin. This is not a VectorWorks problem. The sleep mode of the OS has nothing to do with VectorWorks and vice versa. The problem is between the dongle driver and the Operating System. I am surprised that Aladdin told you otherwise. I have been in clear contact with them and they have not only noted to me that it's a problem with the dongle drivers and SP2, but other programs that supply dongles as their software protection have reported users experiecing the same problem outside of their software.

Share this post


Link to post
  • 0

Hi Katie

I in turn am surprised to hear you say that it's not a Vectorworks problem, from what I've been told.

Sorry, don't see anything on the page about the "summise the problem is with the dongle driver". Can you show me link please.

This could run on and on with us, the poor user, stuck in the middle with both companies bouncing us back and forth!!

Please note, I have not and do not intend to load Service Pack 2, so any inference that this is related to installing that can be completely discounted.

I can only repeat what I was told to me when I telephoned Aladdin UK Tech Support. How the program communicates with the dongle is down to how the software is written to communicate with the drivers, as in Vectorworks, written by you. They supply the hardware and the drivers, the hooks as he described it, for the software to write to.

I was also told that they have hundreds of companies using this with no problems.

I repeat I'm using Windows XP with only Service Pack 1 installed. All my other programs work fine and apart from this dongle issue it appears so does Vectorworks.

Let me make on thing clear please-

I'm not in a position, and would not wish to claim you are not telling the truth, but clearly not only is somebody not doing so, we the end user, are having to put up with the end result whoever it is.

I can see that the site you mentioned has new files on its pages.

Do they relate to SP2 issues and/or VW 11? because I'm running 10.5.1 and at the suggestion of your Tech Support,with replacement drivers downloaded last week. Not these ones.

I've also been told no such problems occur in VW11 with one of the suggestions being to upgrade. Tech Support has said you are working on VW11 now and as such no further upgrades patches etc are likely at all for VW10.

I have, for my part, reconciled myself with the fact this problem will not be cured and have to make do with whatever solution I can implement of my own.

As for my 100% confidence in Vectorworks or upgrading, that I'm afraid unless presented in a very advantageous way, is not going to be forthcoming.

Disappointed.

Alan

Share this post


Link to post
  • 0
Guest

Alan,

I'm sorry you are getting different answers from different people. I have spoken personally with engineers at Aladdin and they have noted that the problem is in the dongle driver, not our software.

There are also other companies that use dongles and their users report the same problem when the computer is put to sleep. I've had these users communicate to me directly and Aladdin has directly told me there are other users outside of VW users that have this problem

This also happens outside of the software - the program using the dongle is closed prior to the user putting the computer to sleep.

Logically, it makes sense that it's not communication between the application and the dongle causing this problem because as soon as a program is closed, communication between the dongle and the application is broken.

My suggestion to you is to try and install the driver as mentioned in my previous post. I don't know if it will work or not because I can't duplicate the problem at work, but this is the recommendation from the aladdin engineer I spoke with. Until you try this, I don't have much more information to take to Aladdin to help them diagnose the problem.

Share this post


Link to post
  • 0

Katie,

I am glad to see that you keep an eye on this thread. However, I would be grateful for a reply to my post of 28th Octob4er in which I asked you for the incident reference you have from Aladdin re your original report to them. Th reason I ask for this is that Aladdin in the UK can not trace your report until they have this reference.

I would therefore appreciate it if you would give me this information.

Eric

Share this post


Link to post
  • 0
Guest

Eric -

Have you tried the download I mentioned in a post above?

Share this post


Link to post
  • 0
Guest

All of the Win32 downloads are ones you can download. These are the same date as the other site, but they are for a different type of dongle, thus the software is a little different.

With this said, Aladdin has confirmed that the Hasp HL driver will work with the Hasp 4 Dongle.

Share this post


Link to post
  • 0

Katie,

It seems that the 1.8 version is Mac, I am PC-based and the drivers listed all seem to be the same 5.11 released at the end of September, unless you can tell me otherwise.

Eric

Share this post


Link to post
  • 0

Katie,

I have tried all drivers available from Aladdin and still get the Standby BSOD. It is clear that, after all this time (nearly 3 months), neither Nemetschek nor Aladdin are interested in resolving this problem.

I would therefore formally request a refund of my purchase price for this software as it is unusable on my machine.

Eric

Share this post


Link to post
  • 0
Guest

Eric,

You will need to contact your local distributor regarding a refund.

We have been more than enthusiastic in regards to solving your problem. We have been working closely with Aladdin so they can offer you a resolution to the problem.

I wasn't aware that the latest suggestion from Aladdin did not resolve the problem until just now. It's been 20 days since I posted that suggestion. I am out of the office today, but tomorrow when I get back, I will contact Aladdin and let them know.

As I have said numerous times before in email and on the board, the problem is not a VW problem. It's a problem between the dongle and the OS. The problem occurs outside of VW, and there is a viable workaround. Should you choose to return the product, that is your perogative. You will need to contact Computers Unlimited in regards to the problem. If they have any questions about your situation regarding the technical issue, they can contact me - the tech dept has my contact information.

Share this post


Link to post
  • 0

PLEASE NNA, GET RID OF THE DONGLES!!!!!

Drop aladdin and concentrate on the great produce which Vectorworks clearly is.

I've been experiencing numerous problems with these annoying red glowing devices and had hoped we'd be able to sort them out. However, having read the above threads, I'm kinda convinced this is going to persist into the future. We are already looking at alternatives to Vectorworks for our practice (which is a real shame as we love the programme) and it looks like we'll not be sticking with it...

Share this post


Link to post
  • 0

I tried just about every link in this string to get the same problem fixed. Only the link posted by scoob (Paul) worked properly.

Thanks Paul! You saved my job.

Share this post


Link to post
  • 0

If you are a laptop user and mobile like I am a dongle is an absolute frigging disaster. A constant risk of loss or damage!

There has to be a better way!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...