Jump to content
  • 0
Sign in to follow this  
Joe Schum...

OS 10.3.8 Vectorworks 11 Printing Vanishes Solution

Question

Vectorworks 11 Printing problem.

A drawing sent to the printer produces no output. It just seams to vanish into thin air.

We have 3 computers as well as a Server all connected via a network.

We share the same HP Laserjet 3700 printer and HP 800 plotter.

2 computers are G4's and 1 is a G5. The computers are networked and the drawing resides on the OS 10 file server.

The 2 g4's have no trouble printing any drawing. The drawing that I will use for this problem reporting is 700 kbytes in size. In the page setup it is reduced to 12% and set to landscape so that it will fit on an 8.5 by 11 sheet of paper.

The G4's have 512 megs of ram and are running OS 10.3.7

The G5 has 1.5 gigs of ram and is running OS 10.3.8

Vectorworks is version 11.

These are the detailed steps of the problem.

On the G5, I opened this drawing and printed. The print disappears into thin air.

On the G4, I opened this drawing and printed and it printed fine. Remember this is the same file that we are loading from the server.

On the G5 I try several files with the same problem which is no printout.

For the remainder of my troubleshooting, I used the 700 kbyte file.

I open the print dialog and save to PDF. Open the PDF and that prints.

I tried printing using the raster option but cancelled the job after 5 minutes because I had no idea how long it was going to take to print and they are paying me by the hour. Remember the G4's have no trouble printing the same file and they were using the postscript setting.

Next, I saved the printed output as a postscript file. Drag and drop onto the printer icon and that printed.

Next, I did a preview prior to printing and printed from the preview's print button and that printed.

Next, I changed the scale back to 100% and then printed page 1 to 1 and that printed, of course that was just one corner of the drawing. I changed the setting back to 12%.

I took the working G4 and put it into target mode and connected it to the G5. Had the G5 boot from the target mode G4 so that the G5 was running from the G4's system and that printed just fine.

Next, I removed the client's hard drive and installed a new one.

Then I cloned the G4's complete drive to the G5 and then removed the G4. Booted the G5 and that printed fine. We could have left it this way but we would not know the reason why and this could fail later on.

These are the steps:

Partitioned new drive as 1 partition.

Install OS 10.3.5 on hard drive from the cd using minimum settings.

Did not do any software updates.

Install Latest HP 3700 printer files.

Added HP to printer list.

Copied over test drawing from server.

Unmounted all other volumes.

Installed vectorworks 11 complete.

Opened my test file. The test file complained that it was missing 4 fonts and did I want to remap them, but I ignored the error message. It printed okay.

I quit vectorworks.

Next, I installed the complete font library from client's server, tried another test print. That test print failed with no print activity.

I removed the fonts that I installed and tried a print and that printed okay. So the problem is font related. I copied the complete font library from the working G4 and tried a print and that printed.

I reinstalled the original hard drive in the G5, trashed all the fonts and copied all the fonts from the G4 and tried printing and that printed fine.

Through a process of trial and error I found what must be a bad font that caused the problem. This font was the Graphics font that my client uses.

That explains why none of the other applications had problems printing. They were not using the Graphics font.

What I can't explain is why did the file print when it was saved as a postscript file and then drag and drop the file onto the printer.

I compared this Graphics font that was on the server with the one that was on the G4 and they look the same.

This only took me 8 hours to solve and a price tag of 680.00 for my client. I think the turning point was booting the G5 using the G4 hard drive in target mode to isolate problem to software, then installing a fresh system and not do any updates or add anything else. Confirming it works and then test after each change made.

Throughout this ordeal, I made a call to vectorworks help line and was told to make sure we had all the latest drivers and to use raster setting for print. This was not an acceptable solution since the G4's had no problems and raster printing is soooo sloooow.

My next phone call was to Apple, although I did not expect they could do much but provide another opinion. They did suggest the G4 target mode to boot from and that part worked as mentioned earlier.

Once, I determined the fault, then is was a simple fix to the client's original drive.

I hope this helps someone out there.

Joe Schumacher

caldraft

New World Electronics Ltd.

Edmonton, Alberta

Share this post


Link to post

1 answer to this question

Recommended Posts

  • 0
Guest

When you print to a printer, the fonts get downloaded to the printer. When you simply create a file, the fonts are not downloaded, hence the reason it worked.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...