Jump to content
  • 0
Sign in to follow this  
Yovav

Condensed text printing problems

Question

Since upgrading to VW 9.x and 10.x a new print problem jump into my life - some plots got all the text messed up. In the effected prints it seems that the spaces between the characters got a negative value. Characters are printed one over the other with overlap. A line that should be 5 cm long is condensed into 1.5 cm.

Strange? Wait to the random factor. Since upgrading from VW 8.x this problem started to happen in different files and different sheets, inside the same file. Just yesterday I've printed 35 sheets from the same file, 33 where printed correct 2 of them returned from the print shop with the condensed lines.

The weird fact is yet to come: the fix for those 2 problematic prints was amazingly easy - just print them again. I didn't change any font, size or attribute regarding those texts. I didn't change anything in other parts of the drawing. I didn't change any of the preferences of the printer driver.

I know it sounds really bad, but I'm holding this post for 2 months just to get the regularity of this problem. Until know nothing. What I know are those facts:

1. It happened on HP plotters (1050 series, with different drivers used to print the files) positioned in print shops and on my office Epson 1520, connected directly to the net.

2. It happened on 9.X and 10.X. never on 8.X.

3. It happened on some sheets in a document while others where printed OK

4. It happened on different computers.

5. It happened with different fonts, sizes etc, and even on different languages.

6. I'm using XP System with 256 MB RAM.

7. It can take 30 to 40 plots that are going fine, and then suddenly the ghost awakes and I get the plots from the shop, with the condensed text.

8. Dimensions, call-outs, and text inside symbol or groups, are effected in the same way.

9. This problem is line oriented - the condensation effect, in paragraphs of text, is taking only the spaces inside the line (between characters, and words), but do not effect the correct spaces between the lines.

Some one saw this one? Some one knows how to deal with it?

Share this post


Link to post

Recommended Posts

  • 0
Guest

The only known way to fix this consistantly is to print it a second time.

Of course, that's not the answer you wanted to hear.

We are currently looking into what is causing this problem. We see it on a number of printers that use the same exact print driver for a wide variety of formats. Those formats being HP GL/2, RTL and PS. yes, there are some drivers out there that are designed to build in settings for each of the three mentioned print languages in one single driver.

These are the drivers we are having the problem with.

The bug is currently bug listed and given a high priority level.

Share this post


Link to post
  • 0

I have the same thing here: HP 430 (driver v. 4.61), Win XP. Unnerving, but the second print has always been fine so far. Others have written NNA about the same thing. One option, to process the plot in the computer instead of the plotter (an option under "print" or "print setup") produced a positive effect as I recall, and was no slower. Lines were lighter though. I can't remember though if it absolutely solved the problem. The other theory proposed was memory issues. Oddly though the problem occurred in some pretty simple files.

That's all I know..

- Carl

Share this post


Link to post
  • 0
Guest

It's a memory problem on board the RIP we think. Maybe VW is sending the information incorrectly and the RIP doesn't know how to get rid of it.

I have no idea at this point in time.

Like I said, it's a high priority to try and workaround this issue. I have no expected date as to when it will be resolved or worked around.

Carl -- You should be using version 4.62 on the HP website. That should fix a few other printing problems and possibly this one as well for that printer.

Go to Hp.com and click on drivers and downloads. Type in the model and select the OS. Version 4.62 was released in Oct 2002.

Share this post


Link to post
  • 0
Guest

One more point.

Sometimes, restarting the printer by turning it off and leaving off for a minute or two then turning it back on will resolve this problem also.

Share this post


Link to post
  • 0

Katie:

I have experienced same problem w/ my HP430 occasionally. I do not believe that it is a memory issue - I have the max 36MB installed in my printer & am using driver 4.62. Problem has occurred in VW 9.5.2, most often on sheets with Worksheets (schedules). Have not done much plotting yet with 10.0.1., but so far so good!

Windows XP Home

P4 2.23

512 RAM

Share this post


Link to post
  • 0

Sorry to disappoint you Carl, but the problem occurs also when you check the "in computer" radio button.

All of you are referring to HP drivers and plotters; let me remind you that I got the same on my Epson Stylus color 1520 - a simple old A2 printer that uses totally different driver.

Until Katie will announce the savior fix for the problem the only work around I can think of is a decent viewer for HP print files. Does any one know about such a product? Does HP supply such viewer (in older drivers they had a preview option, in a window opening during the print process, so it shouldn't be so complicated)?

Share this post


Link to post
  • 0
Guest

I've been on the prowl for a good GhostScript printing utility to allow for these printers to print for OS 9 and or Windows users.

OS 10 users have the option for using Gimp Print.

When I find a useful one, I'll let you know. I've been trying a few different ones, but so far, nothing amazing has been found.

I would be curious if you created a PS file in VW and then used the command line (windows) to send the files to the printer if that makes any difference.

If you don't know how to send files to a printer thru the command line, here's how:

In VW print dialog box, select Print to File in the upper right hand corner (Post Script printers only).

Click on OK or Save in the lower right hand corner and save the file to a path name you can remember (and type) easily such as c:\filename.ps.

(Make sure you add the .ps to the end of the file).

Launch the MS DOS command line thru the Start menu.

Type

copy "[filename including full path and .ps]" "[full path including network path and name of printer as it appears on the network]"

hit enter

It's important to put the "" around both sets of paths. Leave out the [] and include a space between the file name end quotes and the printer path begin quotes.

That command will copy the saved file to the printer forcing the printer to process the print job.

If this makes a positive or negative affect, I'd be curious to know.

Share this post


Link to post
  • 0

Since there is no real fix for that annoying problem, coming from NNA, the best non-real fix is a soft called CAD Viewer 3.2. This is viewing software that can open several CAD formats, including HP/GL files.

I'm using it to check the files I'm sending to the print shop, to find out if the text is condensed or not.

Their WEB address is: www.guthcad.com.au

Of course this is not a real solution, and it costs extra money, but that the best I have now.

Share this post


Link to post
  • 0
Guest

A known problem that causes this is corrupted fonts.

If you eliminate any bad, unsupported or corrupted fonts, this problem should disappear.

Share this post


Link to post
  • 0
Guest

VW won't fix corrupted fonts if that is what is causing the problem.

If there is not enough memory in the computer, and the plot is large, VW can't fix that problem either.

If you are getting the scrunching of fonts on the drawing or in the worksheet when printing, it is probably related to a bad or corrupted or out of date font. Resolving the font problem will fix the problem.

Share this post


Link to post
  • 0

Hello Katie

I don't think I'm dealing with corrupted fonts. I think so because printing from a 3 layers document worked fine for 2 of them, and corrupted the 3rd. The same fonts where used all over the document.

Just today I've sent the same plot to the service bureau 5 times. All of those plots came back with the condensed text. The mentioned VW 10 Document contains 3 sheets, describing 3 floors of a simple house. The file is smaller than 5 MB, and got just 2d stuff inside.

As mentioned, 2 layers were printed fine in the first shot. The 3rd gave me the troubles. After the 2nd try to print it I've deleted all the text from the problematic layer, copy the text from one of the printable layers (just titles to the page), edit them, and resend it to the service bureau. Bad results again.

The next time I've opened a new blank document and copy/paste the problematic layer into it. Bad results again.

At this stage I tried another HP Driver (went from 1055CM to 1050c). Bad results again.

Since the day was about to finish I left my pride, exported it to VW 8.5, printed it from there and everything was OK (if you can call "OK" spending almost 3 hours on installing drivers, sending 5 e-mails, talking over the phone with bureau, using 3 years old software, and all of that just to print a simple A3 page).

I'm using 10.0.1, On XP, got 256MB of RAM, printing with up-to-date HP 10xx drivers, and going insane. By the way, when I print the file to my Epson Stylus Color 1520 everything is working fine.

And last but no least: what is the definition for "corrupted font"? How can I check which font is corrupted? If those fonts are printed fine in others software, or in others VW documents, can they be corrupted? Is it possible that Microsoft's built in "Arial Unicode MS" could give me that kind of troubles?

Share this post


Link to post
  • 0
Guest

A font can become corrupted with no explaination at all. Generally it's non-system fonts that have problems with becoming corrupt.

Tracking down a corrupt font is difficult.

Basicall, taking out all the non-system standard fonts and then restart the computer. Place the removed fonts in a folder on the desktop temporarily.

If the drawing prints fine, then the problem is with one of the fonts that is in that folder on the desktop.

Generally, placing these fonts back in the fonts folder and restarting the computer will fix any corruption. Although, some fonts need to be re-downloaded and installed to get rid of the corruption.

Corrupted fonts is a fairly common problem on Macs more often than PCs, but cannot be completely ruled on on the PC end. I've seen many PC users have this problem. Once they tried the above steps, the files print fine.

Usually if you are not using a standard OS font, the printer will download the font to print it. If a font is bad and the printer downloads this font, then the text will print out shaky at best.

This can happen in only one file using a specific font(s), or many files. It's a strange behavior to track.

This problem is still in the air over a computer specific problem, VW or printer specific. Since you say you can print to the other printer fine, it's probably not VW causing the problem .. but could still be.

Comparing Vw 10 to Vw 8 is not exactly a fair comparison. VW 8 was a 32bit application where VW 9 and 10 are 64bit applications. It's like comparing apples to cucumbers. Completely different code and bit combination.

Comparing VW to something like Word or PhotoShop or AutoCad isn't going to give you anything to go with either. All of these applications have different behavior and the way objects/text is treated. VW is an exclusive application compared to the others with the exception of AutoCad in that it is a vector program. AC is also, but that's a night and day difference.

Question -

Is the bunching happening in only worksheets or text in the drawing and worksheets?

Does this happen in all files?

Does this happen in new,blank files or only in files converted from an earlier version to the current version?

Which arial font are you using?

Are you only using arial fonts in your files, or do you have multiple fonts in each file?

Can you print text with a different font and have it print out correctly?

What is the make and model of the printer you are printing to? (I never saw the exact model you are printing to other than trying different drivers.)

Are other computers in the office having the same issues with this printer?

If you don't have the plotter there to run test prints, you can email a file or two to me and I can further look into here.

tech@nemetschek.net

attn: Katie in the subject line.

Share this post


Link to post
  • 0

Hello Katie

Thanks for your replay, sorry for my delay. Here are some answers for your questions:

Is the bunching happening in only worksheets or text in the drawing and worksheets?

If I understand your Q correctly the problems is not connected to worksheets. I got basic documents with no worksheets, just 2 or 3 layers, and I got the problems with them also.

Does this happen in all files?

No. Some files plot OK, some don't. Some times a document prints OK, and after a few days, and few changes made in it, it gives me corrupted plots. All Of those documents are using the same fonts.

Does this happen in new,blank files or only in files converted from an earlier version to the current version?

It happened in both situations ? blank new documents, and old one coming from 9.x, and changed by 10.x

Which arial font are you using?

I'm usually using simple "Arial", but since the problems started I?m tried to use only "Arial Unicode MS", since this is a regular font coming with the Operating system. I'm using those fonts mostly with Hebrew Text and also some local fonts called David, Gutman Haim and others, but I don?t believe the names of those local fonts will give you some hints?

Are you only using arial fonts in your files, or do you have multiple fonts in each file?

I'm using multiple fonts. During the tests I've done I tried using Only "Arial Unicode MS", but it didn't solve the problem.

Can you print text with a different font and have it print out correctly?

As mentioned above ? no, changing the font doesn't solve the problem.

What is the make and model of the printer you are printing to? (I never saw the exact model you are printing to other than trying different drivers.)

I'm printing to HP 1055CM plotter located outside of my office, in a print shop, using print to file option.

Are other computers in the office having the same issues with this printer?

Yes. We are using 2 computers and both of them are having the same random symptoms.

And last questions, from me to you this time: since I'm printing mostly Hebrew Text should I set something especially in the system? Maybe something in the "regional and language options" control panel?

Since I'm writing from home, I'll send you a problematic file when I get to my office.

Thanks Katie, hope you'll think of something because I'm running out of ideas?

Share this post


Link to post
  • 0
Guest

Okay ..

Is the Opearting System an english Operating System and you are using the Hebrew keyboard settings?

Share this post


Link to post
  • 0

Yes, I'm using English versions of XP Home and XP pro.

The "regional and languages options" control panel is set to:

"Regional options" tab > standards and formats > Hebrew.

"Languages" tab > details > text services and input languages > English US

"Advanced" tab > languages for non Unicode programs > Hebrew

In the past I tried changing almost every parameter in this control panel, but it didn't solved the problem.

Share this post


Link to post
  • 0
Guest

Yovav,

Is Hebrew text written left to right or right to left?

Also, can you send in a file with this problem along with the fonts being used ?

I am going to have an engineer look into the problem further along with the fonts and character set in the OS for Hebrew.

Please put a link to this page in the body of the email.

tech@nemetschek.net?subject=ATTN:Katie

Share this post


Link to post
  • 0

Hi Katie

Our company has had all the above mentioned issues since upgrading from 8.5.2 to 10.1 Architect.

The language setting is configured for English(New Zealand)-US on all machines. US Keyboard.

10 PCs- Windows 2K + XP pro PCs

P3 766- P4 2.3

256- 512 RAM

Plotter- HP 750C Plus with HPGL 4.63 driver

Standard drawing font- Arial Narrow.

The fault is intermittent across all the machines. Typically the first print will fail (ie condensed font, turns all line weights to 0.10, turns dashed line styles to standard lines).The next print is usually perfect but not always.

On the failed prints, there is some text and line types (approx.10 percent) that prints normally. Line weights however have always changed to 0.10 on these failed prints.

This ritual happens on a daily basis, with a +/-10 percent failure rate.

Please help.

Share this post


Link to post
  • 0
Guest

Update to VW 10.1.2. That should fix the problem.

Share this post


Link to post
  • 0

Upgrading to 10.1.2 hasn't solved any of the printing issues. I had to print 8 times this morning before I could hand my client a corrected floor plan.

Windows 2000

HP 500

VW 101.2

Share this post


Link to post
  • 0
Guest

HJ,

Your problem may be related to having PoolSmart turned on, according to HP.

They've been able to reproduce some of the problems encountered in VW when printing to the HP 500/800 family of printers, 100 and 120 from WIndows.

The link below describes how to turn POolsmart off for the 100 and 120, and is the same for the 500 and 800 and other printers.

Try it to see if it helps.

If you have problems with the procedure, contact HP and they should be able to walk you thru the process.

From HP:

HP's spoolsmart feature does not handle lines drawn with a patterned pen

very well. Essentially it blanks out everything that follows in the

document. When printing to a non-PS printer, we generally don't draw

with a patterned pen. The exception is when the pen thickness is 1.

Person 1 said that, to the best of his recollection, we don't use patterned

pens because they generally didn't work, and may have caused crashes,

and that we may have allowed 1 pixel thick pens for performance reasons.

I have seen that they draw solid lines instead of patterned lines when

output is to a metafile. Person 2 said that on NT/2K/XP the print

job is spooled as a metafile (when not using spoolsmart). Thus we can

deduce that they will print solid, which I have seen.

In drawpad, our workaround for drawing with patterned pens is to fill

regions. We could alter the handling of 1 pixel thick lines to draw

with regions, or draw solid, to avoid the problems reported.

http://h20015.www2.hp.com/en/document.jhtml?lc=en&docName=bpp03857

When customers call in to our support group, it is common for HP to walk

them through this procedure.

Share this post


Link to post
  • 0

I have the same printing problems. They only appeared after upgrading to Windows XP. Don't think it is a font problem. First plot is bad and second one, with no changes, seems to work fine in most cases. Waitng for the fix.

Windows XP

VW 9.5.0

HP 350C ver 4.63

Share this post


Link to post
  • 0

I hate to make this problem sound simplistic, but I have found that if you simply close the file and re-open it, it prints fine as long as you don't edit it in any way before you plot the image. I am using Vectorworks 9.5 on XP Pro at work and this has worked every time.

Let me know if this works on other systems and versions.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...